Maps (process com.google.android.apps.maps) stoppedSupport


Last Updated:

  1. JLM

    JLM Active Member This Topic's Starter

    Joined:
    Mar 21, 2011
    Messages:
    33
    Likes Received:
    1
    I've been trying to use Google Maps, which seems to work just fine until I attempt to use the Navigate portion within it. I then get:

    'Sorry! The application Maps (process com.google.android.apps.maps) has stopped unexpectedly. Please try again.'

    Has anyone seen this recently and is there a fix? I love the system...it always worked like a charm on my Eris.

    Thanks.
     

    Advertisement
  2. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,180
    Likes Received:
    3,953
    The Navigation app is working for me. GPS and data are both enabled.

    Do you have a data connection (or Wi-Fi) so it can access the map data on the Internet for a new map section to display?

    Does the Maps app work (for an area that you have not previously displayed)?

    When I run Navigation in Airplane mode it runs-and-runs-and-runs displaying "Getting driving directions".

    ... Thom
     
  3. ErisDroid?

    ErisDroid? Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    175
    Likes Received:
    8
    You may want to try and update the map app.

    Just a thought.
     
    mary mukina likes this.
  4. JLM

    JLM Active Member This Topic's Starter

    Joined:
    Mar 21, 2011
    Messages:
    33
    Likes Received:
    1
    Well, I seem to have fixed it...or it fixed itself.

    I had rooted the phone, but not forever rooted it. I know there was a system push yesterday. Once I rebooted with the forever root, I was able to update Maps and it's now working fine.
     
  5. andrew gamal

    andrew gamal New Member

    Joined:
    Jun 13, 2012
    Messages:
    1
    Likes Received:
    1
    the same << 'Sorry! The application Maps (process com.google.android.apps.maps) has stopped unexpectedly. Please try again.'
    >> appears to me when i open MAPS ,, even my phone storage has 37.8 mb free ,, and i had my phone reboot several times ,, i can't open it
    plzzzz help me !!
     
    mary mukina likes this.
  6. Lars

    Lars Well-Known Member

    Joined:
    Mar 24, 2010
    Messages:
    1,439
    Likes Received:
    210
    go into settings applications and uninstall updates for maps and then clear it's storage. Let it update again and you should be good.
     
  7. Harakumar

    Harakumar New Member

    Joined:
    Feb 25, 2014
    Messages:
    1
    Likes Received:
    0
    pl.solve this problem
     

Share This Page

Loading...