Market Error "The requested item could not be found.", Please HelpSupport


  1. RichSz

    RichSz Not Entitled VIP Member

    Apparently the Market and I don't get along very well.

    Over the past week or so, when I try to access many of the apps in the Market through the Market app on my phone, I get the error "The requested item could not be found." These are not obscure apps which won't run on my DX but are current apps which are often already installed on the phone. For example, to get the correct error message, I tried to access Google Maps with the above result. What's weird is I got the update to GM yesterday and as long as I do an "install all", it works just fine. However, if there is a permission change, I might as well uninstall it because I can't get the update.

    I do have a history of weird Market issues. For example the web-based market does not recognize my phone, though it does recognize my rooted Nook Color.

    I've tried force closing the Market app, clearing the cache and data, uninstalling updates then restarting it without success. I've tried fixing permissions using ROM Manager. Nope. I did notice this seemed to begin about the time I installed the Amazon Appstore so I uninstalled it and tried the re-doing the Market app again. Failure.

    I figure my next move is wipe the phone and start over but I really hate to do that, it's always a pain. Is anyone seeing similar behavior? Any ideas what might be going on?

    Yes, my phone is rooted but I never played with any ROMs so it's rooted stock Froyo.

    Thanks.

    Advertisement
    :
  2. lirwin

    lirwin Member

    I have the same exact problem on my non-rooted Epic. When I click on most of My Apps from the Market, it says, "The requested item could not be found." If I conduct a search in the Market for the same app, it will allow me to open the app from the search, but not from the My Apps list in the Market. (The apps open correctly from my app drawer, so this bug does not affect the actual application.)

    I've also cleared the cache and data for the Market to no avail.
  3. RichSz

    RichSz Not Entitled VIP Member

    I think I figured it out. In the Market app go to settings. There is a content filtering pulldown. Everything in there was unchecked. I checked "Show all apps" and like magic the problem went away. I don't remember going in there before. I figure I either unchecked them all be accident or they default to off.

    Try that out and see what happens.
  4. RichSz

    RichSz Not Entitled VIP Member

    Oh, just to make sure we're on the same page, my Market version is, 2.3.4.
  5. lirwin

    lirwin Member

    I have the same version of Market (2.3.4) but do not have that option in my settings. The only item in settings is Notifications: Notify me or Do Not notify me (regarding updates). Hmmm.
  6. shonangreg

    shonangreg Member

    I've been having the same problem for a few weeks (aldiko was the first or second app for this to happen to with me). It does seem to be random as to which apps are not found. After a reboot, google maps was found whereas before it wasn't, for example.

    I have just found that while in market, a long push on an app, then selecting "update" is working every time.

    For reference:
    - Xperia X10 (Japanese version)
    - android 2.1
    - rooted with superoneclick
    - I've used "Market Enabler" but I think it was set back to the original location correctly
    - appbrain (though it wasn't used in this round of updates)
  7. daemon9

    daemon9 New Member

    I just started having this problem a few days ago. ANY apps I try to purchase on my Xoom I get the message saying "The item you were attempting to purchase could not be found". And when I try to buy any app on my PC, my device shows gray in the pull down and a mouse-over message saying "This item cannot be installed on your device". I was purchase apps with no problem before all this.

    I can't find a "Settings" button on my Market app as mentioned in the earlier post. I'm completely at a loss.
  8. hiroc13

    hiroc13 New Member

    Same problem... please help...
  9. nightmoves

    nightmoves New Member

    ok ive downloaded the apps im looking for before and now their non existing on my market? what is the solution hear? I find it kinda hard to belive my phone can't get these apps anymore when I had them before?

    phone xperia x10

    "please help"

    apps include

    word with friends
    zinga poker
    droid words
    bejewled 2
    "and countless others"
  10. Airmaxx23

    Airmaxx23 Well-Known Member

    They all show up for me except for "zinga poker", try installing and then running this Market Fixer app.
  11. nightmoves

    nightmoves New Member

    market fix did nothing went to download and it says problem phasing package or some crap any fix for this market issue I really font understand it?
  12. cmarens

    cmarens New Member

    That did the trick! Thank you very much!
  13. qbuster

    qbuster New Member

    That did it for me too. Mine was set to 'Everyone' and I reset it to 'All' and I'm back to normal.
  14. dvo

    dvo New Member

    For full access, I had to set the content filtering to "Mature", not "all". Google should be more clear on the semantics of this setting.
Loading...

Share This Page