Market hangs at Starting download

Discussion in 'Android Devices' started by JB in AZ, Jun 22, 2010.

  1. JB in AZ

    JB in AZ VIP Member
    VIP Member
    173

    Oct 27, 2009
    1,869
    267
    173
    Florida
    Yes, I know this is a duplicate post. I posted this last night in the regular Sprint HTC forum, but it may be more root related...and I thought those of you that frequent this forum may be better at coming up with the fix.

    Summary... Had to RUU back to 1.5, then re-rooted and restored back to a nandroid of ZenROM. Market has always worked fine, until after this process yesterday. I am able to search the market, it says the app will download, but never does. All my contacts are there, web works, email works, I have rebooted, restored to a different Nandroid... still hangs at starting download. Googling turns up a few responses regarding British users having their gmail adresses wrong... "googlemail" vs "gmail" but that isn't the issue here...

    One possibility...when I RUU'd back to 1.5, I MAY have accidently typed the gmail address incorrectly...(I have two that are similar except for one digit) But when I restored back to the ROM I'm using, it shows the correct address in the accounts and sync area. This is the only thing I can think of.

    Any help guys? Before I RUU again?
     

    Advertisement
  2. NYCHitman1

    NYCHitman1 Gun for Hire
    343

    Oct 16, 2009
    6,537
    1,738
    343
    Male
    EUSA
    Long Island, NY
    I actually think this is more of a signal (reception) error. It happens to me occasionally and I just turn off mobile network and re-enable it. Usually works for me afterwards.
     
  3. JB in AZ

    JB in AZ VIP Member
    VIP Member
    173

    Oct 27, 2009
    1,869
    267
    173
    Florida
    Tried that, no help. However, tried it again, and noticed that when I go to Settings/Wireless & Networks/(set options for) Mobile Networks, I get the message "Sorry! The process com.Android.phone has stopped unexpectedly. FC" This is all very strange, as texts work, email works, web works, VVM works. Tried it on wi-fi and mobile network. I was able to download the app I wanted thru the browser and install just fine.
     
  4. ccapasso

    ccapasso Well-Known Member
    163

    Jan 12, 2010
    1,127
    278
    163
    I do not know if this will work and am not responsible for any damage you cause your phone trying this (it shouldn't do anything bad :)), make a nandroid first, then try this:

    Go here and download the Google Shits. Then open up the file, and find the market apk (i believe it might be called vending). Put that file in your android-sdk-windows/tools folder and push the apk to /system/app/

    Again, I do not know if this will work, but it might..
     
  5. JB in AZ

    JB in AZ VIP Member
    VIP Member
    173

    Oct 27, 2009
    1,869
    267
    173
    Florida
    Thanks for the suggestion, ccapasso! I got it working again. YAY! I figured IF I did in fact mistype the google email address, then I needed to re-set it up again, so I wiped and flashed the ZenRom clean. Setup the google acct again, so I could access the market, and it worked...so I then wiped, and restored my nandroid of my ZenRom (all set up already), and now it works again.

    I can't stress enough, that rooting and modifying the Hero is easy, but it is extremely important to follow instructions exactly, and be very aware of typos! (which, unfortunately, I am very prone to! :eek: )
     
  6. ccapasso

    ccapasso Well-Known Member
    163

    Jan 12, 2010
    1,127
    278
    163

    Glad to hear you got it working. And yes, following directions is very important :). I for one can't stress enough how much easier it is if people copy/paste when they can, as it eliminates many many Typos :)
     
Tags:

Share This Page

Loading...