Market is stuck on "Installing..." for 12 hoursSupport


Last Updated:

  1. SeattleYanksFan

    SeattleYanksFan Well-Known Member This Topic's Starter

    Joined:
    Mar 1, 2010
    Messages:
    932
    Likes Received:
    242
    Twitter showed there was an update in Market last night, so naturally, I updated. After like an hour, I noticed it was still showing as "Installing..." in Market. I turned off the phone and back on. Still showed "Installing..." I went to sleep figuring it has to finish by the time I wake up. Nope.

    I tried uninstalling Twitter with AppBrain. Still shows "Installing..." Rebooted my phone again. Same deal.

    Any help would be GREATLY appreciated!
     

    Advertisement
  2. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,048
    Likes Received:
    8,510
    So long pressing on the "installing" progress bar and then cancel doesn't work?

    If not, go to applications and clear data/cache for market. Then reopen the market, agree to terms and see if everything is back to normal.
     
    stinkyadv, Bertk and SeattleYanksFan like this.
  3. SeattleYanksFan

    SeattleYanksFan Well-Known Member This Topic's Starter

    Joined:
    Mar 1, 2010
    Messages:
    932
    Likes Received:
    242
    I tried the first suggestion already to no avail.

    The second idea worked like a charm.

    Thanks!
     
  4. pikappetapi022

    pikappetapi022 Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    145
    Likes Received:
    49

    Please excuse the dumb question but could explain how to get to apps and where clear data/cache for market are located?

    I tried going into apps from the dedicated menu button but could not fine the clear data/cache for market option...

    Thanks
     
  5. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,048
    Likes Received:
    8,510
    Menu > Settings > Applications > Manage Applications > "All" tab > Scroll down to "Market" and press on it > Clear Data/cache
     
    pikappetapi022 likes this.
  6. pikappetapi022

    pikappetapi022 Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    145
    Likes Received:
    49

    THANK YOU THANK YOU THANK YOU!!!!!!

    The idiots at my local VZ store sugguste a factory reset which would have meant a lot of reformating my settings!

    You made my day!!!!
     
  7. SeattleYanksFan

    SeattleYanksFan Well-Known Member This Topic's Starter

    Joined:
    Mar 1, 2010
    Messages:
    932
    Likes Received:
    242
    I'm going to tell you something, and it's very important you listen.

    NEVER LISTEN TO TECHS AT THE VERIZON STORE.

    They are clueless.
     
  8. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,048
    Likes Received:
    8,510
    Sure. Yeah they sometimes like to treat a scraped knee with major surgery. :D

    Resets do cure a lot of issues but often at a very unecessary consequence.
     
  9. pikappetapi022

    pikappetapi022 Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    145
    Likes Received:
    49
    I know they are clueless but thought I'd ask anyway since I was there to pay a bill.


    Why do you think I checked here first???I'd much rather put a bandaid on then go through their surgery!!!!

    Thanks again
     
  10. lewy.lewy

    lewy.lewy Member

    Joined:
    Sep 1, 2010
    Messages:
    16
    Likes Received:
    1
    I've been having a similar issue, I have about 10 apps that need to be updated so I selected update all and figured they'd take care of themselves from there. Two weeks later I still have 10 apps that say "Starting download" and none of them have made any progress. I found that when I let the battery run out completely a few of the apps will update but now I've got more apps that need updating and that trick isn't working. I tried going into manage applications and clearing the data/cache for the market and that didn't do anything.

    Help!
     
  11. parita

    parita New Member

    Joined:
    Oct 15, 2010
    Messages:
    1
    Likes Received:
    0
    the 2nd option has not worked for me
    I have only one option to clear cache
    the other is to uninstall updates please advise
    thanks
     
  12. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,048
    Likes Received:
    8,510
    I would try the cache clear first and if that didn't work, I'd go ahead and uninstall updates and then close out the market, reopen the market and try redownloading the app. Try this on your least essential app in case it causes issues but I don't see why you couldn't get them back with a fresh download unless perhaps if it were a paid app and your Google market history was borked somehow.
     
    nicto likes this.
  13. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,048
    Likes Received:
    8,510
    You could also try clearing data in Google Services Framework at your own risk. I've actually done this before without issue but it could temporarily cause a loss of calendar items, perhaps contacts, etc. Should be ok though once you re-sync Google. Not sure what else to suggest other than a dreaded factory reset. If you're rooted, you could try a different Rom.

    Actually, just thought of one other idea but it's a workaround at best. If you're typically on wifi when loading market updates, try it on 3G instead. Clear your que altogether before trying to update again. This was an older issue, can't remember what OS/Rom but it's worth a shot.
     
    nicto likes this.
  14. amosher13

    amosher13 Member

    Joined:
    Sep 13, 2010
    Messages:
    5
    Likes Received:
    0
    dont know if i'm too late but i've been wrestling with this issue for hours and finally found a fix. it only works if you can still download new apps from market while this issue is happening (or if you have appbrain and fast web installer already installed).

    install and follow the directions for appbrain and fast web installer, sync it with app brain

    if you use titanium backup, backup your apps so you can restore the data if you want

    uninstall the app(s) stuck in downloading.

    kill the market with a task manager or by going to settings > applications > manage applications > market > force close (i would clear cache/data too while you're in here)

    go to appbrain.com and install the apps, this immediately pushes down the newest version and fixes the issue

    use TB to restore backed up data
     
  15. Bertk

    Bertk Member

    Joined:
    May 1, 2010
    Messages:
    9
    Likes Received:
    0
    This worked for me. :)
     
  16. nicto

    nicto Member

    Joined:
    Aug 11, 2010
    Messages:
    8
    Likes Received:
    1
    Uninstall market updates and going back in to it and accepting fixed my issue with stuck installing apps.
     
  17. ninja_reject

    ninja_reject Well-Known Member

    Joined:
    Mar 19, 2011
    Messages:
    536
    Likes Received:
    82
    The clear cache suggestion should work, but with download manager, not market.
     

Share This Page

Loading...