Market won't open / 'force close'


Last Updated: 2012-05-09 19:35:54
  1. SoCalSkippy

    SoCalSkippy New Member

    Sorry if this is a redundant thread, I'm a total newbie, this is my very first visit and post here!

    Anyway, I recently switched from the iPhone to the HTC EVO 4G Android with Sprint and I'm having issues with the Market app, can anybody help me? The other day there was an update for my phone, so I downloaded/installed it and ever since then my Market app refuses to open and keeps "force closing," grrrrr! I've tried re-booting the phone, I've tried clearing the data/cache (it won't let me) I turned my Wi-Fi off/on again hoping that might do the trick but it didn't and now I'm thinking about doing a factory reset but really wanna avoid that. This is the exact message it gives me when I click on the Market app: "Sorry! The application Market (processcom.android.vending) has stopped unexpectedly. Please try again. Force close."

    What can I do? Any tips/advice/help would be greatly apreciated, thanks! ;-(

    Advertisement
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Clear your market data. Settings > Applications > Manage Applications > All tab > Market > Clear Data.
  3. SoCalSkippy

    SoCalSkippy New Member

    Like I said, it won't even allow me to do that, the clear data/cache options are dimmed and I'm unable to even click on them! I'm starting to think a factory reset is my only option and that sucks, ugh. How do I even take out the SD card/memory card anyway? Where the heck is it located?
  4. Illi Hisham

    Illi Hisham Member

    I faced the same problem past few days, then I read some guy posted about the solution in this forum, I cudn't really remember what was it...somehow, I cleared my Gmail data/cache, force stop n rebooted my phone, after that my Market works just fine :)
  5. Illi Hisham

    Illi Hisham Member

    found it

    Market failures stemming from Google/gmail problems are common. Sometimes it turns out to be a gmail temporary glitch, other times it's the user who has entered false gmail info, or a messed up Market app.

    You're leaving out all of the info that could lead us to help you, as mentioned in a previous post, but if I were unable to download because of Gooble/gmail errors I'd go into the application manager via menu > settings > applications > manage applications.. there I would find the gmail app, click it and clear data and defaults and cache.

    Then I'd reboot. There will be a prompt to enter Google/gmail accounts, carefully start the account over that you want to use. ;)
  6. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    another option is to uninstall any market updates. Your clear data and cache buttons are probably greyed out because there may not be anything to clear.

Share This Page