Masqed Crusader Review (Transfer Speed Tweaking App)


  1. jabbawest

    jabbawest Well-Known Member

    The http://androidforums.com/optimus-m-...nal-updating-your-preferred-roaming-list.html got me wondering.
    Is there any way to increase the throughput on our devices?
    Unfortunately, we are all to familiar with the slow as molasses data transfer on the 1x MetroPCS network, which we can do nothing about until MetroPCS decides to upgrade their equipment but, maybe there is a way to streamline or tweak the throughput and gain a few extra kbps.

    With that said, I decided to try Masqed Crusader, an application for rooted phones that claims to increase throughput by forcing the use of Google's Fast DNS Servers and by locally caching nameserver data. While not a free application, there is a trial version that will allow you a few days of using the main function, which is local caching of DNS and the advertised hook to Googles fast DNS servers.
    Masqued Crusader also has a few other functions, like ad blocking and the ability to use OpenDNS when you'd like a little more privacy from the prying eyes of Google's DNS servers.
    I'm only going to focus on the advertised data throughput increase functionality.

    To test data throughput I'm using a free tool from The Market, Open Signals Maps
    It's a very straight forward application that has the ability to test WiFi and Data transfer speeds.
    In almost real time it shows the cell towers your connected to and their location relevant to yours, which is then over-layed onto Google Maps. I highly recommend this for your toolbox.

    Onto the tests.

    My PRL version is 3018, which was recently updated from v3017.
    Before I began testing, I used Open Signals Maps to check my signal strength to one of the three towers I get signals from when I'm at home. Average distance to each tower is around 1.25 miles as the crow flies.

    [​IMG]

    Using my phones default settings, I ran 7 consecutive tests, taking care to leave the phone static so that no processes, like the accelerometer or gyro would compete for power or processor usage.
    After each test, I was also careful to make sure the tests were complete and that all data transfers had ceased before looking at the results and beginning the next test.
    Unfortunately I had one connection failure during the this run of seven but considered it real world data that could be a result of the default settings, so I left it.

    [​IMG]

    Now for Masqed Crusader and 7 more consecutive tests using the same care I took with the previous seven.

    [​IMG]

    Hopefully no one will fault me for this but I obviously ran the 7 Masqed Crusader tests prior to running the 7 without, but I don't believe the overall data/results were skewed, or screwed.

    In the final analysis, it does appear that Masqed Crusader was able to do what it claimed.
    Since I had a lost connection during default testing, I omitted the lowest up and down from the averages in the Masqed Crusader results.

    Default Download Speed Averaged 16.5 kbps
    Default Upload Speed Averaged 42.6 kbps

    Masqed Crusader Download Averaged 24.8 kbps
    Masqed Crusader Upload Averaged 100.1 kbps

    Not shown are the ping results.
    Default settings, pings were around 400-500ms.
    Masqed Crusader, pings were averaging a little better 350-450ms

    Well, that's it.
    I'm not shilling for Masqed Crusader but it does seem to do exactly what it advertises.
    If, after a few days of test driving the trial you find that it benefits you, I hope you'll purchase the application from the developer.

    Advertisement
    KOLIO likes this.
  2. blaxican25

    blaxican25 Well-Known Member

    this might increase tether speed to.
  3. jabbawest

    jabbawest Well-Known Member

    KOLIO likes this.
  4. t3084

    t3084 Well-Known Member

    yes this would help tether if you can speed up your connection.

    great app! especially for the tower reference.


    for those of you not afraid of the adb shell

    you can find your current DNS servers for your DATA/1x connection by issues these two commands:
    Code (Text):
    1. sh-3.2$ getprop net.rmnet0.dns1
    2. getprop net.rmnet0.dns1
    3. 10.221.15.54
    4. sh-3.2$ getprop net.rmnet0.dns2
    5. getprop net.rmnet0.dns2
    6. 10.221.15.55
    you can manually set these with
    Code (Text):
    1.  
    2. sh-3.2$ su
    3. su
    4. sh-3.2# setprop .net.rmnet0.dns1 208.67.220.220
    5. setprop net.rmnet0.dns1 208.67.220.220
    6. sh-3.2# setprop net.rmnet0.dns2 208.67.222.222
    7. setprop .net.rmnet0.dns2 208.67.222.222
    8. sh-3.2#
    the above method is is only temporary. you can modify these automatically with scripts.

    for wifi it will be slightly different
    Code (Text):
    1. sh-3.2# getprop dhcp.wlan0.dns1
    2. getprop dhcp.wlan0.dns1
    3. 192.168.1.1
    4. sh-3.2# getprop dhcp.wlan0.dns2
    5. getprop dhcp.wlan0.dns2
    you can manually set these with
    Code (Text):
    1.  
    2. sh-3.2$ su
    3. su
    4. sh-3.2# setprop dhcp.wlan0.dns1 208.67.220.220
    5. setprop dhcp.wlan0.dns1 208.67.220.220
    6. sh-3.2# setprop dhcp.wlan0.dns1 208.67.222.222
    7. setprop dhcp.wlan0.dns2 208.67.222.222
    8. sh-3.2#
    you can also automate this with scripts or by modifying /system/etc/dhcpcd/dhcpcd-hooks/20-dns.conf

    this can be directly modified with root, or perhaps extended to call for a file that you can update.

    the section you would change for a static DNS server no matter what Wifi network you are on.

    for instance this is the section of the script we will look at
    Code (Text):
    1.  
    2. set_dns_props()
    3. {
    4.     case "${new_domain_name_servers}" in
    5.     "")   return 0;;
    6.     esac
    7.  
    8.     count=1
    9.     for i in 1 2 3 4; do
    10.         setprop dhcp.${interface}.dns${i} ""
    11.     done
    12.    
    13.     count=1
    14.     for dnsaddr in ${new_domain_name_servers}; do
    15.         setprop dhcp.${interface}.dns${count} ${dnsaddr}
    16.         count=$(($count + 1))
    17.     done
    18.  
    19. }
    20.  
    21.  
    we can make changes here, so that even if they are updated, they get switched back no matter what.

    Code (Text):
    1.  
    2.     for dnsaddr in ${new_domain_name_servers}; do
    3.         setprop dhcp.${interface}.dns${count} ${dnsaddr}
    4.         count=$(($count + 1))
    5.  
    6.         setprop dhcp.wlan0.dns1 208.67.220.220
    7.         setprop dhcp.wlan0.dns2 208.67.222.222
    8.  
    9.     done
    10.  
    that is not a very clean way of doing this, but for the sake of the board, but you get the idea.

    or modify it with something like this, and you can modify /system/etc/resolv.conf ( i haven't tried yet, I doubt if awk or grep even works on regular android shell :/)
    Code (Text):
    1.  
    2.  for dnsaddr in ${awk '/[0-9.]*/ {print $2}' /system/etc/resolv.conf}; do
    3.  
    jabbawest likes this.
  5. ZepHed69

    ZepHed69 Member

    I am running a Droid Charge rooted with imnutts's PeanutButter Jelly. After downloading Masqed Crusader and turming it on, my speed tests went from 5-6 mps to 11-13 mps. So the app worked for me. However, my "Wireless Hotspot with USB Tether" app (awsome frickin app BTW) does not work. Not a single device that I own can connect to the hotspot anymore. This is extremely frustrating due to the fact that I dont have home internet. I have tried uninstalling both apps and reinstalling the hotspot to no avail. I have reflashed PBJ and even factory wipe and reset on CWM. Still not working.

    Any suggestions?
  6. Mikenly

    Mikenly Well-Known Member

    Hmm. It works. Thanks.

Share This Page