Maylong M270 Freeze


Last Updated: 2015-04-02 14:31:48
  1. jabarrera34

    jabarrera34 New Member

    I have a tablet Maylong M270 when I turn on the tablet stays frezze ice cream logo and does nothing. Only has the power button.

    Thanks for the help



    M-270 Mobility Tablet PC Specifications:
    CPU 1.0 GHz Cortex A8 with 3D accelerator
    Memory RAM 512MB DDR
    Flash 4GB Built-in Flash Drive
    Display Touch Panel 7" TFT LCD(capacitive)
    Resolution 800 X 480 Pixels, Auto-rotate screen
    WIFI 802.11b/g/n
    Camera 0.3M Pixel on fron
    Input/Output Touch Panel
    Capacitive type touch panel
    SpeakerTwo built-in loud speakers 1W
    SD/MMCOne MicroSD card slot compatible with up to 32GB SD card
    USBMini USB 2.0 x 1
    Buttons/SwitchesPower On/Off, Speakers volume Up/Down
    BatteryBuilt-in Li-Polymer battery
    AC Charger InputDC 110-220V AC Output5V DC 2A
    Physical Characteristics Dimension7.5" X 4.5" X 0.4" Weight 11OZ ​

    Advertisement
  2. mikedt

    mikedt 你好 Guide

    Hello jabarrera34 welcome to Android Forums.

    Have you tried doing a hard reset? What could have happened the system software ROM has become corrupted or damaged, rendering it bricked and unbootable. Which means it has to be reloaded. This is something that can often happen with cheapo tablets like the Maylong, due to poor quality. You may be able to get the file from the manufacturer's website Maylong M270 Mobility Tablet PC Features

    If not and it's under warranty, best bet would be to get an RMA, and return it as faulty for replacement, repair or refund.
  3. twistedgeminid

    twistedgeminid Well-Known Member

    i have the same tablet pc and finally got it rooted. i had a problem sorta like yours but mine issue was it kept booting into recovery mode and wouldnt boot into the android os. here was my solution, while it was in this mode i plugged in my keyboard and pressed control alt delete. it rebooted and went into android os and works just fine now. give this a try, couldnt hurt
  4. jabarrera34

    jabarrera34 New Member

    Thank you all but I have tried in many ways and I can not do anything. Do not put the tablet in recovery mode and much less not charge a new file is corrupt, but this is not anything else.
  5. geekettewannabe

    geekettewannabe New Member

    I did internet search that brought me here. I need instructions to factory reset Maylong mobility tablet after grandson/daughter locked themselves out n don't remember password- imagine my surprize when I get here n it is not one of tablets in list. Does anyone have any help or words of wisdom please. I am at end of rope!
  6. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Hi there, geekettewannabe, and welcome to Android Forums. :)

    Sorry to hear you're having problems being locked out of your device. Although we don't have a forum for your specific device, we do have a thread that may help you: Lost/Stolen or Locked out of Device. Read Here

    If that doesn't do the trick, feel free to post again.
    breadnatty08 likes this.
  7. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Moved to the General Tablet Talk section for better results. :)
  8. Slug

    Slug Check six! Moderator

    Further merged with a related topic.

    Goggle hasn't been much help, I'm afraid. There appears to be no way to reset the tablet other than Android's Settings/Backup & reset menu. :(

    All I can suggest is downloading the most recent firmware from here and following the instructions to update the device.
  9. pally320

    pally320 New Member

    A good solution for the maylong device freezing at the icecream sandwich logo is here www(dot)maylonggroup(dot)com/Tablet_downloads.htm maylong has had a problem with the m-270 version for a long time and this is the only fix that is available for the issue you are having. the tablets reset button when in this state doesn't work as well as the fact that when you plug it into your computer and start the device it will get past the loading screen sometimes and you will be met with a gesture lock with no actual way to unlock it. as well as the fact that programs meant to reset locks from a computer wont unlock it.

    I hope this helped. read the instructions before hand to see what s/n the file you download supports.

    first post so i couldn't post the link as a link
  10. n3rdy13

    n3rdy13 New Member

    mikedt likes this.
  11. madre712

    madre712 New Member

  12. jjgurley

    jjgurley Member

    I followed the same advice and got the same result of a non-functional touchscreen. The readme accompanying the firmware says the update didn't apply to my model number (M270 1204), so I guess I can hardly blame anyone else. There is another file on the website that claims to apply, but it won't flash, possibly because it's an older version?
  13. jjgurley

    jjgurley Member

    After writing the above, I decided to give it one more try, and it worked! It might solve your problem if you have a model like mine. I used a different file: http://www.maylonggroup.com/Tablets/M270FV1/M270FV.zip. Although this had failed to work, I created a new SD card, and it worked. I think my SD cards might be marginal for the Maylong or something. If you go to http://www.maylonggroup.com/Tablets/M270FV1 you'll see a PDF describing the models the update is intended for. There's a similar file for the CQ file as well.
  14. mikedt

    mikedt 你好 Guide

    I think "Maylong Group" might no longer be in business though. Their main page now just gives "This website is no longer available.". The documents are still there until they pull the plug on the server probably.
    Last edited: Apr 2, 2015
    #14

Share This Page