Memory card and airplane mode issues. Also help with rooting.Support

Last Updated:

  1. csc2ya

    csc2ya AF Contributor Contributor This Topic's Starter

    Oct 23, 2010
    Likes Received:
    I purchased an Xperia X8 (my first android device) two days ago, and so far I love it. It's running Android 1.6 (cupcake?)

    However, i've noticed a couple of issues.

    The first issue, is that if I put it into airplane mode, when disabling it, the phone doesn't always reconnect to the network. It will sometimes ask for my sim card pin, after which it will reconnect.

    If it does not reconnect, then changing my sim card pin will force it to reconnect, but i'm not sure I should have to do this.

    I have an 8GB SHDC microSD card in it that was originally in my nokia. However, when opening the camera application, occasionally, it will say there is no memory card in it, despite ringtones that are on the card still working.

    A reboot will always get the camera working again.

    I've downloaded the updater from Sony Ericcson's site to check for updates, and have reflashed android 1.6 to it to try and fix both these issues, but they are still occurring.

    I'm also trying to root it, but am not having any luck. I've tried universal androot 1.6.2 beta 5, but that always errors out (can't remember the error now).

    I've also tried Superoneclick 1.4 Shortfuse, but that just stays on waiting for device (the phone is connected via usb with usb debug mode enabled).

  2. coman_nick

    coman_nick Well-Known Member

    Oct 25, 2010
    Likes Received:

    I would recomend returning the device. I never had any of these problems on my X8 so it's not normal. I already returned mine because I couldn't send SMS messages.

Share This Page