Menu Button Has Remapped Itself to Home ButtonSupport

Last Updated:

  1. maryn

    maryn New Member

    At least I think it has.

    [Working on an unrooted Sprint Hero running 2.1.]

    I updated a number of apps the other day, and noticed yesterday that my 'menu' button has started operating like the 'home' button. Same activities - in an app, it returns me to home; long hold brings up recently used apps; and press on the home screen zooms all to all screens.

    My home button still works fine and the same.

    I use launcher pro, and recently updated that, but having the same problem when reverting back to Sense. Haven't dropped the phone or done anything I can think of that would have damaged the hardware.

    My thinking is that one of the apps I recently updated might be the culprit - but now have no way to get into the 'my downloaded apps' section of the market to try to see what I recently updated.

    But, suffice to say, it's a bit of a problem since I basically can't access the settings or menu of any app.

    Not sure what to do besides a factory reset, which would be pretty lame. Anyone have any ideas? Is there a way to reset buttons?


  2. LBPHeretic

    LBPHeretic Well-Known Member

    It could be hardware related, but that seems unlikely. A factory reset may be the only option unfortunately.

    That is unless you root it and do a Nandroid backup. Then you can reset it and see if that fixes it, and if it does not, you can restore your Nandroid and be back to square one. Heck, if you root it and then wipe the cache and Dalvik cache it might fix the issue. It would be strange for an app to remap the buttons like that unless it was specifically designed to do that.
  3. maryn

    maryn New Member

    Just an update - took the phone into Sprint and it is apparently a unique and unfixable problem. I'd tried taking off all apps myself, didn't work. Sprint did a manual reset, but factory reset is impossible since you need the menu button to do it. They took it apart and nothing seems off.

    Upshot is they mucked with my phone for hours, but no resolution (and now the earpiece has stopped working - the phone seems to be dying a weird death). So upgrading to a new phone, since I'm not paying $100 just to get a new Hero. Hopefully the shift will treat me better - yay for more ram.

    But the menu button problem appears to be hardware, not software. And thoroughly mystified the Sprint techs.
  4. duncanrr

    duncanrr New Member

    Ok I had this same issue right after I installed my new screen (previous screen shattered). Not sure if this is going to work for you but I found my solution. I was getting the same issue as you whenever I pressed the MENU button it would function as the HOME button. After playing around with the keys I noticed that if I touched the MENU button on the top side toward the screen it would work fine. I'm thinking when I took it apart I didnt get the keys to line up perfectly. Anyways just a suggestion, hope it fixes your problem.
  5. xevious

    xevious Well-Known Member

    Well, this really sucks.

    My phone has been perfectly fine for all this time. I didn't load any new software onto it. It has been business as usual. Then suddenly, my menu button starts acting like the home button. Also, the decrease volume button doesn't work right. You press it once and it goes up then down one notch (essentially going nowhere). You have to click and hold it, which forces volume all the way down, and then you can notch the volume up with the increase button.

    Also, I managed to notice that the SEARCH button is behaving like the CALL button! Oddly, it would happen only on the main screen. Any other screen and it would bring up the search dialog and virtual keypad. I played with the buttons for a while to see what other peculiarities were manifesting, but this was it.

    I searched the Internet and found a few other people reporting the same problem with no clear resolution. I have a feeling it is a hardware issue that gradually crops up over time, as some have reported problems with other buttons as well. One person noted having this issue after exposing his Hero briefly to some water (not submerged but just some fell on top of the buttons).

    I went kayaking yesterday and had my Hero in my bathing suit pocket, protected by a waterproof sleeve and sealed in a plastic bag. The phone did not get wet and it worked fine afterward. I'm just wondering if there's something to do with humidity affecting the button function. But, I find it very odd how it's only two specific buttons that aren't even adjacent to each other.

    Anybody here on Android Forums run into this problem and manage to fix it?
  6. xevious

    xevious Well-Known Member

    I discovered another peculiar behavior.

    When the phone was idle for some time, I awoke it with the END button, then a screen swipe to get to the main screen. Pressing "MENU" brought up the proper sub menu toolbar. However, going back and pressing it again showed the wrong behavior again (acting like the HOME button).

    It was then that I stumbled upon what seemed to be a "workaround". If you tap the menu button lightly and quickly, the sub menu toolbar appears. A standard button push will cause it to act like the HOME button.

    EDIT: I left the phone for a while, went back to it, and the light tap on the menu button no longer brings up the proper menu--it's behaving like the HOME button again. Given how erratic the behavior is, I'm starting to think that there's some "threshold" in the software programming that has been crossed and is causing this... Doesn't seem plausible to be a hardware issue.

    I did NOT see any erratic behavior prior to this, like the MENU button mostly working fine and only occasionally acting like the HOME button. It was a rather sudden change. Given the behavior, I'm starting to wonder if something has built up inside under the button bezel that is doing this. Perhaps taking it apart and giving it a good cleaning would resolve it? But then on the other hand, a button is a button. They are designed to give feedback to the processor--tap, normal, and hold. Based on one of those three types of button uses, the programming can decide how to respond. With the SEARCH button behaving differently depending upon which screen you're on, it definitely has to be a software related issue. So, it would be odd if it was partially software and partially hardware.
  7. xevious

    xevious Well-Known Member

    Anyone, anyone? .....

    I guess this phone is too old for anyone to care much about it. :-/
  8. xevious

    xevious Well-Known Member

    It's very strange behavior.

    My Hero is still experiencing this problem most of the time, but sometimes the menu button will work properly. When it does, I can click the button again in the exact same way, and it will stop working right. Other times, I can dismiss the pop-up menu, then click the menu again and it works maybe 2-3 times. Then after that, it's back to the "HOME" button behavior. Once it does it again, I cannot coax it to work properly again, no matter how many different variations I try. I have to wait for a long while before trying again and finding that it works properly again.

    If it was a software problem, I don't think it would be erratic. If "remapped", this would be sustained. I can't see how it could "revert" on its own. So, it must be some kind of hardware issue. Perhaps it's an accumulation of debris in the switch contacts that is causing it. So, refreshing the ROM probably won't solve anything. Maybe a partial disassembling of the casing would be worth doing to inspect the button contacts.
  9. xevious

    xevious Well-Known Member

    Somehow, miraculously, the problem resolved on its own. I guess it must have been a hardware issue, as I didn't make any software changes. I can press the menu button repeatedly and it works normally now. Really weird. I guess that perhaps there was some debris or residue buildup inside that eventually worked itself out.

Share This Page