menu/home/back buttons not responding.Support


Last Updated:

  1. nexile

    nexile New Member This Topic's Starter

    Joined:
    Jul 6, 2010
    Messages:
    4
    Likes Received:
    0
    My girlfriend just got an x10 to match mine and for some reason every once and a while, the 3 buttons at the bottom completely stop working. At first I thought the phone froze but I could still use the on-screen keyboard and press whatever I wanted on screen but the 3 buttons wouldn't work oO This has NEVER happened with my phone.

    After searching around a bit, I only found one solution which was "if you have a gel phone cover, take it off and see if it works." We tried that and it seems (so far, for an hour or so) that it's working fine. That doesn't make much sense to me as we have the same phone and the same cover - just a different colour. Anyone had this problem before? Should we be bringing the phone back or is there something I'm overlooking?
     

    Advertisement
  2. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    If you put her cover on your phone does it do the same? I wonder if the set up of the cover and buttons on her phone are just slightly out in comparison with yours.

    If you have no problems with it during today then I guess you have your own answer. Time to look for a different cover. If the problem recurs without the cover and the phone is quite new, take it back.

    I have seen this mentioned on here and another forum so defo a problem with certain covers marginally touching the buttons.

    Let us know what today brings!
     
  3. gunny5821

    gunny5821 Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    501
    Likes Received:
    29
    Welcome! Can you please tell us what case you are using? This would be helpful for future users, if it is in fact the problem. Please advise, and again, Welcome!
     
  4. cwepruk

    cwepruk Well-Known Member

    Joined:
    May 25, 2010
    Messages:
    195
    Likes Received:
    9
    I'm thinking the case might be light pressing a button that freezes it. I used to get it very rarely with a skin case and I would just have to pull up around the button areas.
     
  5. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    FYI

    An update I have just seen from SE's forum... apparently some of the cases press on the camera button very slightly and that freezes up the three hardware buttons on screen.
     
    Terminate likes this.
  6. minimulisha

    minimulisha New Member

    Joined:
    Sep 8, 2010
    Messages:
    3
    Likes Received:
    0
    Yep.. same problem here with a silicone case i bought at best buy...i believe it was a "zeb" brand grey colour case (ill have to confirm that)

    every once and a while the hard buttons stopped working, and if i lifted the right side of the silicone case away from the phone, they magically worked... always thought that was weird :confused:...lol

    There seems to be alot of the "iskin" brand cases available here now, so im thinking i might give that one a shot.... unless anyone is already having the same problem with them??
     

Share This Page

Loading...