[Merit] Complete ZTE Merit Guide: Root, Flash Recovery and Install New ROM (with links)


Last Updated:

  1. Motorhead1991

    Motorhead1991 Well-Known Member

    What carrier are you using?

    Advertisement
  2. neutrontech

    neutrontech Well-Known Member

    What are the advantages of going to one.three from the stock Merit rom? I see you can overclock and it has a smaller memory footprint. Is there anything else?

    Also having a problem when flashing CWM. I'm getting an error

    "mtd: read error at [hex address] <out of memory>"

    Using adb from Windows command prompt. Got the same error when trying with the terminal emulator on the phone itself.
  3. Motorhead1991

    Motorhead1991 Well-Known Member

    Try killing any other running apps and trying again. As for your ROM question, one.three and my MH-1.0 are faster than stock because they are slimmed down, and de-odexed.
  4. krystal1985

    krystal1985 Member

    Hopefully someone will hook you up. I deleted mine after I realized I wouldn't want to go back to stock. Otherwise, if you have Straight Talk, then there's a link to it within this very thread. If you have an Avail/Roamer, just google "ZTE Avail stock roms".

    I hope you don't mean you deleted your ROM via a clockworkmod wipe because then you're just sol. No replacement rom in the world would help, b/c as I thoroughly warned in my guide, the Merit does not have the volume up/down power button option to get into clockworkmod.
    ffoghorn and thagnome like this.
  5. neutrontech

    neutrontech Well-Known Member

    I'm running Go Launcher Ex. I went into the app drawer and clicked on running apps, then killed them all. Tried again and got the same error.

    I would just boot into recovery mode and do it that way, but I don't want to have to wipe my settings to do it.

    EDIT: I got it. I downloaded Advanced Task Killer and shut a bunch of crap down!

    EDIT2: Just installed one.three, I'll post if it all goes well.
  6. neutrontech

    neutrontech Well-Known Member

    On first boot I got a mount error from Link2SD. I recreated the mount scripts and rebooted. Now my phone is showing only 6mb free. I can access all my linked apps, but for some reason the system thinks my apps are using internal storage.

    EDIT: I think I got it. I had to recreate links for the Dalvik Cache

    EDIT: nope. I can't get anymore than 30meg free after uninstalling EVERYTHING. So, I think I'm gonna wipe/factory reset it and see if that helps But ADB no longer sees my device
  7. neutrontech

    neutrontech Well-Known Member

    Ok, so I downloaded an app that allowed me to reboot my phone into recovery. I wiped it and reset it. Then took the SD card and wiped that as well, and setup the partitions again, creating a 1gb ext2 for apps.

    I've installed a handful of apps and WOW it sucks up space fast. After wiping my phone, I had just over a 100meg free, now I'm showing 59meg free with only a fraction of the apps on it that I installed before. So, turns out there wasn't anything wrong with link2sd when I wiped it. The old ROM seemed to give me much more free space then this new one. I had 42meg free on the old rom with over 350meg worth of apps on the SD card. I have less than 200meg on the SD card now, as I haven't finished loading apps back. But at this rate, I'm gonna run out of space on the internal memory.

    EDIT: After rebooting, I now have 73MB free. Might just be a delay after linking the apps before the freed space shows.

    Also might want to add in the OP to set the APN settings for straight talk. I had to do that before MMS and internet would work.
  8. thagnome

    thagnome Member

    sorry, was out of touch for a little bit, got the mod up and running, something in the way that i rooted did not like the mod one.three. i went to the link up top(the one you give props to) DL'd the mod(one.three) from his post, I'm not sure what the difference was, but i put my card back in, ran the .zip, and viola, full on awesomeness.
  9. dinat411

    dinat411 Member

    Here's my screen shot. Yes, "debugging" was set as well as "unknown sources". :) All files were downloaded per your instructions. I'd also tried the other person's instructions on this site when they first appeared. Yours were clearer to me because I'm new to rooting, etc. Anyway, as u can see, it still stops at step 10..."no such file or directory". I've attached just in case screen print. Thanks

    Attached Files:

  10. Motorhead1991

    Motorhead1991 Well-Known Member

    @dinat411:
    Try skipping step 8, it looks like it's trying to symlink to a non-existant file. Worth a try ;).
  11. dinat411

    dinat411 Member

    Symlinking is OK. I still can't create #10...ls -l /data/local.prop.
  12. stayboogy

    stayboogy Well-Known Member

    your symlinking is not okay, it clearly says "link failed file exists" that file must be deleted before it can be linked, and because it's not linked you can't get "local.prop" created

    dinat411, go here http://androidforums.com/avail-all-things-root/566407-root-zte-z990g-merit-avail-variant.html and follow this to a "T"

    if that still doesn't work you need to do a factory reset / T card flash and try again.

    why follow someone else's method who was not the person to actually develop it??? whoever posted the directions above needs to remove them before others have more trouble. jcase's directions are more than proficient and understandable...

    (according to the directions of the one who got root on the Merit)
    you must make sure that this file "/data/local/logs/kernel/log_kernel.txt" is deleted before you symlink, and it can recreate the file before you get it symlinked, and then you must delete the "/data/local/logs/kernel/log_kernel.txt" and try again.

    if the file is not deleted, then symlinked immediately, the "/data/local.prop" will not be created. aside from that it takes a couple of minutes before that file is created.

    you need to try listing the "/data/local/logs/kernel/log_kernel.txt" file again and if it has been recreated you need to delete and try symlinking again.

    follow the directions, the right directions not these in this thread

    hope you get it going. it took on mine the very first try with no trouble at all, so the method is fine.
  13. thagnome

    thagnome Member

    is anyone else having issues with data? i can connect to pretty much everything else, but my data is not working
  14. krystal1985

    krystal1985 Member

    If anyone wants some STOCK roms that work on the ZTE merit (other than straight talk) I can give links, just pm since people like to bitch and moan over one little discrepancy that's being misinterpreted. The prop file was created for me, no problems. edit: btw the rom I'm using now has FTM mode capability...this splash screen comes up with big "ftm" letters which didn't happen before. maybe ill use tht mode someday, but doubt it.

    BTW my directions have worked for some, others it has not. Guess some ppl misunderstand. This is the way I did it when the original directions from jcase or whatever didnt work out for me until I tried it twice.

    And btw, I have clearly posted the link to the original directions for those who are whining, and the link has been there from the start. If mine don't work for you, and you want to leave bitchy comments, plz bug off and find some that do. Either a root will be a success or not, you are not going to "brick" your phone. If my directions are so terrible, obviously a moderator will close/delete the thread.
    Kayoss666 and algiers like this.
  15. thagnome

    thagnome Member

    worked fine for me, took a few tries, and a couple of tweaks for my phone, but i can use everything(minus 3g), i have a feeling i jacked something up there though. it's not showing my network as att, or straight talk. trying to find the problem on the forum. elsewhere, will post it when i find it if anyone else needs it, but as of time now, no one else has stated anything about the problem so i assume it is me :D

    Edit: i also have a second completely stock, never activated merit that i can try and root and pull a ROM off of(i have no idea how to post it so if someone wants it i may need to mail it to OP for posting)
  16. Motorhead1991

    Motorhead1991 Well-Known Member

    Using a file hosting site will work fine, like 4shared or mediafire... It's looking likeI'll have all of the available APNs to make a consolidated version :D.
  17. thagnome

    thagnome Member

    it'd be nice to have a ready made that will run everything out of the box, i dont know enough about the systems to try myself though, i can build a computer, and install the software, but i have never gotten into the whole programming thing
  18. krystal1985

    krystal1985 Member

    No hun, you've been nothing but nice and thankful...it's a no-account user with one post that was giving me a hard time.

    The rom I'm currently using is for a zte v860 and the built-in FM Tuner app keeps saying it "has a bad signal" and I can't tune into any local stations (but I also can't tune in via my living room radio without a large antennae) so when I get a chance to test it in town I'll report back about it. I'm pretty sure the ZTE Z990g version (which is what I have) has a radio inside of it but of course they don't exactly avertise that and have no app to operate it.

    The only bad thing about the FTM mode is that I have the choice between leaving that along with the stock recovery OR reflashing to cwm and loosing the ftm. I see no use in the FTM for this particular phone so I've gotten cwm back. I guess if it was ever needed, I can just use the stock recovery image from this ROM or whatever.
  19. thagnome

    thagnome Member

    still havent found the problem, i'm thinking i'm going to go ahead and root the other phone, clockwork mod, then put the back up off that one on to this card and see if it will boot me into the stock straight talk, i think the issue i'm getting is that the phone doesnt want to use the signal, my bar is black, says i have 90% sig. but not getting any internet capabilities.

    BTW it's saying my mobile network type is HSDPA, i have no idea what this means, shouldn't i be reading AT&T, or straight talk? i went into settings/mobile networks/ access point names/ and clicked at&t broadband still nothing

    any ideas?
  20. Motorhead1991

    Motorhead1991 Well-Known Member

    Are you using my European ROM by chance? It's formatted for the V860 and has the FM Tuner...
  21. thagnome

    thagnome Member

    somehow managed to jack the other phone up while trying to root it, now it wont go past the ZTE logo
  22. thagnome

    thagnome Member

    do you have the passsword to that stock rom krystal? i dont see it anywhere
  23. thagnome

    thagnome Member

  24. Chud1

    Chud1 Active Member

    If flashing the one. three ROM on the zte merit without wipe/ resetting back to factory prior, will it still be a slimmed down version? Or will it leave behind some unwated bloat crap?
    Any answer is greatly appreciated!


    -Chud-
  25. Motorhead1991

    Motorhead1991 Well-Known Member

    It'll be slimmed down. It formats the system and replaces everything in the /system folder
    napalm6283 likes this.

Share This Page