[Merit] Complete ZTE Merit Guide: Root, Flash Recovery and Install New ROM (with links)


Last Updated: 2015-01-01 12:05:53
  1. Russ71

    Russ71 Well-Known Member

    Arg! App put this in wrong spot. Cant delete either. Sorry folks.

    Advertisement
  2. Buzz2043

    Buzz2043 Active Member

    So how do we find out the phones specific drivers then.
    I am presuming that the drivers would have changed after we did recovery and flashed the ROM?
    If not are they not the same as the drivers we started with before we did this mod?

    One more thing the link you posted what is it for I cant tell as the link is broken or something?
  3. neutrontech

    neutrontech Well-Known Member

    Yeah I also was am not able to connect via USB after switching roms. I downloaded the avail drivers, but it still didn't work. Although I must admit I didn't spend much time on it.
  4. Buzz2043

    Buzz2043 Active Member

    Ok So where are the drivers needed to repeat the Recovery and Rom steps of this tech please?
    Ah Ok I have just now found what I was looking for myself accidentally I hit restore from recovery mode on the phone thank god I did a back up of my original setup I am now back to stock that was easy and now all I have to do is repeat these steps again but after I find out how to keep what I want from my original setup... anyone care to lend a hand on this task please?
    the Items I want to copy over.
    web browser
    photo gallery
    Well I cant remember what else there was but I will think of it later on and edit this when I do. :)
  5. Buzz2043

    Buzz2043 Active Member

    Ok Now this gets annoying to have to re install every app back onto my sd card every time I do a different flash of the ROM I see there in the one.three zip there are the apps that come with in there if I was to transfer my apps to the same folder in that zip would those apps be installed automaticaly?
  6. neutrontech

    neutrontech Well-Known Member

    I didn't have to reinstall when I upgraded roms, bit I did have to relink every app and had to reboot a bunch of times due to memory errors. As long as you don't delete the cache and reset, you can do it. Its probably easier to reinstall them though since the phone takes a while to boot during that process.

    That's the one thing that I don't like about android. If the phone didn't come with so little memory allocated to apps, I wouldn't have to bother with linking. I really don't understand why these phones ship with such a pathetically small app memory allocation. I don't need multi gigs of storage for media, but I certainly need more than 100 meg of app space. Just makes no sense at all.
  7. Motorhead1991

    Motorhead1991 Well-Known Member

    My Rugby Smart has almost 2GB internal ;). As for reinstalling your apps, that happens when you factory reset before flashing. Just wipe the dalvik, the cache and boot it up.
  8. Buzz2043

    Buzz2043 Active Member

    Thats all good but e all dont have the rugby my ZTE-Z990g only has 167mb or something around there I rely on my sd card to store all my apps pretty much
  9. Motorhead1991

    Motorhead1991 Well-Known Member

    The Avail was my first droid, so I feel your pain. I was stuck with the stock 2gb sd, so I couldn't really split it. That's why I altered a script to move the dalvik.
  10. stayboogy

    stayboogy Well-Known Member

    SOMEONE DELETE THIS THREAD...

    there are more people having problems trying to follow the directions the one who started this thread posted than there are who are getting it right...

    this thread should have been deleted from the get go

    USE THIS THREAD FOR ROOTING INSTRUCTIONS--THIS IS THE GUY WHO GOT ROOT IN THE FIRST PLACE FOR ZTE MERIT Z990G (tracfone, straight talk)--DON'T USE THE INSTRUCTIONS HERE AS THEY ARE NOT AS CLEAR AS WHAT JCASE POSTED

    http://androidforums.com/avail-all-things-root/566407-root-zte-z990g-merit-avail-variant.html
  11. Buzz2043

    Buzz2043 Active Member

    Ok well just to be clear and clear everyone else up here I did have problems from this threads rooting steps and I did use this link [ROOT] ZTE z990g Merit (An avail variant?) to complete the root process but came back to this thread to complete the other steps in here which all have worked ok for me after a bit of deciphering. I think if I hadn't found this thread though I would not have found the proper threads or the original owner of the tech.
  12. therealmccoy95

    therealmccoy95 New Member

    can anyone tell me where i can get custom ROMs for ZTE Merit??
  13. JM3

    JM3 Member

    I did all of this successfully, but now my internal memory is even smaller. How do I get rid of the old ROM?
  14. Motorhead1991

    Motorhead1991 Well-Known Member

    Wipe the Dalvik-cache....
  15. JM3

    JM3 Member

    I done all the steps even factory reset my phone. Now using the one.three ROM and now my moble network isn't working. Is there something I need to turn on???
  16. JM3

    JM3 Member

    My moble network is disabled. How do I fix this.
  17. neutrontech

    neutrontech Well-Known Member

    Enter the proper apn settings. There is a thread discussing it.
  18. JM3

    JM3 Member

    I rooted my ZTE Merit and loaded the one.three.zip file. I did the factory restore before loading the zip file. Everything took fine, but now my APN is set to AT&T and not my straighttalk. So I am only able to recieve calls now. I also tried connecting to wifi and I could not even do that. Please someone help...
  19. kingmt

    kingmt Well-Known Member

    The settings are listed in this thread. Straight Talk uses AT&T settings.
  20. JM3

    JM3 Member

    Thanks for all the help. I have fixed everything and my phone is back to working condition. Thanks again for all the great information!!!
  21. Enigma78

    Enigma78 New Member

    Thanks for the guide. I was able to successfully root my Merit. :)
  22. lolopolo

    lolopolo New Member

    at step 14 i keep getting a message saying no such file or directory. pls Help!
  23. maverickwolf

    maverickwolf Member

    Make sure you have the su file in the directory you are running ADB out of
  24. atTrue

    atTrue New Member

    woke up to a dead phone this am. Don't know if it had anything to do with rooting it or not. Rooted zte merit 2 weeks ago left stock rom on it and everything was fine till this morning left it on the charger all night and woke up to a phone that wouldn't turn on or anything. Took it back to walmart and exchanged it for a new one now to root all over again.
  25. Buzz2043

    Buzz2043 Active Member

    Sounds like you might have cook the battery I noticed that mine gets very hot now when charging and will actually stop charging when it does. when I leave mine on charge over nite now I stick it in from of my fan beside the bed that way it dont over heat not saying this is actually what happened or if this is something to do with the mod or not though. Hope you have better luck with the new phone.:)

Share This Page