1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Merit] GPS broken after minutes reload...any ideas?

Last Updated:

  1. Hi all! Rooted my ZTE z990g following Squdly McNerd's instructions to JustJoanie, with ZERO issues. Cleared a little bloatware (Facebook and Twitter, homescreen tips) and backed up all my apps with TB. Service ran out a little over2 weeks ago, and I let it ride until Wednesday the 6th b/c I had access to wi-fi. While serviceless, GPS essentials could see the birds, but got no fix, which was no surprise. AFTER adding a 30-day unlimited card, the GPS reports as disabled to ALL of my mapping apps, even though it's turned on in settings and shows as active on the power control widget. Google Maps and Navigation won't even LOAD! Everything else seems to be working just fine.

    After a day or two of searching the interweb and trying various USSD codes (NONE of which go through), I broke down and called Net10, only to be told in broken English that they don't help customers with GPS problems.

    Like I said, all my apps and data are backed up so if flashing a new ROM is the only option, it _IS_ an option, but I'd
    much rather fix the problem without having to go through the the trouble of reinstalling everything. I'm a gold prospector, so GPS is 100% INDISPENSABLE, as I must verify that any finds I make aren't already claimed, and GPS capability was the primary reason for selecting this device, in addition to the durability reviews online. Any help anyone can offer would be GREATLY appreciated, especially if we can get this resolved before the snow melts!
    thanks in advance,

  2. kingmt

    kingmt Well-Known Member

    If you moved maps to the SD then move them back. They won't work on the SD.
    reverendfreeze likes this.
  3. Nope...Maps is still on internal (only because TB wouldn't move it)...it seems to be a .conf issue or something...the system isn't in control of the GPS chip anymore...got any diagnostic suggestions?

    Update: tried to run a few different diagnostic tools from play store, all crash on GPS diagnostic...this is starting to feel more and more like a hardware issue...what could cause chip failure?

    Update2: Doms Diagnostic tools shows the GPS chip (woo hoo!) in the hardware checker, but crashes when I try to run a GPS diagnostic...guess we're back to a software issue?
  4. kingmt

    kingmt Well-Known Member

    Did you try to restore it & start over?
    reverendfreeze likes this.
  5. Not yet...haven't had access to a computer since this started...my roommate's been tying it up trying to unbrick his Samsung GS2...I was trying to hold off on a restore until I figure out what I forked up...so I don't do it again...I'm new to Android and trying to learn instead of just wiping everything and starting over...dunno if these phones are the same, but I do know that too many reinstalls on a laptop can kill a hard drive...
  6. redfield88

    redfield88 Well-Known Member

    Google Maps runs fine on the SD card. Just so you know.

    Did you remove Network Location when you were removing your bloatware? That's more than likely the cause of your GPS not working.
    reverendfreeze likes this.
  7. I couldn't get it moved. TB didn't have it as an option, and I didn't want to do a recovery exploit remove and reinstall...figured I'd live with the space it takes for now...

    Nope...it's still there...I don't do anything illegal (except exercise my freedom of speech to the hilt!), so I'm ok with being tracked ;- Could it be forked up? If you could Alsopoint me to a factory Net10 apk, I'm willing to try removing/reinstalling it...

    You said most likely...what are other possibilities?

    Also, if you can tell me where to ls it, i'll post up all tthe apks installed on my phone so we can figure out if I removed anything I shouldn't've...
  8. kingmt

    kingmt Well-Known Member

    It may have been maps being linked or maybe a updated app fixed the problem it had been 6 months or so since I dealt with this but the gps didn't work with maps. Once I put the maps back on the phone all was good.
  9. redfield88

    redfield88 Well-Known Member

    To my knowledge, NetworkLocation.apk is the only file the android system uses to obtain the GPS on GSM phones. It's located it /system/app/NetworkLocation.apk

    Well let's run through the obvious first.

    Settings -> Location & Security settings
    Make sure the following are checked: "Use GPS Satelites", "Use wireless networks"

    Wireless networks for GPS really isn't required. If both are checked, uncheck and recheck them. Sometimes the Android Settings bug.

    Are you using stock or a custom rom?

    I've used Google Maps installed on the SD card since I first rooted my Merit many moons ago. Never had an issue. *shrugs*
  10. It's still there..I tried removing and reinstalling it, but no go...

    Tried that before and after the reinstall of NetworkLocation...no good...phone says it's on, but nothing is getting any info from it...

    Stock...haven't done anything but root and change boot animation...deleted all of the updates that exploded my phone when I first turned it on, removed Orkut, Twitter, and Facebook, added Rom Toolbox and removed it; left Titanium Backup, Superuser, SuperSu, Root browser, and term emulator on it...like I said, I'm trying to learn the system, so I've been taking my time...

    Haven't been brave enough to flash a new ROM, yet...plus, I'm picky about having the cleanest and lightest system I can find, and I haven't found the right one, yet...
  11. kingmt

    kingmt Well-Known Member

    This should have nothing to do with your problem but superuser & supersu won't work at the same time so pick one.
  12. nickdalzell

    nickdalzell Well-Known Member Contributor

    GPS could be borked up with no fault of your own--this is a cheap phone. mine has a broken prox sensor so if i dial a call i have to use speaker because putting it to my face turns the screen off forever until i pull battery so i cannot interact with automated menus
  13. Which do you recommend from a functionality standpoint? Haven't _noticed_ any problems running both, but alyways willing to learn from someone else's experience rather than make my own mistakes...;-)
    Could be, but it just quit...no drop, no water, nothing...prox sensor working just fine, accelerometer, etc all reading 5x5 to diagnostic Apps...diagnostic also shows GPS chip and reads it, just can't get the chip to report to the system...

    Does the bin have a version of lshw? Not scared of command line, if we have to go into the terminal to ping the GPS chip and make sure it's NOT a hardware issue...If I need to get the phone replaced, it's under warranty if it gets smashed...:)

    Just had a thought...could it be a permissions issue?
  14. kingmt

    kingmt Well-Known Member

    I use superuser but it really doesn't matter. I could be wrong but I believe there files have the same names so which ever one you updated the binary for last is the one that is working.

    As for your GPS I'd restore to the point it was working & start over. Just do less at a time & see if you can tell at what point you break it. It it's the easiest way to learn.
    reverendfreeze likes this.
  15. redfield88

    redfield88 Well-Known Member

    You can fix permissions with CWM, highly doubtful that's the issue. As kingmt suggested. Restore to stock and start from scratch, it's really the only way.

    Sent from my ZTE-Z990G using Tapatalk 2
    reverendfreeze likes this.
  16. Ok...so that just leaves two questions...
    #1 Is there any way to ping the GPS chip from the terminal, just to verify that it isn't a hardware issue? and
    #2 How exactly do I restore to stock? I've been backing up regularly, and, since I'm limited to a backup history of 1 I'm pretty sure none of my backups are stock...

    Sorry if it seems like a stupid question, but it's something I haven't figured out yet......and do I need to do it on a computer?
  17. nickdalzell

    nickdalzell Well-Known Member Contributor

    does your data service even work or are you using wifi only? last i checked these phones need data to even utilize the GPS....if i recall so did my old BlackBerry. never understood why as my TomTom never needed an internet connection
  18. Data service working fine (if you discount the slow-ass 3G of the network)...like I said in the OP, when I <u>didn't</u> have service, the app GPS Essentials could see the satellites, but couldn't get a fix from them...now that I added service time, it doesn't even <u>see</u> the satellites...Dom's Diagnostic Tools shows the GPS chip in the hardware profile, but every time I try to run a diagnostic on the GPS, the app crashes...still trying to find a command-line option for checking the GPS chip for functionality...that's the most frustrating part of this whole issue...if it's hardware, replacing the phone is feasible, but I can't figure out if it's a hardware or software issue...
  19. redfield88

    redfield88 Well-Known Member

    Try typing this into the dialer app. *983*0# this is zte's built in diagnostic tool. Go to GPS and see if your chip is working. If this tool shows it as not working your GPS chip went bad.

    Displaying only a 0 means GPS is either turned off system wide or your GPS chip is faulty. I'd suggest doing this from a stock nandroid.

    Sent from my ZTE-Z990G using Tapatalk 2
    reverendfreeze likes this.
  20. kingmt

    kingmt Well-Known Member

    You don't need a PC to restore a nandroid.
    reverendfreeze likes this.
  21. Well, I've tried several times, and hitting "GPS Test" gets one of two results...either I get "Emode (com.zte.emode) has stopped working unexpectedly [Force Close]", or it goes to a black screen for a few seconds and then dumps me back into the dialer...which is similar to the result I get from other Diagnostic apps...
    That is, of course, when I actually get INTO emode...half the time, *983*0# does absolutely nothing...
  22. Ok...so what is a nandroid, and how do I restore one?
  23. redfield88

    redfield88 Well-Known Member

    A nandroid is a backup of your phones system. It's created and restored by ClockWork Recovery. You should've made a stock backup when you first rooted your phone. If you didn't use the forums to find one someone provided.

    Based on the error, I'm guessing you removed zte.emode thinking it was bloatware. If that's the case, You only need yo restore that file and not flash a stock nandroid.
    Sent from my ZTE-Z990G using Tapatalk 2
    reverendfreeze likes this.
  24. I don't think I have clockwork recovery...It was mentioned in the root instructions I followed, but I never found it to install it...as for Emode, both emode.apk and emode.odex are present in /system/App...i used Titanium Backup to backup my phone apps, but don't have the paid version, so it only holds one backup history, and those backups were all made after the GPS stopped working...

    So how forked am i? Are we talking sand in the vaseline, or dry and rough? Can someone post a link to a stock nandroid, and if I find one, can I even install it?
  25. On a side note to both kingmt and redfield88, I can't express enough thanks for your help on this, or enough gratitude for your patience with my ignorance...I know this is what you do, but it seems to me that you guys are going above and beyond the call for me, and I appreciate it...if we get this fixed, I owe you both a nugget!

Share This Page