[Merit] [ROOT] ZTE z990g Merit (An avail variant?)

Last Updated:

  1. jcase

    jcase Well-Known Member

    Mods: If a more appropriate forum exists please move this, but the Merit (z990g) is most like the Avail (z990?)

    Root for ZTE z990g aka ZTE Merit
    by jcase - jcase@cunninglogic.com - Justin Case (@TeamAndIRC) on Twitter
    June 16 2012 - Copyright 2012 CunningLogic
    Do Not Distribute or republish without permission. (Sad that this is needed, but people/blogs like to profit off the work of others without credit)

    Want to support my work? Donations are always appreciated, but never required:

    Paypal: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=LZ62YFU3XCEK8
    Amazon Giftcards: jcase@cunninglogic.com

    Required files:

    Unzip chaindsdd-su.zip and then get a shell with adb

    Code (Text):
    1. adb shell
    Set up the dirs, so shell owns them prior to logging. If shell does not own them then we can not control them. If the logs dir already exists, you may have to do a factory reset to remove them. They should not exist unless someone attempted this previously.

    Code (Text):
    2. mkdir /data/local/logs
    3. mkdir /data/local/logs/kernel
    Open emode's logset activity. First button should be for enabling log set, enable it. Do not exit the activity, but if you do just repeat the below command.

    Code (Text):
    1. am start -a android.intent.action.MAIN -n com.zte.emode/.logset
    Confirm the log_kernel.txt file exists, if it does not wait a minute and check again.

    Code (Text):
    1. ls -l /data/local/logs/kernel/log_kernel.txt
    If it exists, delete it and immediately symlink it to /data/local.prop, logset may recreate it, if it does delete and try symlinking again.

    Code (Text):
    2. rm /data/local/logs/kernel/log_kernel.txt
    3. ln -s /data/local.prop /data/local/logs/kernel/log_kernel.txt
    Now we want to wait for /data/local.prop to be created, it may take a minute or two. Keep checking until it exists.

    Code (Text):
    1. ls -l /data/local.prop
    Now once /data/local.prop exists, go back to the logset activity and disable logset. If you don't disable it, it will slowly eat away at all the disk space, and possibly overwrite the local.prop before you get root. Now lets set qemu=1 then reboot.

    Code (Text):
    2. echo 'ro.kernel.qemu=1' > /data/local.prop
    3. exit
    4. adb reboot
    Once you have rebooted, remount, install su.

    Code (Text):
    2. adb remount
    3. adb push su /system/xbin/su
    4. adb shell chown 0.0 /system/xbin/su
    5. adb shell chmod 06755 /system/xbin/su
    Clean up your mess!

    Code (Text):
    2. adb shell rm /data/local.prop
    3. adb shell rm -r /data/local/logs
    Reboot, install the Superuser app from the market and enjoy

    Code (Text):
    2. adb reboot

  2. pmollohan

    pmollohan Member

    Delete me
    Last edited: Nov 23, 2014
  3. stayboogy

    stayboogy Well-Known Member

    so you did it and got it working just fine???
  4. pmollohan

    pmollohan Member

    Delete me
    Last edited: Nov 23, 2014
  5. stayboogy

    stayboogy Well-Known Member

    worked perfectly and without a hitch

    thanks jcase, you rock!!!!!!!!
  6. Chud1

    Chud1 Active Member

    Nice work!!! 100% working!
    You DA MAN!!!!

    Thanks a million.

  7. Noname4aday

    Noname4aday Member

    Do you have to change rom when rooting? If you don't can you still run off an sd? And move useless crap? New to android
  8. Motorhead1991

    Motorhead1991 Well-Known Member

    You do not need a new ROM, moving apps to the sd card is a native feature of Froyo and Gingerbread. Using a root browser with the right permissions (like ROM Toolbox) will allow any app (system or user) to and from the sd.
    Noname4aday likes this.
  9. ziggily

    ziggily New Member

    Hi i get all the way to the final few steps where you install "su" but i cannot do that part,
    it says "adb not found" or it comes up with a different one saying how it cannot find the file or directory of the file su i dont know exactly where i unzip that file or where i should save it or just leave it in the downloads? i also tried putting into my sdk manager under tools that didnt work i even extracted it there please help!
  10. ziggily

    ziggily New Member

    [Root] ZTE z990g aka ZTE Merit - Development - RootzWiki
    logikal on the link above has the same problem as I am having but he says he fixed it but I have no idea what he is refering to in his wording of the scripts or whatever it is he did I am new to rooting and would love to have this done because I love my phone please reply I will be checking frequently I just need to figure out how to load the SU into my phone since its not recognizeing it or wherever i need to save it thanks!:D
  11. Motorhead1991

    Motorhead1991 Well-Known Member

    Copy su to your SD card, mount the phone as rewritable and move it there yourself.
  12. ziggily

    ziggily New Member

    Its as simple as either of these two fixes after a few hours i found a old post about a tablet being rooted heres how i fixed it and did it to my zte thanks and hope this helps someone else ! credit for below info to JJBOVE!


    You need to open the command prompt in the same folder as ADB. You could either (assuming your on windows)

    1) hold shift, and right click anywhere there is blank space inside the folder with ADB, and you should get the option
  13. Motorhead1991

    Motorhead1991 Well-Known Member

    You can also push from an alternate directory, like so: adb push c:/android-sdk/platform-tools/su
    adb push c:/Users/(your name)/android/su
    (these are examples and may not be the directory your file is in)
  14. Timmers10

    Timmers10 New Member

    I get stuck on this part -- says "The system cannot find the path specified." Anyone have a clue what this could mean, or what I could need to do? Many thanks in advance :)

    EDIT: Never mind, got it figured out.
  15. CelloMistress

    CelloMistress New Member

    It works until here...

    Once you have rebooted, remount, install su.

    adb remount adb push su /system/xbin/su adb shell chown 0.0 /system/xbin/su adb shell chmod 06755 /system/xbin/su
    I keep getting "cannot start 'su' : No such file or directory"
    I tried changing the location of the su file and everything and it's still not working.
    SO FRUSTRATED. I have no idea what the heck I'm doing and to be this close to rooting my phone and then it not working is so annoying. Dx

    Where the heck exactly does the file need to be located at so that these directions will work?

    EDIT: I read Motorhead1991's post and got it to run the first part. It brings up a huge menu. I try doing the chown part and keep getting the same error. I changed it so it would be the correct directory and it still won't work. :(
  16. dinat411

    dinat411 Member

    While trying to root my ZTE Merit, all steps thru reboot are Ok. But, when I enter "adb remount" I get the error below. I tried just "remount" too...same error appears. I searched threads and didn't see a "remount" issue discussed. Help please!

    Shows ...
    # adb remount
    adb remount
    adb: not found
  17. Noname4aday

    Noname4aday Member

    I stuck here too remount remount failed operation not permitted any help will be great
  18. Noname4aday

    Noname4aday Member

    Remount successful but adb push su /system/xbin/ su cannot stat su no such file

    After this I found I had to cd c:/program files/android/android-sdk
    Then do... adb push su c:/program files/android/android-sdk/tools/su
    Then download super user before root completes just hope to help someone
    O and he never said about dnwld adb tools before you start so you can put the file in the tools folder
  19. dustyj

    dustyj Member

  20. dustyj

    dustyj Member

  21. jamespfassett

    jamespfassett Well-Known Member

    Its just not working, I dont know why.

    My question is this...
    Can anyone out there walk a complete noob (myself) through rooting this phone using plain english?
    Im not a hacker, dont know the lingo and stuff. I get through all of the steps and reboot and nothing happens. What am I missing?


    EDIT: ROOTED BITCHES!!! Planning on sending JCase a little gratuity too, now if I can just find the thread on recovery images for the merit...
  22. yamataz

    yamataz New Member

    oops double post
  23. yamataz

    yamataz New Member

    im with james on this one, and would be wiling to use tsviewer to get this done ASAP. the 17mb of free internal storage is quite annoying, as i have a 32gb sd card installed.

    ANY help would be gretaly appreciated, TY
  24. PoorBoy52760

    PoorBoy52760 Well-Known Member

    if you have root and cwm and someone can do a nandroid from a factory reset so all your data is not in it, me and the guys at androidarea51.com will be happy to put together a new rom, and kernel tweaks that will work like the ones on the precedent to increase the internal storage using a /sd-ext partition on the SDCARD
  25. PoorBoy52760

    PoorBoy52760 Well-Known Member

    the guys at androidarea51.com have a CWM INSTALLED Kernel that needs tested this will kernel is basically stock with the addition of ext4 enabled to make it so they can add remounting /data on /sd-ext and work on a 900mhz OC. for it also.

    Need to know if its bootable or not, STOCK kernel is also in a CWM Flash Just incase download BOTH but them on your sdcard and give it a shot.
    Russ71 likes this.

Share This Page