Message counter shows wrong value.Support


Last Updated:

  1. dmantamp

    dmantamp New Member This Topic's Starter

    Joined:
    Oct 28, 2012
    Messages:
    3
    Likes Received:
    0
    Hi all,
    On my S3, the message icon always shows there are two message( number 2 at the top right side of message icon). I don't have any unread message. Even if get messages the number does not increase. I tested this by sending three SMS from a different phone and I recived them. But the icon still shows 2. I installed an application that was telling it can reset the count. But it didn't work.

    Any help ?


    Thanks
    DM
     

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Are you rooted?
     
  3. dmantamp

    dmantamp New Member This Topic's Starter

    Joined:
    Oct 28, 2012
    Messages:
    3
    Likes Received:
    0
    No. I have not rooted. I have upgraded to JB sometime back,
     
  4. Shotgun84

    Shotgun84 Well-Known Member

    Joined:
    May 30, 2011
    Messages:
    5,305
    Likes Received:
    3,101
    Welcome to the forum.

    I'm not sure if this fix is permanent but go to settings, application manager, all, BadgeProvider and clear data.

    I've moved this to the main gs3 forum. Maybe someone else will have some other ideas:)
     
  5. dmantamp

    dmantamp New Member This Topic's Starter

    Joined:
    Oct 28, 2012
    Messages:
    3
    Likes Received:
    0
    Thanks a lot. It worked.
     
  6. Perrorist

    Perrorist Member

    Joined:
    Apr 14, 2014
    Messages:
    15
    Likes Received:
    0
    I have a similar problem to the OP. In my case, it shows -1 when there are no mails. Whatever number is shown, there's always one more mail to read.

    I've tried the BadgeProvider clear data approach and it hasn't helped.

    I've recently updated to 4.3 but the problem remains.
     

Share This Page

Loading...