Messaging app won't "find" contact when you start typingSupport


Last Updated:

  1. ssr26

    ssr26 Member This Topic's Starter

    Joined:
    Dec 29, 2009
    Messages:
    9
    Likes Received:
    0
    My husband and I have moments. We both text quite a bit and for some reason, on his phone when you start typing a name in the "to" field of the text message, it does not give the option of choosing from matching contacts. But mine does. Is there a setting that I need to change? Anyone having the same issue?
     

    Advertisement
  2. Carl C

    Carl C Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,062
    Likes Received:
    38
    They should both be the same , there's no option to enable or disable this as far as I know so thats quite odd. are you both using the same sms app {Default or one downloaded from market}? Same keyboard even?:)
     
  3. ssr26

    ssr26 Member This Topic's Starter

    Joined:
    Dec 29, 2009
    Messages:
    9
    Likes Received:
    0
    Its an issue using the default messaging app and it happens with either keyboard. If it didn't work at all, I wouldn't care - I'd just install an app and call it a day. But the fact that it works on MY phone and not on his is bugging me! I have to know what the difference/problem is! :)
     
  4. agent0014

    agent0014 Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    394
    Likes Received:
    1
    I wonder if it has something to do with how the contacts are stored? Maybe even something as dumb as the formatting used for the phone numbers (###-###-#### vs ##########, etc).
     
  5. latinmaxima

    latinmaxima Well-Known Member

    Joined:
    Oct 15, 2009
    Messages:
    835
    Likes Received:
    111
    I think your right about it being the format I was testing this out. It will only pull matching suggestions. If he saves his numbers 1-xxx-xxx-xxx then that is what he needs to type. or if he saved it as xxxxxxxxx or xxx-xxx-xxxx then that is what he types. However she in this case is saying he types the name and it doesn't work. You may want to do a soft reset using the menu>settings>>sdcard>factoy reset. Make sure he backs all his info up. If that doesn't work I would suggest taking the phone in for an exchange?
     
  6. ssr26

    ssr26 Member This Topic's Starter

    Joined:
    Dec 29, 2009
    Messages:
    9
    Likes Received:
    0
    I figured it out! My husband had a Palm Treo prior to the Moment. When I exported his contacts from the palm and imported them into Gmail contacts, the "labels" (work, home, mobile) came over but as "custom" fields (though they showed up in contacts as actual named fields) so Gmail was not recognizing them as proper labels! The Gmail labels are the same but still, different. The only way I was able to tell the differance was that the Gmail labels have the first letter capitalized! I was so frustrated with the problem that I downloaded handcent (I was resisting because my husband does not have much patience for new programs he can't figure out right away) and when I initially downloaded it, all of the contacts showed up. When I chaged the settings, however to show only mobile numbers when texting, I was left with only about 4 contacts. It took me awhile, but I figured out the problem! Thanks, everyone, for your help!

    ps. you are probably right about formating, however, I was entering text recipeants by name, not number, so the number format wasn't an issue. Typing the name should automatically bring up the numbers/options.
     
  7. agent0014

    agent0014 Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    394
    Likes Received:
    1
    it was very very late and I was very very tired when I posted, but good to hear I managed to be right about something anyway lol. Glad you figured it out. Cheers!
     
  8. mazipani

    mazipani New Member

    Joined:
    Mar 13, 2010
    Messages:
    1
    Likes Received:
    0
    The messaging app only recognizes contacts whose numbers include a "mobile" option, and for good reason. But some of your contacts' numbers might be set to "Generic/Mobile" or "other." You simply need to edit those contacts' information, and change their mobile number's settings to "mobile," and the app will recognize them by name.
     
  9. Felecity

    Felecity Member

    Joined:
    Nov 11, 2009
    Messages:
    15
    Likes Received:
    1
    I'm a technician for Sprint and had the same complaint from a customer the other day. With the stock messenger, you are limited to just "mobile" numbers to text to. HOWEVER, if you install a third party messenger such as Handcent, then you aren't limited to just mobile. Try that out if you don't want to change all 100+ contacts. If you do prefer to change the contacts, then it would be faster to do it through gmail rather than on the handset itself.

    Good luck and welcome to Android! :]

    (I apparently, didn't read your response, OP. Sorry for the duplicate information.)
     

Share This Page

Loading...