1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Messed up my Root, Messed up my update


  1. Maddingo

    Maddingo Well-Known Member

    Hi,

    I rooted my phone with Unrevoked3. Then applied Unrevoked Forever. Then tried to update to 2.2 with the Update.zip method from the google server file. Phone kept rebooting and force closing. Attempted to Unroot which I am not sure I did properly. I also think my phone is still S-off. Tried to update to 2.2 after unrooting and get errors and it aborts. Now I am also worried that I will not be able to receive the OTA update. Any suggestions? Any way to make sure I am unrooted?

    Advertisement
    :
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    You had to unroot BEFORE trying to apply the update zip. There is a great stickied post at the top of this thread that will link you to any instructions you are looking for. Did you do a nandroid backup??? It is always suggested you do PLENTY of research before attempting anything that might harm a $600 phone.
    Maddingo likes this.
  3. Maddingo

    Maddingo Well-Known Member


    So what steps should I take now? Didn't do a nandroid backup since it was a new phone I had nothing on it yet. How do I know if I am still rooted?

    Thanks.
  4. cuban11182

    cuban11182 Well-Known Member

    Well first you need to be able to turn the phone on, all the way. Then download an app that requires superuser access, and see if you can grant it.

    So if you didn't do a nandroid, and for whatever reason you didn't get the ROM/Update to work, how exactly did you plan on getting your phone working?

    To see if you have S-Off, go into Hboot, it will tell you at the top.

    If you still can't get the update to work, and want 2.2, get a ROM from one of our DEV's and install it. Make sure you do a nandroid if your system is working fine currently.
    Maddingo likes this.
  5. sdrawkcab25

    sdrawkcab25 Guides Guide

    nandroid backups aren't really for backing up YOUR data, they back up the PHONE'S data, just like creating a restore point on a windows system; it lets you restore your phone to perfectly working state just in case something similar to what you did happens.

    An easy way to check to see if you have root is to download "Titanium Backup" from the market and see if it works or possibly look for the "superuser" program in your app drawer(you may or may not have it depending how you rooted your phone). You still have s-off unless you applied the s-on tool from Unrevoked.

    If you still have root just go ahead and download the official OTA rom on the xda-forums. It's EXACTLY the same as the update.zip that is being sent out OTA and will save you a lot of time and headaches especially if you want to keep your root status.

    [ROM] Incredible Sense/Froyo v3.21.605.1 *Official Release* (100% stock, rooted) - xda-developers
    Please read ALL of the instructions and make sure you understand them before doing ANYTHING. There is a lot of info out there that will help you. The "search" button and Google will be your best friend.

    If you did successfully unroot your phone, your best bet will be to just download the "RUU.exe" if you have access to a windows computer(preferably windows XP). You can also try to go the "update.zip" route, just make sure to do a factory reset AFTER you apply the update zip. The instructions located on this webpage are good and by looking around the forums have helped a lot of people.
    Howto: HTC Droid Incredible, Froyo 2.2, and root - Technology - Jonamerica.com

    There is also good instructions here: http://androidforums.com/incredible-all-things-root/162100-stock-2-1-fully-rooted-froyo-2-2-a.html

    Good luck! and remember when in doubt DO a nandroid backup and when NOT in doubt DO A NANDROID BACKUP! it will save you a lot of frustration.
    Maddingo likes this.
  6. cuban11182

    cuban11182 Well-Known Member

    +1
    Maddingo likes this.
  7. iowabowtech

    iowabowtech root@android:/ # Moderator

    You need to run the 2.1 RUU and get back to full stock if you're wanting the OTA. Verify at Menu > Settings > About Phone > Software Info.
    Maddingo likes this.
  8. dsb9938

    dsb9938 Well-Known Member Developer

  9. Maddingo

    Maddingo Well-Known Member

    Thanks all..I think I got it all working.
Loading...

Share This Page