Messed up settings on Galaxy S2Support


  1. garywc

    garywc Member

    Sorry if this has been covered previously -

    I tried to do the firmware update on my phone and It was all going well until the phone restarted after. it then came up with storage problems saying it could'nt complete due to not enough storage.

    after about a day i saw my internal memory had come back (11.**gb)

    but after all this the most critical part of the firmware must have failed as i can no longer access my settings so I cannot do anything with my phone. it wont connect to kies, wi-fi. bluetooth or even let me alter anything...

    I tried a factory reset. (power off. then vol up, power and home button) but still it comes up with errors.

    this is the error message i get" Sorry! the application com.android.settings (process come.android.settings) has stopped unexpectedly. please try again"

    also the settings cog image doesnt appear its just a green android man


    anyone shed any light into what to do??/

    Advertisement
  2. Hadron

    Hadron Well-Known Member

    Hi garywc, and welcome to AF,

    Sorry to hear you are having problems. Can you tell us what sort of S2 you have (GSM or CDMA, which network). It's probably best to ask in the device forum for this, but we need to know which type to know which is the correct device forum (there are a lot of different S2 variants!).
  3. dontpanicbobby

    dontpanicbobby Guides Guide

    Try loading your stock ROM using ODIN. There's a Guide called How to ODIN... in the S2 t-mobile forum.
  4. garywc

    garywc Member

    hi thanks for the reply, sorry its in the wrong location (new to this :eek: ) its the GSM and on Three network.
  5. Hadron

    Hadron Well-Known Member

    Three UK? OK, that would make it the "international" S2 version.

    I'll move the thread. I'm assuming the device isn't rooted.

    And no need to apologise :)
  6. garywc

    garywc Member

    yes three uk and no its not rooted (no idea how to do any of that)

    I have got kies to find my phone via USB and it says there is firmware update but when its doing it, now it says "insufficient space avaliable 3000mb required"
  7. garywc

    garywc Member

    Anyone know??
  8. kelis32

    kelis32 Well-Known Member


    Hello

    What is your current firmware ?

    As suggested you should update via ODIN, look at this thread for the files and instructions, these are stock unbranded firmwares

    http://forum.xda-developers.com/showthread.php?t=1544487

    You should update to the new JB I9100XWLS8 (top post)

    you can get the latest 3 branded ICS firmware here

    http://www.hotfile.com/dl/176389176/fc1a8fd/I9100XWLPY_I9100H3GLP7_H3G.zip.html

    and the instructions again are also here (although for the older firmware) the process is still the same

    http://www.androidauthority.com/galaxy-s2-gt-i9100-uk-carrier-3-three-i9100h3glp2-xxlpq-69704/

    Cheers
  9. garywc

    garywc Member


    Hi, im just downloading the JB I9100XWLS8 from the top link, do i also need to download the 3 branded ICS firmwares from the second link? then do i follow all instructions on the bottom link??
  10. kelis32

    kelis32 Well-Known Member


    That's actually your choice, if you want Jellybean or 3 branded ICS on your phone , JB has been updated to LSD but if you followed the link then im assuming thats what you are downloading.

    Once you have downloaded, the process is pretty simple as per the instructions posted and they are also on the thread you are downloading from

    Extract the firmware
    Open the included Odin
    Turn off your device
    Put your device into Download MODE (Home + Volume Down + Power)
    Click PDA and select *.tar.md5 in ODIN
    Connect your phone to USB
    Odin should recognise your phone on the com port which will be yellow
    Click start

    The flash process will begin , you can see this in ODIN in the com port, once finished it should show pass in green and your phone will reboot

    Once your phone is back in a stable condition you can decide if you want to root it and put on custom firmware etc etc

    any problems then just ask
  11. garywc

    garywc Member

    done everything you said, but the com port wont go yellow so i cannot download to phone
  12. kelis32

    kelis32 Well-Known Member


    Ok make sure the kies service is not running on your PC, if it is stop it through task manager, also check that you have USB debugging enabled on your phone, im assuming that you have put your phone into download mode as well

    Which version of ODIN do you have ? if 3 v3.04 try 3 v1.85

    finally if all that fails try a different USB port
  13. garywc

    garywc Member

    i removed Kies, and i cannot get to debugging mode on my phone as i cannot access my settings, and yes phone is in download mode.

    also running v3.04
  14. kelis32

    kelis32 Well-Known Member


    Ok get 1.85 from here and try that

    forum.xda-developers.com/attachment.php?attachmentid=581913

    can you just clarify by what you meant when you said you removed kies ?
  15. garywc

    garywc Member

    already downloaded that to try also, it doesn't do any different to the newer version. but when i plug my phone in via usb it comes up with found new hardware "gadget serial" and tries to install.... do i need to do this
  16. kelis32

    kelis32 Well-Known Member

    yes, let it go through the installation process, try installing the USB drivers again from here first

    http://forum.xda-developers.com/showthread.php?t=1982287
  17. garywc

    garywc Member

    got it all to recognise now but i try to start and it says "MD5 hash value is invalid"

    do i need to download a nother version of the update i have I9100XWLS8
  18. kelis32

    kelis32 Well-Known Member


    Yes go for the LSD version, on the same page you got LS8 from, its the latest version

    Just to confirm you are extracting the file from the zip and selecting that aren't you
  19. garywc

    garywc Member

    yes extracted it and i got I9100XWLS8_I9100XXLS8_I9100FOPLS3_HOME.tar.md5

    ile download the LSD version now
  20. kelis32

    kelis32 Well-Known Member

    ok could just be a bad download

Share This Page