Root Metamorph Issues

Discussion in 'Android Devices' started by brettlewis, Mar 13, 2010.

  1. brettlewis

    brettlewis Well-Known Member
    68

    Nov 3, 2009
    867
    49
    68
    Arizona
    Since updating to 2.1 roms, I have not been able to successfully apply ANY entire theme via metamorph.

    It will go through the entire application proccess, then it will get to the final step and my phone will reboot itself. It used to ask me if I wanted to reboot. However, upon the automatic rebot, the theme is only partially applied.

    Im using petes latest 2.1 rom, I tired using the theme he had, but I couldnt even extract it, it was missing the .thm file

    any advice? :thinking:
     

    Advertisement

  2. japus

    japus Active Member
    15

    Jan 6, 2010
    32
    0
    15
    Wichita, Ks
    if you are trying to use Pete's theme for his 2.1 rom, it is not to be installed using metamorph, that theme is installed using the update.zip method. Put the file in the root of your sd card, power off phone, enter recovery mode, install, allow update.zip, install update.zip, then reboot and enjoy. I have also heard that most themes for 2.0.1 will not work on the 2.1 roms. I tried one and nothing worked and looked right, had to do a nandroid restore.

    I am having a different problem then that. After I flashed pete's 2.1 rom, updated to v.6, and installed pete's smoked glass theme, I redownloaded metamorph and when I try to run it I get a message saying I don't have either enough memory in /system or busy box is not installed. I know it's not busy box because i reinstalled that. Is there anyway I can get metamorph up and running?
     
  3. brettlewis

    brettlewis Well-Known Member
    68

    Nov 3, 2009
    867
    49
    68
    Arizona
    Thanks for the info on that theme. haha. I should of though of that.

    on the other issue
    That actually is a busy box issue, it is not being given proper permission.

    get the app "terminal emulaltor" from the market
    [​IMG]

    then type this into the emulator
     
  4. brettlewis

    brettlewis Well-Known Member
    68

    Nov 3, 2009
    867
    49
    68
    Arizona
    installing from update.zip through me in boot loop...
     
  5. japus

    japus Active Member
    15

    Jan 6, 2010
    32
    0
    15
    Wichita, Ks
    sorry, I won't be much help with this issue, I had no problems installing Pete's theme. There is FAQ thread for Pete's roms, try looking in there to see if there is a solution, sorry for no link have to leave for work in a few minutes. And I will give the terminal emulator a try, thanks.
     
  6. shrink57

    shrink57 Well-Known Member
    143

    Dec 19, 2009
    1,529
    149
    143
    South Florida
    Hitting the "problems" button on Titanium's main screen will also help in redownload and reinstalling busybox and in my experience clears up many related problems. You still need 2.1 specific themes to run will on a 2.1 setup.
     
  7. planetj

    planetj Member
    15

    May 24, 2010
    21
    0
    15

    I just tried that.... It says "operation not permitted".
    Any ideas?

    EDIT:
    I found out i need to write su before the other stuff... Metamorph still doesn't work, though :/
     
  8. planetj

    planetj Member
    15

    May 24, 2010
    21
    0
    15
    Well, I give up... been trying for days, nothing seems to help.
    Too bad, it sounds like a cool app, for those who can make it work.
     

Share This Page

Loading...