[MetroPCS/CDMA] GPS not working?!

Last Updated:

  1. gianflavio

    gianflavio Member

    ......gps isnt working. well, navigation isnt working.
    gps finds my location just fine, but once i try to navigate, it just says "Searching for GPS..." and it doesn't do anything.

    just to make sure i installed some other navigation apps and none of them worked. they all showed where i was at, but none could guide me to another address. it doesnt even work with the wifi on!!!
    anyone having the same problem? any fix?

  2. Hunter5

    Hunter5 Well-Known Member

    Tried several apps from the market and no luck then installed Google Maps thanks to the advise from others on this forum and once I got all the google account stuff set up...worked like a charm.

    Good luck..hope you figure it out.
  3. confed

    confed Well-Known Member

    might just be a setting for ya. try enabling google location services under System settings - Location access.
  4. blasdomin

    blasdomin Active Member

    I have that problem, what I did?, ok. Go to Google search and turn on Google now, the app ask for turn on your gps and for permission to used for all apps from Google and that's end your gps work like new.

    For some reason Google need to ask for permission for gps to work
  5. ultra008

    ultra008 New Member

    I bought mine in Dec-2012. Two weeks ago, need to find an address and started GPS. All three applications, Google maps, 4.0.4 Navigator and Metro navigator keep saying searching for GPS. Spent two days with metro customer service doing "debug" and nothing worked (factory reset 2x times). Finally, SC says to take it to repair/exchange center. I call up the center and they want to charge $49 to order the phone from Samsung? Yesterday I called Samsung and after a brief discussion, they send me an RMA ticket to get the unit fixed.
    I tried everything on the net before calling metropcs sc. In the end it looks like majority of the units have faulty GPS and Samsung is keeping under wraps. Check your units on the road with only GPS enabled (Setting --> Location services). If the navigation app says searching for GPS after 5-mins, have your unit checked.

  6. Krew

    Krew Well-Known Member

    Yeah I bought my phone in December, the GPS was perfect. Up until about the start of January. It just doesn't work anymore, and I've tried everything to fix it. Including downloading calibration apps such as GPS Status.

    I'm guessing it's faulty hardware, but I don't think I want to waste money having the GPS fixed, I don't even need it. You would think it would be free since it's clearly a defect. :rolleyes:
  7. ultra008

    ultra008 New Member

    Hi Guys,
    Update on my GPS failure. Had to send out my phone 3x times to get fixed. Here is the breakdown for repairs.
    1. Tech updated the sw and checked the GPS, working fine at the factory. I get the phone back and its not working
    2. Tech replaced the LCD screen, update sw and GPS is working fine at the factory. I get the phone back and GPS is not working. Samsung asks me to replace sim card, since their sim card works at the factory and mine doesn't. Replaced sim card, still not working.
    3. Tech replaced the PBA board, GPS works fine. I get the phone back and GPS works for me too. In the end it was the PBA board that was defective and couldn't lock on to GPS signal.


Share This Page