[MetroPCS/CDMA] [MOD][Hooked-Up SecMms.apk Mod for SGS3-R530M TouchWiz Roms]

Last Updated:

  1. ARocker

    ARocker Developer Developer

    interesting...not sure what that means.

    edgees reported the same issue with the mc3 leak.

    mike28 likes this.
  2. ARocker

    ARocker Developer Developer

    Mike, did you have the 4.2 mms installed with #2?
  3. discua8

    discua8 Well-Known Member

    I had the same issue right now . I had to restore my phone to the backup I had I think its not compatible with #2
  4. ARocker

    ARocker Developer Developer

    Might need to flash after a fresh install...anyone wanna try?
    discua8 likes this.
  5. discua8

    discua8 Well-Known Member

    Okay im stock and rooted . I flash the zip and it seems like it deletes the messegin files for some reasons. I still have the icon but it says app not installed ... /:
  6. discua8

    discua8 Well-Known Member

    Im goin to try installing metropolis 1.5 nd see if it works
  7. ARocker

    ARocker Developer Developer

    weird....i just did a fresh install of #2 including a data wipe.
    after it booted i flashed the mod and it worked fine for me.
    i didnt wipe dalvic and cache after installing the mod.
    maybe thats killing it?
    discua8 likes this.
  8. discua8

    discua8 Well-Known Member

    That is just weird I dont know whats happening. Let me try installin #2 again but let mw download the latest version . Il post back with my result

    Im actually doin a wipe data and dalvid b4 I flash ?. You think thats whats killi g it ?.
  9. ARocker

    ARocker Developer Developer

    its possible...or more likely it needs to be installed after a data wipe. possible that existing data from the mms you had didnt play nice with the mod. wiping data cleans the slate for the mod.
  10. ARocker

    ARocker Developer Developer

    OP Updated!!
    Two Mod versions available!!!!
    One version DISABLES long texts to MMS conversion!!
    The other version leaves long text to MMS conversion ENABLED!!

    Results vary when flashing this mod OVER your current rom, depending on the rom.
    For best results, flash the mod after a factory reset and fresh rom install. I've been able to flash it to #2 rom in this way. Id like someone else to confirm this if possible.

    I'm thinking that app data may be the issue here and wiping data, either by factory resetting or by clearing Secmms.apk data and cache with an application manager, then flashing the mod, might avoid this. Id really appreciate it if someone tried this as well.

    Lastly if someone can test out the new version...that would be great!

    discua8 and mike28 like this.
  11. discua8

    discua8 Well-Known Member

    I just did a fresh install of #2 and im still gettin the same problem. Idk why . Goodthing I made a copy of my old messaging app. Lol.. this sucks. I really wanted this mod.
    ARocker likes this.
  12. mike28

    mike28 Well-Known Member

    Same here specially the new mod since I rather have the long text :(
    ARocker likes this.
  13. Pappy62

    Pappy62 Well-Known Member

    Okay... sorry about the delay guys. My SECOND Biostar motherboard fried last night. (stay away from their AM3 socket MBs if you build your own too)

    Update on my testing so far;

    Since I had all my ROMs stored on the computer that fried last night (SATA drives), I had to pull out the old backup machine (IDE drives) to get back on line until my new machine gets another MB... anywho,

    I tested this mod on Metropolis 1.1.0 and 1.2.0 - both worked fine.
    Tested on LD's first version on #2 - it worked, but not on any of the later versions.

    Oddly enough, even on Metropolis 1.2.0, after a while the SecMms.apk would just disappear. (???) I suspected my phone, because it's been loosing root sometimes after rebooting - SuperSU looses it's Binary, and can't update (and it's happening randomly - no rhyme or reason)... I seem to be plagued with bugs in just about every electronic device I own. lol

    Maybe it's time to save all the data on it, completely wipe everything and start over fresh. Apparently, just wiping System, Factory Reset, Cache and Dalvik between ROMs aren't enough. lol

    BTW - has anyone noticed any issues with TWRP in regards to dirty/incomplete wipes?

    I'm going to play around with it for a bit longer and get back to you guys.
    ARocker and mike28 like this.
  14. confed

    confed Well-Known Member

    Biostar has been notoriously bad with am3. Great with others though. Very budget friendly. Got my 2500k up to 4.5 with no issues. Board only cost me 30 when I bought it 2 years ago.

    Also TWRP has been updated. If you have goo manager just flash the newest. I did it this morning and I believe it was 2.5.
    ARocker and Pappy62 like this.
  15. Martin714

    Martin714 Well-Known Member

    this is usful glad i was able to test lol=p
    ARocker likes this.
  16. alexandroid5

    alexandroid5 Well-Known Member

    I tested it on hyperdrive ROM last night and my SecMMS.apk disapperared too, I tried installing it manually and I just couldn't get it to work. I might go back to metropolis to try it. By the way isn't TWRP latest version on 2.5? Or something like that? On some ROMs after I flash it tells me to fix my su binaries
    ARocker likes this.
  17. Pappy62

    Pappy62 Well-Known Member

    It was an A780L3C ver.7.0
    Biggest POS I've ever used. :mad:
  18. Pappy62

    Pappy62 Well-Known Member

    I'm updating it now... weird thing is, SuperSU only does this after I reboot, and not always - it's completely random... sometimes it'll run fine after rebooting, but then die a few minutes after boot. Earlier, I installed Superuser, and uninstalled SuperSU... so far, so good. We'll see how that goes...
  19. alexandroid5

    alexandroid5 Well-Known Member

    I'm on weinhzners (I spelled it wrong but something like that) ROM and I tried flashing it while I flashed the ROM and it didn't work and I tried flashing it after flashing the ROM and it still doenst work
    ARocker likes this.
  20. manesag

    manesag Well-Known Member

    OK so you said group messaging is supported. My friends (with I phones) have a group message and I'm in it but I get each text as a 1kb MMS message from each sender. Does this alleviate it and allow me to have a group convoy wiht them?
  21. imSHAD

    imSHAD Well-Known Member

    This is mainly a response to your old post with the screenshot. On touchwiz roms mms app is called SecMms.apk so thats what you should see in your system spp folder. Check again to see if it's there it wont just be called mms
    ARocker likes this.
  22. ARocker

    ARocker Developer Developer

    I don't believe so but you are free to test it out and report back.
  23. ARocker

    ARocker Developer Developer

    Thanks, everyone, for your help testing the mods :)

    Ok, I don't think twrp version has much to do with the issues. I'm not using the very newest (I'm on v2440) and I have yet to have a "disappearing" mms issue. But by all means, try anything.

    Those having issues can also try to install by renaming their current mms apk to something like Secmms.old and pulling Secmms.apk out of the zip and place it in the system/app folder manually and fixing permissions.

    I've been able to install on Metro v120 and v110 and both worked well.
    I've also managed to install it on #2 v103.
    Seems Metropolis plays best with the mod, perhaps because its closest to stock than other roms...maybe?


    Oh, and thanks for testing the mod on other roms peeps. I appreciate your feedback :)
    mike28 and Pappy62 like this.
  24. Pappy62

    Pappy62 Well-Known Member

    Okay... this is weird.
    I wiped EVERYTHING, just as before - nothing different, and re-installed Metropolis 1.2.0 from scratch. Again.

    Immediately went in, installed Superuser, uninstalled SuperSU, went back into TWRP, flashed the mms test, and now - it works.
    Almost 3 hours later, still working.
    ??? WTH??? :confused:

    I gotta wonder - is it just my phone? This doesn't make any sense...
    First everything's stable, then it isn't... now it is again...
    This has GOT to be my phone going nutz and not the SecMms.apk... or maybe it had something to do with SuperSU?
    mike28 and ARocker like this.
  25. mike28

    mike28 Well-Known Member

    I'll be honest guys what's app is just killing sms and mms have you guys try it

Share This Page