[MetroPCS/CDMA] [MOD][Hooked-Up SecMms.apk Mod for SGS3-R530M TouchWiz Roms]


Last Updated:

  1. ARocker

    ARocker Guides Guide

    Idk pappy...perhaps I need to tweak the installer script to do something more??
    I'm not familiar with scripts so I could use some help with that from someone who is more knowledgable.

    I simply can't explain why Secmms would disappear like it has for some.

    Advertisement
  2. ARocker

    ARocker Guides Guide

    I haven't mike
  3. mike28

    mike28 Well-Known Member

    I try it and I tell you it's amazing messages go through in a breeze pictures as well of course the only downside is that you have to have Internet signal so as I backup we use the regular message app sorry arocker didn't mean to stir off topic
  4. ARocker

    ARocker Guides Guide

    No big deal about off topic :)

    Its my thread...i do what I want :p
    mike28 likes this.
  5. Pappy62

    Pappy62 Well-Known Member

    Yes. It also comes in handy when you're texting someone that has to pay extra - i.e. - no unlimited plan with texts. (yes, I know... rare these days)

    It also means people will get your texts even when they're in an area without Mobile Data or Wi-Fi - whether it's unlimited for them or not. (When I'm out and about, I run into that more often than not)

    It's just my opinion, but I really think Metro should have considered that prior to releasing the phone... it would have been a nice "selling" point for their service, if you stop and think about it.
    mike28 likes this.
  6. ARocker

    ARocker Guides Guide

    That's right. Good points. Split texts will still go through, even on the slowest bands (1g?? :p) without a WiFi, 4g, or even 3g connnection... an mms won't.
    mike28 likes this.
  7. mike28

    mike28 Well-Known Member

    Excellent point pappy :thumbup:
  8. ARocker

    ARocker Guides Guide

    Reposted

    imSHAD and most recently Shabby pointed out that you should be looking for Secmms.apk and not Mms.apk...so there's that.

    Thanks for that gentlemen :)

    I'd like to get a tally of how many people have it working? Let me know what rom version and mod version ur using?
    Sweet
  9. theenextkb24

    theenextkb24 Member

    This is great, thanks a lot! I've always been annoyed by the MMS conversion. There is one problem, though: the conversations seem to appear out of order. In other words, if I send someone a text and that person replies back, that person's response will appear before the text I had sent. Unless, of course, it was meant to be this way? Anyway, thanks again!
  10. ARocker

    ARocker Guides Guide

    I could be wrong but i think thats just how it is. When it splits the message...it starts from the last thing you type, counts x many characters back from that, splits and sends that piece. It does this till it reaches the beginning of the text and sends the last piece. So they end up responding to the last thing you type, before they get the beginning.

    Glad that you like it! Glad its working for you! If you please, what rom are you running?
  11. Pappy62

    Pappy62 Well-Known Member

    Okay, update (v2.0 lol)

    If you read my last post concerning the SecMms.apk, I installed Metropolis 1.2.0 and deleted SuperSU, but only AFTER installing Superuser... I've since rebooted many times, in an effort to re-create the problem, but have not had the same loss of Root issue (and failure of the new SecMms.apk) that I had before.

    Barring further testing, I can only assume at this point that the problem was with SuperSU... hopefully I won't eat my words later, but that's what it looks like at this point.
    Can someone else please try this for me?

    1. Install Metropolis 1.2.0 (a CLEAN install, of course), and then boot into the ROM
    2. Go to Play Store and download the free version of Superuser. Open and update it's Binary.
    3. Go into SuperSU and select "Settings", then scroll down to "Switch superuser app". That gets rid of it. Do that, and then reboot.
    4. Go back into your recovery, and then flash the mms test.zip
    3. Reboot and try it out.

    Please report your findings.
    Thanks guys. ;)
    mike28 likes this.
  12. Pappy62

    Pappy62 Well-Known Member

    I noticed that too, but I'd like to find out what's keeping the thing from being 100% stable ATM... the message order sequence will be the next issue to work out after we get it working 100%.
    It's kinda like making a cart that just rolls first - before giving it independent four-wheel suspension. lol

    And on that note - great job ARocker! It's getting there bro!
    ;)
  13. ARocker

    ARocker Guides Guide

    There's not much more tweaking to be done with the mod. Seems that getting it to work depends mostly on how you install it.

    It works with stock deodexed, Metropolis and #2.
    It should also work with stock odex provided you delete the secmms.odex file but I have not tested.

    Most reliable way to install is to start with a new base. Factory reset, then flash the rom, then flash the mod. Barring any flash gremlins that happen from time to time that should get you working.
    Pappy62 likes this.
  14. discua8

    discua8 Well-Known Member

    i just reflash #2 latest version . i manually installed messaging app. and i got a reboot and then my messaging app disappear.... any thoughts
  15. Pappy62

    Pappy62 Well-Known Member


    Understood... I was referring to the message order sequence next spoke of... I have it too.
    You?
  16. ARocker

    ARocker Guides Guide

    Can you not find it in the system/app folder? Try following the method I used in the post above.

    Also if you are restoring data with twrp or Titanium backup it may cause an issue.

    Could be a bad download...try downloading the mod again.
  17. ARocker

    ARocker Guides Guide

    I don't believe its a bug or issue...I think that's just how it works. Ill keep my eyes open for a mod that changes that.


    This is what I wrote about it.
    Pappy62 likes this.
  18. imSHAD

    imSHAD Well-Known Member

    Tried it and didnt work for me
    Also tried going through to Secmms of the zip through a file explorer a install it as a normal apk... wouldnt install

    Just a thought here but could it possibly be the kernel?

    Maybe a fresh install works becuase we're going to stock kernel. (im on leankernel now)

    And as much as I want to use this mod. Im just not in the fresh install mood lol. Sorry about that.

    EDIT: forgot to mention using metropolis 1.2
    mike28 likes this.
  19. mike28

    mike28 Well-Known Member

    Just try as well fresh install of number 2 no luck :(
  20. alexandroid5

    alexandroid5 Well-Known Member

    Someone should try adding the SecMMS.apk to the ROM before flashing it. Basically unzipping the ROM switching apks and then zippjng it back. With win rar you can just throw it in the right folder while its zipped and it will only replace the apk file. Just throwing ideas out there :)


    *cough* added it to the next version of metropolis *cough* :p
  21. ARocker

    ARocker Guides Guide

    It could be the kernel...idk.
    Thanks for trying.
  22. ARocker

    ARocker Guides Guide

    Yes, that may work :)
  23. ARocker

    ARocker Guides Guide

    The crazy thing is...I have yet to experience one of these disappearing apk issues and Ive flashed this mod so many times. I flash all the time to test all kinds of stuff cause i dont like pushing files via adb. I rarely actually wipe dalvic when I flash and I almost never have an issue.

    I've noticed that this happens with roms like the new mc3 sprint leak, wisenheimer rom, hyperrom which require you to install a custom kernel to work on our phone and you guys on #2 i think all have lean kernel. Perhaps it IS a kernel issue?

    This is what I'm thinking peeps...
    With goodness rom there is a process that needs to be followed to install correctly. The same with the mc3 leak, wisenheimer rom, chemistry rom ect.

    Factory reset, flash rom, immediately flash a patch, then immediately flash the kernel. Try using this process but flash the mod right after the patch, then flash the kernel. See if that works.

    For #2, treat the mod as you would the patch for those other roms. Factory reset, flash the rom with stock kernel, then the mod. Let it boot up and check to see that secmms is there. Then flash lean kernel and see how that goes.

    I know its a hassle loosing ur data every time.

    I appreciate all your help :beer::beer::beer::beer::beer::beer::beer::beer::beer::beer::beer::beer::beer::beer:
  24. Get@Me

    Get@Me Well-Known Member

    This is how i got it working. Did a clean install of metropolis then reboot phone. when it's done booting up immediately reboot into recovery again and flash the mod and reboot. Hope this helps
    ARocker likes this.
  25. ARocker

    ARocker Guides Guide

    Thanks for your input. :):thumbup:
    There doesn't seem to be an issue with Metropolis rom. Must be the superior scripts :D

    more likely the kernel lol

Share This Page