Last Updated:

  1. Exel

    Exel Member

    Hey there,

    I know some people have been requesting this for quite some time! This couldn't have been possible without techguy1214 so a huge thanks goes out to him!

    This is the absolute STOCK M919N Firmware. (THIS IS NOT ROOTED!)

    EXPERIMENTAL: This is UNTESTED by me, I compiled this ODIN tar file using the same structure the T-Mobile ODIN File has. I do not have the MetroPCS version of this phone, I have the T-Mobile version. But I figured enough people wanted it so I would try to make it happen.


    NOTE: Because this is not officially signed by Samsung, I believe your flash counter will go up, use Triangle Away to reset your counter!

    Download the TAR file: https:// copy[.]com/lyMNNbzjaNYm

    Remove the space in front of copy and the [] from the dot in the link as I can't post links yet.

    mike28, ARocker and danyvw like this.
  2. danyvw

    danyvw Well-Known Member

    Downloading. Will post results. Thank you.
    Edit: Do not work, Odin crashes when starting to flash.
  3. Exel

    Exel Member

    What error did you get?
  4. danyvw

    danyvw Well-Known Member

    <ID:0/004> Added!!
    <ID:0/004> Odin v.3 engine (ID:4)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> NON-HLOS.bin
    <ID:0/004> NAND Write Start!!
    <ID:0/004> FAIL! (Auth)
    <OSM> All threads completed. (succeed 0 / failed 1)
    ARocker likes this.
  5. ARocker

    ARocker Developer Developer

    Any news? Is this working or isnt it?
    danyvw likes this.
  6. danyvw

    danyvw Well-Known Member

    The firmware never worked. Downloaded twice, tried to install many times with the same error.
    ARocker likes this.
  7. ARocker

    ARocker Developer Developer

    Too bad :(
    This would have been good for us.

    Hey Exel, thanks for trying. I see that the OP says Confirmed Working and Experimental is crossed out. Who tried it and got it working? Anyone in this forum?
  8. djlucklu

    djlucklu Well-Known Member

    ARocker likes this.
  9. danyvw

    danyvw Well-Known Member

    The user at xda is the same mentioned in the OP.
  10. djlucklu

    djlucklu Well-Known Member

    exel is techguy?:confused:
  11. danyvw

    danyvw Well-Known Member

    I think I wrote "MENTIONED IN THE OP" Not OP creator. ;)

    ""I know some people have been requesting this for quite some time! This couldn't have been possible without techguy1214 so a huge thanks goes out to him!""

    .......thechguy is the same user saying it works at xda forum

    I'm not saying it does not work for him, in my phone does not as I said before after two different downloads and 6 flash intents, and is not Odin related because I flash with it almost everyday. Right now I have an original MetroPCS S4 with T-Mobile M919UVUAMDL Firmware and Baseband. Maybe is a bad upload?????
  12. ARocker

    ARocker Developer Developer

    Yea, looks like techguy provided Excel the files from the phone and also tested it after it was uploladed.

    The <ID:0/004> FAIL! (Auth) error seems to say its an authentication issue. Could be a bad download, upload, or the original file was corrupt from the beginning. Perhaps you can check the md5 checksum of the tar? I didn't download it and wont be able to for a few weeks (i think) as I dropped mine and broke the screen yesterday :(

    The S4 didnt take the beating the S3 did :(

    Why dont you post the error you got on the xda thread danyvw...He may check that thread more often.
  13. danyvw

    danyvw Well-Known Member

    Update: as I said before I had to install T-Mobile firmware in my Metro GS4 and was trying to go back to metro stock but I got the same error many times with two different downloads and many flashing intents then decided to extract all files from the OP .tar, repacked modem.bin and NON-HLOS.bin in modem.tar and NON-HLOS.tar using Cygwin, flashed both files using Mobile Odin (which works flawlessly with the T-Mobile firmware) from that I got a UVUAMDL firmware with UVUAMF2 Baseband device, using TWRP restored the first stock backup I did of my Metro GS4. Result: A complete stock MetroPCS GS4 (rooted of course)

    ARocker: Sorry for your loss brother.
  14. ARocker

    ARocker Developer Developer

    Glad you got yours back to 100% man.

    As for mine...it was a perfect "corner of the phone" drop. I couldn't have hit it any better if I had tried to. Ive had busted screens on phones before where you can still see some stuff and still kind of use it...not this time tho. Thanks for the sympathy btw :(
  15. mike28

    mike28 Well-Known Member

    Damn bro that sucks you got insurance right?
  16. danyvw

    danyvw Well-Known Member

    I hope you have warranty ARocker (LOL I didn't bought it) price of GS4 LCD and Digitizer is around $250. Gorilla or not when they want to brake they brake for sure.
  17. ARocker

    ARocker Developer Developer

    Sucks...I dont think I do...I'm not sure. I'll have to call metro and find out...oh wait...I cant call Metro :p

    I'm gonna have to get another phone to use in the meantime. Thinking about the new S3 Metro has that uses Tmo GSM network (SGH-T999N) its a blue one :). Should have never given my old S3 away.

    I think the digitizer is working as I can hear it unlock when I slide and stuff but i cant tell 100% cause I cant see anything. I'll probably end up needing to get both, thanks for the heads up on the pain :) BTW front glass is fine :confused:

    I'm gonna stop hijacking this thread now :)
  18. nuttmeg

    nuttmeg Well-Known Member

    I'm going to try this, and post back.

    Arocker hope metro will let you get another device, I know that feeling when you break something expensive.

    Try assurion if you have insurance.

    Update: This tar didnt work.
    mike28 and ARocker like this.
  19. Exel

    Exel Member

    Sorry for the late reply guys, for some reason the .tar file apparently got messed up from the upload.

    Looks like someone else on here got it working now.

    But yeah, I'm not techguy, I'm Exel over at xda. :)
    nuttmeg and ARocker like this.
  20. lj27416

    lj27416 New Member

    @ARocket would you mind uploading the modem.tar of M919n please? i dont want to download the whole stock file for just that. :) thanks

Share This Page