MetroPCS Huawei does not connect to apps or internetSupport


  1. rigov

    rigov New Member

    I have a MetroPCS plan and was using one of their $29 phones. Everything worked, very slowly but it worked. All my apps, internet, navigation, app store for metro it all opened.

    I recently purchased a Huawei ascend, took it to the metroPCS store to get it activated, i paid $5. Didn't really test the phone much while at the store.

    Now on my new Huawei phone i cant:

    load mail@metro app
    Metro navigation - unable to connect
    Maps app -
    google internet search - unable to connect
    Android market place

    Basically the only thing i can do i call and text??? Getting cant establish reliable connection to server.

    Any ideas??
    Is it related to the 2.2 update?
    Is it possible to restore back to what it had before 2.1 and then reinstall update 2.2?

    I noticed the google voice app that someone else posted may not be on my phone, so many who ever did the update didnt do it right?

    also received a text from 502: saying free messages will stop automatically weird?

    Any help would be greatly appreciated.

    Advertisement
    :
  2. ShinySide

    ShinySide Disabled

    Did you upgrade your plan? You have to have the $50 a month plan.
  3. rigov

    rigov New Member

    Thanks for the reply. When i first purchased my plan I decided to go with the $50, because i was going to buy the galaxy indulge withing a week. I decided on ascend because of the price. So yes i do have the $50 metro plan. However now that you mention it, I did add a cheaper line for my mom, however that still would not explain how all the apps on the cheaper phone i had been using, that are the same on the ascend wont load or connect.
  4. starxpilot

    starxpilot Well-Known Member

    You bought an Ascend? Last chatter I had with PCS, its been discontinued, not sure if they were told to liquidate...

    Sounds like your Data may not be enabled on your phone, did you try checking the settings, wireless and network settings, Mobile Networks?

    Wonder how many stores are still selling it, last time I checked, around here no PCS has it..
  5. nuttmeg

    nuttmeg Well-Known Member

    you will have to call them or go to the store, i have seen this number of times, they think they put you on the plan but your really not once they double check it they will see, and upgrade you to the right plan. ;)
  6. starxpilot

    starxpilot Well-Known Member

    Wait, he can't do it himself via Activation?
  7. Scur

    Scur Well-Known Member

    This happened when I first got my phone, too. I'm not sure what their problem is, but one call should be all you need to fix it, and it doesn't take long.
  8. nuttmeg

    nuttmeg Well-Known Member

    yes *228 and say activate a phone.



    +1

    same happen to me on both phones and other people phones i have flash for peoples.
  9. NintenMat

    NintenMat New Member

    Hey, I too am not able to connect to the internet without using wifi. I use to be able to, but then I had to have my phone replaced because I dropped it, and ever since, I haven't been able to connect to the internet unless I use wifi. I tried calling *228 on the phone, and said activate a phone, but it said it was already activated. Can someone help please?
  10. starxpilot

    starxpilot Well-Known Member

    Have you updated the PRL? Besides it dropping and breaking your antenna..which is..ouch.

    Call *228 and press 5, see if your connection needs some update. Some Apps will need Wifi to work regardless of Data Connection.
  11. NintenMat

    NintenMat New Member

    Thanks for the advice. I tried calling and pressing 5, and they did say that the connection was updated and will take 15 minutes to take effect. I've wait half an hour, but I still couldn't get a connection without wifi. So I tried calling again, and once again they said the connection was updated, and yet I still can't get a connection. Btw, I'm trying to connect to the Opera browser, which, albeit slow, I was able to do without wifi before I got my phone replaced. Now it just says "Connection failed. Unable to connect. Review connection settings." My connection settings are all default, with data enabled.

    One thing I just realized is that my phone doesn't have the "1x" with the up and down arrows symbol, or the 3G symbol, on the status bar like it use to on the status bar. Does that mean I'm getting no data connection at all?
  12. nuttmeg

    nuttmeg Well-Known Member


    after you update the prl, you need to reboot the phone but also as long wifi is on the 1x will not show up.
  13. NintenMat

    NintenMat New Member

    Hmm... rebooting did not fix the problem, and yes, wifi was off the whole time. I have PRL version 3019, which is right one, I think? Another thing I noticed was after I rebooted and checked the status screen in settings, for "Mobile network state" it said connecting for a bit, and then switched to disconnected. Does this pertain to the data? And if so, why wouldn't it connect? I know my area is covered, because I had the 1x before I had my phone replaced. Again, thanks for the continual advice.
  14. nuttmeg

    nuttmeg Well-Known Member

    best thing to do is take it in, phone might have become internal defect, and yes if it says disconnect and wifi not on than its a network problem.
  15. starxpilot

    starxpilot Well-Known Member

    I think we're all on 3020, PRL version.

    I have to agree with Nuttmeg, really does sound like something else is going on. Your best bet may be taking it in for service.
  16. Kaylagotmilk

    Kaylagotmilk Member

    I'm having a similar problem with my MetroPCS Ascend. The only time it ever works is when it's on wif, which is becoming extremely annoying. I use to have a 1X, but recently it changed to a 3G and that's when my problems started. I just got the 2.2 update on September 4th. And the lady at the MetroPCS store was no help so, any suggestions?
  17. starxpilot

    starxpilot Well-Known Member

    Have you tried resetting your Data, turning off Wifi, turning on Airplane Mode, taking battery out of Phone for a little bit, etc?

    Don't mention 3G or anything to Metro, they'll deny it and be hard asses about it, just go back and say your Data isn't working correctly.

    I've heard people having issues with 3G and actually want to turn it off, but as far as I remember, since Metro Denies it and doesn't 'officially' support it, there is no built in toggle for 3G.

    Although, I can't say 1X was better, 3G is faster, but still buggy at times, but that's Metro.
    Kaylagotmilk likes this.
  18. Kaylagotmilk

    Kaylagotmilk Member


    I have tried all of that, but nothing seems to work.

    But thank you so much! I'll go to the Metro store. I don't know if there's anything they can really do, but I guess trying won't hurt.
  19. Gmash

    Gmash Well-Known Member

    You need to call customer service and tell them what's going on and they will probably be able to re set the data connection on their end or something. The store will probably be no help. They will probably just tell you the same thing I just did.
    Kaylagotmilk likes this.
  20. vernely

    vernely New Member

    What is customer care number ?
  21. KOLIO

    KOLIO NOTEoriously XPOSED Guide

    WELCOME to ANDROID FORUMS,VERNELY!:D

    Try these #'s for Customer Service

    CRICKET : 1-866-384-4425

    METRO PCS: 1-800-901-6266 or 1-866-863-8768
Loading...

Share This Page