1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[MetroPCS] MertoPCS-->CM10.2-->Brick-->T-mob stock FW Working

Last Updated:

  1. gromit0010

    gromit0010 New Member

    Read on I bricked it and got it back. I think some of you might find this helpful as I had to learn the hard way. As of this date there are no stock recovery ROMs for the MetroPCS S4; so if you botch a flash or have to return or repair the phone you cannot go back to stock. Most may also know that the T-mob TWRP and CWM recoveries are functional on the MertoPCS S4. The first thing I did after I flashed TWRP with Odin was make a clean non-rooted backup. I then rooted which worked at that time.

    I then flashed a few T-mob roms and wanted to get back to my original MetroPCS 4.2.2 recovery. I was able to return to stock but when I attempted to root as before I was able to install SU but did not have root. Small detail, when I recovered I was prompted by TWRP to root so I did but then ended up installing root manually as I had before. So I wiped cache, flashed back to another ROM, then recovered again and rooted. Still had root but no root permissions. I should have left it be an waited for a more calculated solution.

    Well, I ended up wiping just about everything possible in TWRP which was, looking back, a bad idea. I had to put my recovery back on my SD card and load up TWRP only to find that TWRP could not see the recovery directory or files on my SD card. But, if I selected the install option it was able to see my files and directories just fine. Bottom line, I was now stuck in a boot loop and TWRP was not recognizing my recovery (which I did copy over multiple times to the SD). So now I had a two day old 600 dollar brick.

    Finally I decided to flash the T-mob stock ROM with Odin. Thankfully it worked and I was back to stock but on a T-mob Rom. The phone now read to be a SGH-M919 not the SGH-M919N, TWRP was removed, and the ROM showed the be official by Samsung. I tried the free GSM unlock procedure which now worked on the T-mob rom. The process did work as described but my phone is still locked. I still intend to return to MetroPCS 4.2.2 if possible but TWRP still not seeing my recovery files in the restore option. I still have service and my phone works fine but I would like to get back to stock if possible. Any help with the TWRP issue would be welcome. Hope this helps some of you all.

  2. dcap0187

    dcap0187 Well-Known Member

    Just use cf auto root get your stock recovery back and flash either twrp or oudhs cwm and use the stock backup that you created or the one nuttmeg made or mine with oudhs cwm recovery. All information you need is here. i've herad of issues with the 2.6.x.x versions of twrp use the it seems to be the more stable version.
    ARocker and nuttmeg like this.
  3. gromit0010

    gromit0010 New Member

    I booted into TWRP did a SD card wipe and put my MetroPCS recovery back on the SD once more. I placed the folder named "TWRP" in the root directory of the SD and booted into TWRP. TWRP found the recovery this time and I was able to recover my stock unrooted MertoPCS 4.2.2 recovery. I think I may have had my recovery in a folder that was not named "TWRP" before but I am not sure. I used the CF-Auto root and was able to get root to work again.

    New problem of course...even though I am back on stock MetroPCS my phone model is still designated as SGH-M919 not the original SGH-M919N. Once booted an error in the notification bar appeared.

    "Prevention information
    The device has detected an application attempting unpermitted actions and has stopped loading. To protect your device, it is recommended you reboot."

    I am now unable to turn on WiFi and if the notification does not initially appear it does when I attempt to toggle WiFi on. I rebooted as directed with the same result. I flashed TWRP again, booted into TWRP, did a good wipe and restored the MetroPCS recovery again with the same notification. I did another CF-Auto root successfully, which restored stock android recovery and erased TWRP. I booted into stock android recovery and did a factory wipe and reset. The phone booted up and prompted me for the initial setup. Ok so this must really be stock factory reset or as close as I could get. Nope WiFi will not turn on and notification is still there. (by the way phone service was still working when I recovered back to MetroPCS from the stock T-mob FW recovery)

    Well I actually need WiFi and I do not like errors so I Odened back to T-mob facory FW recovery. Unlike to first time when the phone booted into T-mob recovery I was initially prompted for setup but several message started to pop up like S Health was unable to run or Gmail has stopped and so on with several other applications. This caused the phone to run really slow and almost freeze. I CF-Auto rooted to gain stock android recovery, booted into recovery, and did a factory wipe and reset. Phone booted no problems, no errors and no notifications.

    One more thing...as Jobs would say. Although not an error if WiFi calling is enabled you will be continually prompted to update your T-mob sim card with a valid address for emergency services. That would normally be an easy fix but I'm using a MetroPCS sim card and I do not have a T-mob account or service. So I just turned off the WiFi calling. I still want to cry, this took way way to long to iron out. Bottom line, if you soft brick do everything possible to recover your backup without overwriting the actual FW. A solution might even take a day or two to find help. Just wait. The alternative is do what I did. Not cool. Can not wait till a MetroPCS stock FW comes out; till then T-mob will do.
  4. dcap0187

    dcap0187 Well-Known Member

    Try my oudhs cwm recovery method. You can always change your recovry later. Just follow the instructions.i really would like to see if you can Achieve stock.
  5. ARocker

    ARocker Developer Developer


    Sorry you had to go through all that. While unfortunate, your ordeal is the product of over zealous flashing and not enough reading. While you may have been a pro with whatever phone you had before, new phones sometimes require a re-learning process.

    I also flashed the most recent version of TWRP (2600). Luckily, I noticed right away that there was an issue with it. So I posted about it before doing anything else and thanks to the good people in our forums (Shabbypenguin and nuttmeg), I learned that the Tmo S4 had issues with TWRP 2600 and as a result our (Metro) S4 would probably have issues with 2600 too. I was told instead to try TWRP 2500 (like dcap0187 pointed out to you) and it works great.

    After your initial post and dcap0187s answer, I read that you flashed TWRP 2600 again, after being told that there might be issues with it. Why would you do that?

    Lastly, we HAVE two stock Metro firmware images available. One for TWRP 2500 and another for CWM based recovery and both are posted in this very sub-forum. I haven't had the need to use them personally (i have my own working backup)...i'm fairly certain they are both working and are from the Metro S4. Here are the links again, in case you missed them....


    [Stock Backup] Restore Using TWRP

    stock no-root cwm based backup
    nuttmeg and mike28 like this.
  6. gromit0010

    gromit0010 New Member

    Although for warranty purposes I do miss having a MertoPCS FW or stock ROM, I am getting along just fine without it. After all this happened I moved to the WICKED ROM v6 for T-mob and things have been working flawlessly. Tether works out of the box and almost all apps, fonts, launchers can be changed, added or removed, and selected before install and initial boot up. All Touchwiz functions are intact and as mentioned the Samsung apps can be installed or removed in the recovery setup before install. Best custom GUI in recovery I have ever seen let alone any GUI at all in a ROM. The Google play camera and the MotoX camera are also available for selection and install which was cool I thought. Battery life usually last two days with a few calls and some browsing and gaming; I suppose standby could last quite some time. I have yet to find any bugs or hangups in this ROM. If you prefer Touchwiz there is no reason why you should not be using this ROM.
    mike28 likes this.
  7. nuttmeg

    nuttmeg Well-Known Member

    you should try infamous or the newest darth stalker v8, it bad arse. :D
    mike28 likes this.
  8. danyvw

    danyvw Well-Known Member

    Had the same problem yesterday, trying to install Infamous my phone got bricked, couldn't restore any backup thru TWRP, the only way I could restore my phone was installing T-Mobile official Tar thru Odin because we don't have the original firmware for this phone. After that re rooted with CF Root, reinstalled TWRP and tried to restore to MetroPCS original backup made by nutmeg but the phone is not able to get WiFi and showing SGH-M919 (same error as gromit00)
  9. ARocker

    ARocker Developer Developer

    Phone wasn't bricked, it probably just bootlooped. Ive been reading that a lot lately round here with Infamous, though, I havent had any issues with Infamous myself, what version did you install?


    What version of TWRP were you using?
    What happened when you tried to restore backup the first time? Did it give you an error?

    Its weird that it wouldnt let you restore, I dont think it had anything to do with Infamous.
    Have you factory reset since this happened? It sounds as if there are still Tmobile stuff leftover from the tar you flashed. Perhaps its in data? Have you tried formatting data?

    gromit00 said he fixed it by flashing Wicked rom, you can try that. Funny thing is that I think Wicked rom is made by the same dev as Infamous. They are very similar.
    nuttmeg likes this.
  10. nuttmeg

    nuttmeg Well-Known Member

    I sure hope you didn't go under advance and tap format data. :confused:
    ARocker likes this.
  11. danyvw

    danyvw Well-Known Member

    Was using TWRP 2.6.1 but uninstalled and installed 2.5 and got the same result. The error was at the time of restoring data, all the time TWRP stopped and said: Restore Failed (using different backups) I'm almost sure Infamous did something in data.
    The problem is after installing T-Mobile original firmware then rooted, TWRP installed I was able to restore any backup (even nutmeg stock) but after that our S4 is unable to get WiFi working. Went back to T-Mobile firmware, WiFi works flawlessly but I'M unable to WiFi calling and My Metro app do not work.
    Now is like having a T-Mobile S4 working in MetroPCS (like BYOD) Lol.
    If we were able to get our SGH-M919N original firmware I could flash it via Odin and everything will go back to the beginning but for the moment I have to stick with T-Mobile firmware.
  12. ARocker

    ARocker Developer Developer

    Is that bad nutt? I think ive done it before :confused:
  13. ARocker

    ARocker Developer Developer

    Yea, our phones dont seem to like TWRP 26+.

    lol Of course Infamous did something in data...it installs apps. I dont think it caused your restore issue. The fact that TWRP couldn't restore your backed up data is down to either TWRP itself or the back up that you made with TWRP 26...I think lol. You should have tried to restore the system partition only after getting the error, effectively bypassing the data partition and the error. TWRP 2600 could be the reason Infamous didnt work properly from the beginning. Its all speculation at this point tho.

    The thing I dont get is why you dont have Wifi with the restored stock Metro backup...it just makes no sense to me. We gotta figure this out. Tell you what...I'm gonna stay away from that Tmobile backup until we do. Perhaps the phones aren't as identical as was originally thought. IDK. Anybody have any ideas?

    Have you tried Wicked rom yet? Now that you have the version of TWRP that works...you might want to try to flash another rom.
  14. danyvw

    danyvw Well-Known Member

    ARocker, I don't know what Infamous did but all my backups didn't work with TWRP 2.5 and 2.6, after installing T-Mobile UVUAMDL, rooting and installing TWRP 2.6 all my MPCS backups started working but without WiFi with a pop up window saying: prevention information the device has detected an application attempting unpermitted actions and has stopped loading. To protect your device it is recommended you reboot.
    Reading XDA forums found users with the same error when updating from UVUAMDB
    to UVUAMDL and trying to root. The fix was to install UVUAMDL firmware, then UVUAMDB kernel with SetUID Restriction Removed.

    The big deal with Metro is that when you install T-Mobile firmware there is something in the kernel that is never removed when you wipe data/system/cache/dalvik. You can run a Metro backup and everything works except WiFi and that is because of the T-Mobile Kernel is still there, then I did the same fix, over my restored metro backup I installed the UVUAMDB kernel with SetUID Restriction Removed and BANG! Wifi started working. What is funny is that when you do another backup restore with different restore point you need to install again the SetUId kernel fix again. That’s why I’m sure that is something with the kernel that is never removed/wiped even when you run a TWRP restore.
    Now I have a rooted Metro Galaxy S4:
    Device name: SGH-M919N
    Baseband version: M919UVUAMDL
    Kernel version: 3.40 matt@batakang #2
    Thu May 1918:00:21 PDT 2013
    With all features working on MetroPCS
  15. ARocker

    ARocker Developer Developer

    Ahh, the kernel...good info there danyvw. Glad you got it sorted out :)
    danyvw likes this.
  16. nuttmeg

    nuttmeg Well-Known Member

    sorry for late response but yes It can be, the phone will get stuck on the samsung screen and all kind of weird stuff will happen and also cause PIT partition to mess up when trying to flash in odin mode. had a hell of a time fixing it.
    everytime I booted the device it would also boot to a firmware screen telling me to connect to kies or something like that.

    fixing permissions didnt work for me, and after flashing stock recovery and twrp 10+ times, it finally fixed itself using the stock cables that came with the phone.

    here is a similar post to some peoples having this problem, http://forum.xda-developers.com/showthread.php?p=44629524

    ARocker and mike28 like this.

Share This Page