[MetroPCS] [recovery][official][twrp]

Last Updated:

  1. ARocker

    ARocker Developer Developer


    Team Win Recovery Project, or TWRP for short, is a custom recovery built with ease of use and customization in mind. It’s a fully touch driven user interface – no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    TWRP Frequently Asked Questions (FAQ)


    How to install TWRP and Root:
    Download Odin 3.07
    Download openrecovery-twrp- file
    If your phone is connected to your pc, unplug the usb cord from the phone and turn the phone off now!
    Extract the contents of odin-307.zip to your C drive. Do not try to extract the files from the .tar file.
    Run Odin 3.07.exe and if User Account Control comes up, click yes.
    Make sure "auto-reboot" is checked and uncheck all other options.
    Click PDA and select the .tar you downloaded. Leave other fields empty.
    Odin may freeze while it checks the MD5 signature. This is normal.
    Next put your device into Download Mode by rebooting and Holding Volume Down + Power. It may ask you if you want to continue, if it does, press Volume Up. You should now be in Download Mode.
    Now connect your device via usb and wait for it to be recognized by odin. The ID COM box should light up and say something if your phone is recognized.
    Click Start in Odin. You should see activity in the message box as it works.
    Your device will reboot automatically when its done.
    You now have TWRP installed!!!

    To easily root your S4, download Chainfire's CF-Auto Root and flash it with odin using the same method as with TWRP...

    or you can try Chainfire's SuperSU-v1.86.zip. Put it on your phones SD card, reboot to TWRP recovery, and flash it.


    Big Thanks to:

    This is a collection of of useful information for our S4 forum.
    I have nothing to do with any of these items except to say that I am a fan.
    I'm not responsible for anything you do to/with your phone.
    I'm happy to answer any questions I can, otherwise Ill refer you to the appropriate website.
    If you appreciate that I've brought this info together for you, then please hit the Thanks button below!

    tgif, exitprogram and robcop19 like this.
  2. nuttmeg

    nuttmeg Well-Known Member

    I flash twrp using odin on metro stock rom and it work.
    ARocker likes this.
  3. ARocker

    ARocker Developer Developer

    lmao...yea. Thanks! I literally just got some help from shabby. Thats what he suggested and it worked for me too!

    Think im gonna post the link to on this thread in case anyone wants it.
    nuttmeg likes this.
  4. nuttmeg

    nuttmeg Well-Known Member

    add it to op. https://copy.com/JrcTbCnVPKOI
    ARocker likes this.
  5. ARocker

    ARocker Developer Developer

    Hmm...how does one change the title of a thread? Do I need to contact an admin?
  6. nuttmeg

    nuttmeg Well-Known Member

    click edit on the op and scroll up and you will see the original title that you named it, you can erase it and add whatever you want. :)
    ARocker and mike28 like this.
  7. ARocker

    ARocker Developer Developer

    You guys must think im an idiot :p

    Lmao...I did that a bunch of times, but it never changed. I had to have an admin do it for me.
  8. unlimitedammo

    unlimitedammo Member

    touchwiz home crashes while trying to change the lock screen wallpaper.
  9. nuttmeg

    nuttmeg Well-Known Member

    If you have a modded TW launcher, than that will happen everytime. Just go to gallery and find the image you want to use, than tap on it or hit menu key and set as wall paper for home or home & lock screen.
    ARocker likes this.
  10. danyvw

    danyvw Well-Known Member

    Version 2.6 was giving me troubles and returned to, the other day installed and is working ok.
    ARocker likes this.
  11. ARocker

    ARocker Developer Developer

    Gonna install tonight :)
    Ill update the thread soon.
    danyvw likes this.
  12. ARocker

    ARocker Developer Developer

    Thread Updated!!
    mike28, danyvw and nuttmeg like this.
  13. ARocker

    ARocker Developer Developer

    Anyone else notice that is slow/laggy when doing just about anything (including starting/booting up) compared to
  14. nuttmeg

    nuttmeg Well-Known Member

    Thats why I havnt left, other versions are just minor things added that might have broke something that was good. :p
    mike28 and ARocker like this.
  15. mike28

    mike28 Well-Known Member

    Same here I'm still on Version 2.5.02 it's been solid
    ARocker and nuttmeg like this.
  16. noirelion

    noirelion Active Member

    Recovery without sdcard support isnt much fun. Sandisk Ultra 64gb class 10....not recognized.
  17. ARocker

    ARocker Developer Developer

    I've got a 64 I don't use because of this.
  18. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    mike28 and ARocker like this.
  19. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    you guys should be good to go now, goo manager should start working to detect you have recovery, however roms wont list due to the build.prop. once you flash a tmobile rom then it will all begin to work.

    all we did was take the tmobile twrp and put it in the metro folder, so no asserts failed etc, it would be like flashing it manually, but easier :)
    savtattoo, Rooqy, mike28 and 2 others like this.
  20. ARocker

    ARocker Developer Developer

    Thank you Shabbs!!!
    Everyone seeing this post should thank and like shabby's post (above this one).
    Let him know we appreciate what he does :)
    mike28 likes this.
  21. ARocker

    ARocker Developer Developer

    Tried installing TWRP via goo for the first time today shabs. It detects the phone and brings you to the download page for the jflteMertoPCS version, it counts down to zero but it gets stuck on "your download is starting". It doesn't start to download and times out after a while.

    Whats the best way to get in touch with the teamwin guys?
  22. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    tahts actually a goo issues, if you visit goo.im they are/have been doing server upgrades. they have craploads of poeple downloading from them and craploads of devs putting stuf fon there so even after an upgrade they are still bogged down.
    ARocker likes this.
  23. ARocker

    ARocker Developer Developer

    OK thanks man :)
  24. bigboss954

    bigboss954 Well-Known Member

    hey guys i was wondering if you can help me out, im not new to flashing but since i just got the metro gs4 i tried rooting it and i get a message on the home screen about supersu trying to access system on my device without authorization. yes i upgraded to 4.3.
  25. ARocker

    ARocker Developer Developer

    This thread http://androidforums.com/metropcs-galaxy-s4-all-things-root/810171-root.html
    seems to have a root that works for 4.3

    I would recommend doing a factory reset then flash the root above with odin.
    Good luck!

Share This Page