Metropcs S2 No GPS, MMS, or Youtube, Data not turning onSupport


  1. rpmsongs

    rpmsongs Member

    Got a sprint S2 yesterday, Had it flashed to Metropcs. Cannot get the GPS, MMS, or youtube to work and the 3G doesn't always turn on when I need it even when Juice Defender is disabled. GPS just keeps searching whether I'm inside or outside.

    I've read this is a common problem, I've read so many posts about how to fix them and it seems there are 5 different ways to fix each problem. If you've had the problem and fixed it please let me know how.

    Model: SPH-D710
    ANDROID VERSION: 4.0.4
    KERNEL VERSION: 3.0.15-1127689
    se.infra@SEP-98 #3
    SMP PREEMPT Thu Sep 27 18:24:35 KST 2012

    Under the Status>Network it still says Sprint, and the MSID is some other phone number. Is this normal?

    I apologize if this seems like a noob problem, I've searched and tried to do this on my own. I've never rooted, and I can't seem to find the Kernel version in the forums so that I could replace it.

    I'm going to be on the road starting Tuesday for a few weeks and would love to solve this problem in the next few hours if possible so that I can use the navigation. Thanks.

    Advertisement
    :
  2. captfbgnet

    captfbgnet Member

    Did you check that you have '3G data' on? Settings>More (Under Data Usage)>Wireless&Networks>Mobile Network. Make sure there is a green check mark in box...
  3. rpmsongs

    rpmsongs Member

    I did, I downloaded FasterFix, Gps Test, and GPS Status and tools. Ran all the fixes I could find including the AGPS fix from the XDA Forums.

    Rooted the phone, added new Kernel, CWM, and flashed the BLU Kuban ROM. No such luck on the GPS, other than that the ROM has a different mms app that works, and now I don't get 3G at all but I do get 1X all the time.

    Any Ideas on the GPS? Could it be that this new phone has a problem with the antenna? Is that a thing? Or is it likely that the guy that flashed to metro pcs forgot to put a check in a box or something? I am also getting a "system error 75" which is a sprint error and I don't have any sprint programs on this rom. Thanks

    Attached Files:

  4. rpmsongs

    rpmsongs Member

    Tried using *#*#1472365#*#* and nothing happens. Must have changed the code on new version s2's. anyone have the new code?
Loading...

Share This Page