[MetroPCS] Think I bricked my phone please help!

Last Updated:

  1. kbaes

    kbaes Member

    I have a Samsung Galaxy S4 (SGH-M919N) from Metro PCS.
    First I rooted it, then I flashed Cyanogenmod. I didn't like Cyanogenmod so I tried to flash it back to the stock rom. The problem is that there is no stock rom out there yet for my phone. So I used the stock rom for the T-Mobile version (SGH-M919). After I flashed it, the Cyanogenmod whirling blue circle came up so I knew something was wrong. It stayed on that circle for about thirty mins then I turned the phone off. Now, even CWM recovery won't come up(just the android laying on its back with a !red triangle above it) and anytime I try turning the phone on, it just goes back to the Cyanogenmod screen and stays there. Somebody please help me!

  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Have you tried reflashing your recovery through Odin?

    The stock ROM automatically writes the stock recovery when it boots on most of Samsung's devices
  3. kbaes

    kbaes Member

    Yes I just tried that and it still stays on the Cyanogenmod blue circle, anything else I can do?
  4. CrimsonPride

    CrimsonPride Well-Known Member

    if its still on cyanogen then you didnt use odin correctly.
  5. kbaes

    kbaes Member

    How do I get rid of Cyanogenmod then?
  6. ARocker

    ARocker Developer Developer

    If you check the sub forum you'll find that there definitely are backups of our stock rom available. Theres no need to flash the Tmobile rom.

    What you have is called a boot loop, not a bricked device. A boot loop is just what it sounds like...the boot animation (in this case, the Cyanogen boot animation) loops over and over. This can happen for a number of reasons and is easily fixed. Since it doesnt seem that you have CWM recovery installed any longer...I'm going to suggest you flash TWRP recovery instead. Relax...its easy :)

    Go to the first link and follow the directions and you'll have TWRP recovery installed.


    Then go to the second link and follow the directions to restore the stock rom that your phone shipped with.

    [Stock Backup] Restore Using TWRP

    After following these you will have the phone back to factory.

    Please....Read before you Do.

    Let me know how it works out :)
    exitprogram, nuttmeg and mike28 like this.
  7. kbaes

    kbaes Member

    What I ended up doing was reflashing the CWM recovery (sorry about that I did it before I read your post haha) and I did a factory reset of the data, partition, and dalvik. then I flashed VirginRom to the instead. And this seemed to work as I can finally use my phone now.

    Also it would be really helpful if you could link the stock rom for SGH-M919N because I can't find it. Thanks!
  8. ARocker

    ARocker Developer Developer

    No problemo. Glad you got it back :)

    You misread me. There is no stock rom that you can flash for our phone yet. What we have at the moment is a Backup of the stock android OS that can be Restored via TWRP recovery and one for CWM recovery too (they are not interchangeable). Its a good idea to keep the CWM backup on your phone in case this happens to you again.

    Heres the link for the CWM backup of our operating system:

    kbaes likes this.
  9. kbaes

    kbaes Member

    Awesome!! thanks so much for your help!! btw, can you explain the difference between the backup of the stock android os and a stock rom?
  10. ARocker

    ARocker Developer Developer

    lol, They're sort of the same thing actually, in that they are both operating systems that are compressed and packaged so that you can install it on your phone via recovery.

    I just wanted to be clear that i was talking about a backup of a rom and not a rom like VirginRom because rather than using "install" in CWM to flash it (like virginrom and cyanogen), you have to use "restore" in CWM to restore it. Cause its a backup (that someone made by hitting "backup" in CWM) of the stock android os from that persons phone (without the data portion, cause thats private). This is called a Nandroid and is compressed and packaged by the recovery and then posted by a helpfull user. Have you ever used the backup part of CWM?

    Now that your phone is running, you can boot into recovery and make a backup of what you have on your phone right now, including the data and apps, so that you can restore it back to that state whenever you need or want to.

    Just about every thread recommends making a backup before you flash anything....no one listens :( lol

    I glad my post was helpfull :)
  11. kbaes

    kbaes Member

    Okay I understand now! So I guess the only way to restore that backup is by restoring from sd card (I tried restoring from internal storage but it doesnt recognize the backup file) and the problem with that is that the backup is 2.11 gb and my sd card is only 2gb, is there a way around this?
  12. ARocker

    ARocker Developer Developer

    There's not much you can do about the file size except get a bigger sd card lol.

    I haven't used CWM in a while (preferring TWRP) but i think you can restore from the internal sd with CWM. You might have to select restore first, then look for something like "advanced restore" i think its in there, something like "restore from internal sd".

    Perhaps someone in-the-know can chime in here....
    kbaes likes this.
  13. dcap0187

    dcap0187 Well-Known Member

    create a folder on the internal called clockworkmod with a subfolder backup and drop the unzipped folder inside the backup folder. then when you boot into recovery choose restore, instead of restore from external sd.
    kbaes likes this.
  14. saferang

    saferang Member

    so i was trying to get back to an unrooted out of box state by following this guide, i wiped the disk with twrp and when i went to load the recovery files from the guide,i couldnt see anything in the browser window.nothing.so i am appreciating any help i can get as this is my only phone.(ya i know im stupid).i made a backup but i cant select it to do the recovery.:(
    i was able to load my backup and my phone is fully functional again,but i still cant load the stock_untouch files to return the phone to the out of the box state

Share This Page