MetroPCS Visual MailSupport

Last Updated:

  1. daveradiofm

    daveradiofm Member

    I'm starting this thread since I can't seem to find much on MetroPCS visual mail.

    I've rooted and flashed my Ascend to Gingerbread 2.3.4, and I absolutely love it. It's so much faster than the stock MetroPCS Froyo that was on the Ascend.

    I can use DSP Manager to crank up the levels on my headset, so I can take Napster with me in the car, and be able to groove without having to crank my stereo full blast just to get mild levels from the Ascend.

    My email is able to update so much faster as well. That was a problem that I had before and started a thread on it.

    I only have 2 problems left with the phone. The first is booting the phone which requires me to pull out my sd card, it hangs for some reason if it's left in there. Overclocking causes my phone to hang on boot as well, so I don't dink with that feature either. I've got a temporary workaround for this, so it's no biggie.

    On to my real problem, My metropcs phone service has added on to it MetroPCS visual phone which I was using with Froyo. I can't seem to use it on Gingerbread. I do have the MetroStore app installed and have success with their other apps like MetroNavigator. I get to installing the Visual Mail app, and I get a, "Provisioning Error. Check the data connectivity." MMS works fine, and I used the MetroOff zip to fix the issue.

    I tried calling MetroPCS during my break and was transferred to 2 different people, and after 20 minutes, I ran out of time on break and had to go back without resolving the issue.

    Anyone have any suggestion on fixing the settings on my phone. I tried adding the APN setting, but when I click save, nothing shows up under APN Settings is as if I didn't do anything at all.

  2. wisepegasus

    wisepegasus Member

    I got the same issue. I just use Google Voice for visual voice mail until someone figures this issue out.
  3. daveradiofm

    daveradiofm Member

    Wanted to stay with a classic like Google Voice, which I had when I was with AT&T, but was toying with whether or not I wanted to part with the extra $5 which is why I went with MetroPCS Visual Mail in the first place. It was free with my Android plan.

    I just need to get around to calling them again. The problem is that you need to use a landline or someone else's cell phone since they have to walk you through checking the settings which is the issue. (I had tried calling before during a work break, but I was put on hold for so long that I couldn't get the issue resolved and the technician wouldn't give me the data to writed down) I wonder if it's an APN issue although my phone appears to work using the 1x internet. I'm checking a co-worker's phone that's non-rooted for the settings. Will get back with you to see how it works out.
  4. daveradiofm

    daveradiofm Member

    Okay, so I finally found a solution. I pretty much used a slight modification of this post [How-To][APP]Visual Voicemail in CM7 - xda-developers. Except I didn't use The utility wouldn't work on the Ascend.

    Here's what's you need. A backed up MetroPCS stock image (which was important if you flashed your phone to CM7 mod anyway) and TitaniumPro which you can download from the Market. It's free. :)

    1) Reboot your phone into recovery
    2) Backup your current CM7 mod image (This will save you a ton of headaches with configuration files as well as activation issues on certain products. I had to call Napster to de-activate the phone from the previous MetroPCS stock install. Not to mention you don't have to redownload stuff from the market)
    3) Restore your MetroPCS stock image and reboot
    4) Once booted, download Titanium Pro from the market and backup your MetroPCS VisualMail app. This will also backup the data for it as well. (Your phone does need to be rooted in order to backup the data)
    5) Reboot back into recovery mode
    6) Restore your CM7 image
    7) (You may not have to do this. I did because I had boot hang issues) Clear your cache and dalvik cache
    8) Once your phone succesfully boots up, re-download Titanium Pro from the market (I had a root issue and had to re-install busybox. It could have also been a delayed response since I have a couple of things going on at work as well)
    9) Back up VisualVoicemail Data only (If you don't already have the App installed, back up App then Data...Backing up app and data together just installs the app in my instance)
    10) Load should see No Message which means it was successful.

    I tested it by calling it, and all active voicemail messages were downloaded instantly to my phone.

    I know it's a really long, tedious workaround...but at least you save a 20 minute phone call and the reps having to walking you through the configuration set up.


    Option wisepegasus said go with Google Voice. It is a great service to use and will even email your messages to you. The downside is that you have to pay an additional $5 a month for call forwarding option to Google Voice

    VisualVoiceMail which is free for any $50 plan on up....or
    Google Voice and pay $5 extra a month

    If you do decide to go with VisualVoicemail, I hope this helps.
  5. nuttmeg

    nuttmeg Well-Known Member

    thanks for post, this will help others for similar problems. ;)
  6. daveradiofm

    daveradiofm Member

    Your welcome
  7. wisepegasus

    wisepegasus Member

    I haven't had to pay any $5 forwarding fee to use Google Voice so far...(been using it for about a month) I do like the Metro Visual Voice mail interface better though (a rare occurrence), so maybe i'll test out your method Dave.

    I tried backing up the Metro VVM app with app backup and restore, and got an error when I installed it in my 2.3.4 mod.

Share This Page