MFLOP sluggishness, How to Diagnose the Problem?Support


Last Updated:

  1. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    My phone will get really sluggish randomly after being turned off from a fresh restart for a bit. Everything starts out fine. I get MFLOPS (from Linpack) above 30. However, once my phone gets sluggish, I will get MFLOPS less than 1, which is unacceptable. The phone is usable but unbearably slow. In running services, only a 1/5 of my usable memory is in the red and yellow. I figured it was a 2.1 issue but now that I am on 2.2 I can really see the difference.

    Don't know if it is because of an app and which app it is or widgets. I was wondering if anyone knew anyway to find out how to trouble shoot the problem. It is quite annoying, as it gets in the way of the phone, and I would hate to have to restart all the time, especially when I in the middle of something...
     

    Advertisement
  2. muzicman0

    muzicman0 Well-Known Member

    Joined:
    Dec 12, 2008
    Messages:
    104
    Likes Received:
    6
    download a terminal application and enter 'top' (without the quotes). This command will display what is using high CPU or memory.

    mm0
     
    zillah likes this.
  3. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    Any recommendations? Does it require root?
     
  4. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    Downloaded terminal emulator application. Used task manager app to quickly kill apps. Uninstalled apps that had recurring services and were not a part of android system such as Weather widget, gesture search and one touch widget.

    Still have a slowdown in MFLOPS being less than 1...

    Again, I don't think the issue is memory, but CPU. Terminal emulator shows that all running services are not using the CPU above 0%.

    All sync settings and wireless location settings have been turned off.

    Reset my phone, will see if the slow down occurs again.
     
  5. muzicman0

    muzicman0 Well-Known Member

    Joined:
    Dec 12, 2008
    Messages:
    104
    Likes Received:
    6
    hmmm...if nothing is using memory, or CPU, then I am at a loss...

    Is it warm or hot when this happens? Are you rooted, and if so, do you have a CPU throttling app installed?

    mm0
     
  6. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    It was warm/hot and I am not rooted.

    So far though, things are working. MFLOPS are above 30. By the end of the day if nothing happens, I will start adding services one by one.

    Right now I am leaving it idle, which is how the problem started after restart. Don't know the exact time the slow down happened though, may be one of the recurring services I uninstall-ed. Need to give it time to see if it happens again. (was fairly quick though, about an hour?)
     
  7. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    Looks like I uninstalled the right apps. Turned on Wifi location services and used the weather.com widget for weather instead of beautiful widgets and haven't experienced any slowdown. But the exact app that caused the slowdown, I can't pin exactly. For those who would like to know, either one of these apps will cause a slowdown on your cpu:

    - MixZing
    - Beautiful Widgets/Weather Widget
    - OneClick Widgets
    - Batterytime Lite Widget

    I am going to need similar widgets like OneClick and Batterytime, may install them or choose another, so after I add them I will let you know if they have any effect.
     
  8. Teknologic

    Teknologic Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    969
    Likes Received:
    93
    I am using beatiful widgets and batterytime lite without any signs of the problem you mentioned. At most my OS is a bit unstable compared to 2.1 but I figured that's just froyo.
     
  9. zillah

    zillah Well-Known Member This Topic's Starter

    Joined:
    Feb 2, 2010
    Messages:
    89
    Likes Received:
    1
    I installed One Click Widgets and Battery Time Lite and experienced the slow down again. Uninstall-ed both. After I see that the system is stable again. I will try Battery Time Lite first for a while and see if that changes anything.

    It could be One Click Widgets...
     

Share This Page

Loading...