MicroSD card read onlySupport


Last Updated:

  1. HolySafari

    HolySafari Member

    Hi,

    I have a problem with my Patriot signature Line 32 gb microsd card with my rooted 16gb samsung galaxy s3
    so i have problem when i try to transfer music directly into the micro sd card from my computer through my phone using a usb cord with the "usb debugging" checked as on.
    it always says file is written protected when i try to delete my music or file or cannot copy when i try to copy new music from my music folder on my computer to the microsd folder.
    i also tried to use android commander to push it in it also came back as permission denied.
    however, i can make changes to the file if i remove the microsd card and insert it into my laptop using the adapter
    when i try to change the permission using es file explorer it says that the "write" option on the extsdcard folder is not ticked off but when i do try to check it, it says cannot change.
    I also have root explorer installed and tried to toggle the r/o and r/w and it also does not work
    the format is already fat32
    do i have to reformat it again?
    i don't want to have to take out the microsd card everytime i want to add a new song
    please help?

    Advertisement
  2. john_g

    john_g Well-Known Member

    Searching on the internet gives several references to putting the dodgy micro SD card into an SD to micro SD adaptor and simply sliding the write-protect switch on the side of the adaptor into the unlocked position. Some people say that it works, others are left wondering whether it can actually do anything since micro SD cards don't have a write-protect switch. Still, it's easy to try if you have an adaptor and I'd be very interested to know whether it does cure the problem - I'm a sceptic!

    My other suggestion would be to re-format the card using your phone rather than your computer. Back it up first if it contains valuable info!

Share This Page