1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

MicroSD in Mass Storage Mode gets disconnected during data transferSupport


  1. marin99

    marin99 New Member

    Hi,

    I have a 32GB MicroSD in my My Razr M/XT 907. The phone is connected to my Windows XP (SP3) laptop. The MicroSD is formatted with FAT32 and is recognized by the laptop. The MicroSD contains 15 large files (~2GB in size).

    I am running an application on the laptop that reads heavily from several large files on the microsd for about 10 minutes with a random access pattern. Then the application writes to the large files on the microsd for about 3 minutes with a random access pattern. Once the large files on the microsd have been updated the application starts all over again with the read cycle.

    Problem is that after a few cycles the MicroSD gets disconnected. Windows explorer shows an empty drive and a message appears indicating that the drive has been disconnected. After reconnecting the device all files are again visible from the laptop.

    So far I have tried the following:

    1. Tried different cables, one of them as short as 13'' -> no effect

    2. Connected the microsd card (Samsung, class 10 32GB) through a card reader -> problem did not appear

    3. Tried a different microsd (Lexar, class 10 32GB) -> same issue

    4. Tried the Lexar microsd with a card reader that is directly attached -> problem did not appear

    5. Tried a different phone (Motorola Atrix, MB860) -> same problem

    Could this be a thermal issue where the MicroSD overheats and gets 'shut down' by Android? Any other idea?

    Thank you

    Advertisement
    :
Loading...

Share This Page