MikG No Unlock Screen After Reboot??


Last Updated:

  1. ndh777

    ndh777 Well-Known Member

    I rebooted my phone and when it came back on, it sat at the (what is supposed to be) unlock screen. The only problem is that my background is showing, the status bar is there, the 3G symbol is there...basically the whole taskbar is there. But where my unlock button is supposed to be, it's gone. I can unlock and lock the phone using the power button but none of the other buttons are working, not even the volume buttons. The Home, Menu, and the other touch buttons don't even work. There's not even a vibration when I click them.

    I restarted the phone and booted into Recovery and wiped Cache and Dalvic Cache and restarted the phone and the problem still remained. So I restored an older backup I had from a few days ago and it has the same exact problem. I went and wiped it's cache too and still the problem remains.

    I'm on the latest MikG 3.11 with the stock kernel. (Stock as in the one that came with the MikG flash.)

    Advertisement
  2. ndh777

    ndh777 Well-Known Member

    I had my brother call me to see what would happen if I received a call. The phone vibrated and there was the green phone symbol in the top left hand corner but the bottom part of the screen is just my background with no options of answering or denying the call. I can't even click Home or any other buttons. I could press the lock button and silence the call, but that was it. He hung up and the phone said that I missed a call from him.
  3. 9to5cynic

    9to5cynic Well-Known Member

    This is the first I've heard of anything like this, but I haven't followed our roms as closely as in the past.

    If you have a nandroid of your current set up, I'd probably try a completely new rom, just to see what happens. I'm quite surprised that wiping cache and davlik did nothing, and that your old, clean nandroid didn't fix the issue.

    Quite odd.
    ndh777 likes this.
  4. ndh777

    ndh777 Well-Known Member

    It really is. It's even more weird because since I made that backup on the 29th of April, I have rebooted my phone and things have been fine. The last thing that I did with my phone before it did this was use the "Facebook icon remover" app that requires root. I thought that may have caused this but at the same time, I doubt that because my older backup shouldn't have the same problem. I really didn't want to, but I'll try flashing a clean MikG and see what happens. If that doesn't work, I'll try flashing a completely different ROM.
  5. 9to5cynic

    9to5cynic Well-Known Member

    Hmm... very weird. Tell us how it goes - I'm quite interested in this. Hope something reveals itself as the cause.
  6. ndh777

    ndh777 Well-Known Member

    Same here. Thanks for the help though. This is the strangest issue that I've ever come across.

    But this version of MikG seems a little bit buggy. I don't really like hitting "restart device" after flashing a zip but instead clicking "shut down device" then letting it cool for about 30 seconds then turning on the phone to see the homescreen. Mik has added a new line of code after it's finished installing that forces the phone to restart from the Recovery. When that happens and MikG comes on with the "rain boot", it goes into an infinite reboot and will sit at the boot for hours without changing. I have to take out the battery and do a cold restart which then gets me to the homescreen. This only happens after installation though. If you reboot from the homescreen, it reboots okay.

    So I flashed a clean install of MikG and it came up fine with the lock screen and I'm back to the Android screen with all of my controls. I think that hitting "reboot" instead of just shutting down and manually restarting was the issue. The only problem is that that still doesn't explain why it affected my backup. But perhaps when I hit reboot, it tried rebooting and when I restored the backup, it still registered as MikG and wanted to reboot and somehow this messed up the backup. I wonder if I tried now to restore the backup, would it still be messed up or if it would be okay.

    I think I'll now try restoring the backup and seeing what happens.
  7. ndh777

    ndh777 Well-Known Member

    WOWOWOWOW PREPARE TO SHIT YOUR PANTS! lol

    So I flashed a clean MikG and I was able to get back into the homescreen. Cool. Then I decide to go in and try to restore my backup that didn't work before and guess what happens?...the freaking phone restores the backup and everything works on it.

    I think that I'm right in my theory. Mik needs to look into what's going on with his shut downs. I just noticed that when I shut down the phone, I wasn't able to start it like you normally should be able to. I had to pull out the battery and then it would turn back on. Then there's this whole issue with the reboot from Recovery after installation that makes the phone have an infinite reboot, and then when you try to reboot by holding down the power and telling it to reboot normally, it does this! Ironically, I reboot into Recovery all the time and it works fine with no problems. That was my first and only time rebooting through the holding down power menu and it will be my last until some changes happen.

    I seriously hope that this is only an issue with my device.
    9to5cynic and argedion like this.
  8. argedion

    argedion The TechnoFrog Moderator


    I haven't used mikg in a while. Trying another sense ROM all together and see If your still having these funky issues. Give Nitrous 144 a try.
    ndh777 likes this.
  9. ndh777

    ndh777 Well-Known Member

    Sounds pretty cool, I'll give Nitrous a try.

    I've used quite a bit of other Sense ROMs and never had any issues like this. It seems to be only MikG that has this problem. I can't say that I understand why it does it internally, but on the surface, it seems that this is linked to possible bad coding from the devs on MikG when they modified the code for reboots and shut downs. With other Sense ROMs, I was able to shut down and reboot normally with no issues. But I'll give Nitrous a try when I get a chance, thank you.
  10. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Or just flash mikg over itself after wiping caches.

    Didn't read the last few responses so sorry if you tried that already

    Sent from my PC36100 using Tapatalk 2 Beta-5
  11. OlegNYR

    OlegNYR New Member

    Have had the same issue few times. once wiped Cache and Dalvic Cache and it fixed the problem another one only restore from backup helped
  12. MizzouBrent

    MizzouBrent Well-Known Member

    I have had this happen a couple of times when restoring MikG with the Amon RA style recovery. Not sure if I shut down my phone or not...usually I reboot to recovery.
  13. 9to5cynic

    9to5cynic Well-Known Member

    Good catch man! :thumb:

    I didn't know that Mik had changed the reboot process when flashing.... hmmm..

    :ridinghorse:
  14. ndh777

    ndh777 Well-Known Member

    Hopefully the devs will catch it and fix it in later releases. It's a really good ROM other than those little hiccups.

    I reboot to Recovery all the time by holding down the power button then selecting Recovery. That has always worked for me with no problems. It was holding down the power then telling it to reboot manually that I believe caused this problem. I never reboot like that but tried it that day just because I didn't want to wait around for it to shut down then me to turn it back on.

    Lucky you :laugh: That usually does work for me. That's been ocnbrze's motto as long as I've known him on this forum haha. Glad it fixed it for you though! That gives me hope that this is an isolated problem and not universal to all MikG ROMs.

    I should've tried that. I wonder what would've happened if I did try that or maybe if I would've tried downloading MikG's special zip made for flashing over older MikG releases.
  15. ndh777

    ndh777 Well-Known Member

    Oh by the way...I switched over to Nitrous early this morning...awesome ROM. Much faster speeds on 3G as promised too! That's what really got me loving it :D No problems as of today when I flashed at about 7:30am PST. :thumbup:

    Thanks for the suggestion, argedion!
    argedion and ocnbrze like this.
  16. gonowhere

    gonowhere Well-Known Member

    I had this same problem a few months ago on the older MikG version and now I'm having it on the newer update. I've tried two different backups, wiped cache/dalvik, reflashed the update, still nothing!!!

    I'm over it!!! Jumping ship for awhile.
  17. argedion

    argedion The TechnoFrog Moderator

    I've been hearing about more issues the past month with mikg than the rest of my time here. To much of a hurry to get it out maybe?
  18. gonowhere

    gonowhere Well-Known Member

    Maybe, or the universe is telling me its time to move on, there's a lot of good things happening for our Evo right now, I do like familiarity in my daily but, oh well.
  19. bigbear6708

    bigbear6708 Well-Known Member

    I like familiarity as well. I was a Mikg power user..lol, but recently switched to the KWIQ version of cm7.2 and LOVE IT! the minor hiccups and glitches with mikg turned me off..my wife still uses it with out problem though
  20. gonowhere

    gonowhere Well-Known Member

    Running 4 Kornerz for now, so far so good. Just got done setting it all up, pain in the butt.
  21. allanonmage

    allanonmage New Member

    Had this happen to me last week or so. I already had an SD card mounting problem that I wasn't fully aware of, and I told the phone to shut down via the menu. Booted back up with no lockscreen. Man I was scared and pissed and all sorts of stuff.

    To get back in, I flashed the MikG 3.11 **upgrade**. I can't tell you everything bad about that process, like I said I had an SD card problem and was apparently running A2SD, so I didn't have any of my apps installed. However, their icons were on the desktop and I had my contacts, SMS, and all that jazz.

    I haven't seen too many people post this fix, so please pass it around. I'm more active on XDA with this same handle.
  22. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    welcome to the forums!!!!!!!!!!!

    well one of the ways you can fix these kind of issues is to first try and wipe dalvik cache and cache and see if that helps. if that does not work then you can try and wipe dalvik cache and cache and re-flash the rom which is what you just did. so glad you were able to figure that out.
    Rxpert83 and Mikestony like this.
  23. allanonmage

    allanonmage New Member

    Other people have suggested that in this thread, so I didn't mention it. I tried it, and it didn't have an effect. Also, no one on the 'net had success with that in the context of this problem. While it's a good first step whenever you have problems, I don't see a point in bringing it up again.

    No, I did not. I flashed the **UPGRADE** MikG makes 2 ROMs for every version: a clean install and an upgrade. The upgrade will allow you to keep most things intact and just puts stuff on top of what you already have. The clean install will wipe first, then give you a fresh install.

    I appreciate your welcome to the boards. However, as one who has obviously spent a lot of time here (I see you have 12,000+ posts), I would have hoped that you have more precision and accuracy when you attempt to help someone. Remember, in technology, you can't fake it. The machines don't care. You have to be accurate and precise and pay attention to the details.

    If you've ever gone to Best Buy of Microcenter or Fry's and talked to the associates, you'll understand what I mean.

    Oh look, this board has a smiley with a sombrero! :smokingsomb:
  24. EarlyMon

    EarlyMon The PearlyMon Moderator

    Most of ocnbrze's posts come from helping people escape from nearly bricked Evos and other dire root issues. Hardly faking it.

    There's no need whatsoever for the smart attitude.

    The guy volunteered to help you for free, try showing common courtesy for the effort.

    And no, he didn't complain to me on this.

    I can also offer something better than a sombrero -

    There's also handy access to the rules you agreed to abide by when you joined in my signature . Good idea to read them.

    Cheers, thanks. :)
  25. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Ocn knows his stuff. This place would be in ruins without him.

    Also, I edited a version of mikg so that it wouldn't wipe on flash. I would recommend downloading that and using it to re flash your rom.

Share This Page