MILESTONE 2.1 update and root guide


Last Updated: 2014-04-26 22:59:12
  1. craigcrawford1988

    craigcrawford1988 Well-Known Member

    Intro
    Here is my 2.1 update and root guide. Firstly I would like to thank the community for these files used in this guide, without them we would not have root.

    I have tried this process on my UK MILESTONE using the following:
    • UK MILESTONE.
    • 2.1 UK SBF (non-service).
    • 90.73 bootloader.

    I cannot guarantee you will have the same success as me if you try a different bootloader version or SBF country/version.

    Before you start, a few points to make:
    • I am not responsible if your phone becomes bricked from this. It worked perfectly for me without a single hitch but for you it could be different.
    • Flashing a non-service SBF will WIPE the phone, so you will start from a blank slate.
    • If you don't know what root is, then read up on it first. It may not be for you. Chances are if you are happy with your phone and you don't find it lacking, then you don't need root.
    • Please read the WHOLE guide before starting, if you find yourself confused, then do NOT start. Ask first - you may break your phone.
    • It is recommended you do this on a computer that isn't going to crash or power down mid-update. A laptop plugged in with a good battery is recommended.

    Prerequisites

    Procedure
    So, if you've got this far and have decided to take the plunge and downloaded all the prerequisites, then you're ready to get started!

    Follow these steps carefully and you'll have your MILESTONE with rooted 2.1!
    1. Charge your phone battery up FULL. While your phone is charging, install the USB drivers and RSD Lite.
    2. When the phone has finished charging, shut it down and unplug the USB cable from the phone.
    3. Load the phone up into bootloader mode by holding the UP direction button on the D-PAD of the phone (up as in towards the screen) and pressing the power button until you see the screen light up.
    4. You should be presented with the following text:
      Code (Text):
      1. Bootloader
      2. <version number>
      3.  
      4.  
      5.  
      6.  
      7.  
      8. Battery OK
      9. OK to Program
      10. Connect USB
      11. Data Cable
    5. Connect your USB cable to the phone and the last two lines should change to:
      Code (Text):
      1. Transfer Mode:
      2. USB
    6. Now you can load up RSD Lite using the icon on your desktop. Follow the steps in this image, selecting the 2.1 SBF you wish to flash (not the vulnerable recovery, that is later).
      [​IMG]
    7. Wait for RSD Lite to finish (The Status column will read Finished and the Result column should read PASS).
      If you get anything else or it seems to be taking forever, please ask here and do not interrupt the program or phone.
    8. When your phone boots up and asks you to set it up, shut it down and repeat step 3 of this guide.
    9. Once into the bootloader again, you can flash the vulnerable recovery SBF. Repeat step 6, but this time select the vulnerable recovery SBF and not the 2.1 SBF. This update should take a few seconds/minutes, and the phone will start back up once this is done with RSD Lite reading a Finished and PASS result in their respective columns.
      Again, if you experience problems as outlined in step 7, don't interrupt the phone/program. Ask in this thread.
    10. In Windows explorer, navigate to the SD card of the phone and copy the milestone_root.zip file over and rename it to update.zip.
    11. Once that has copied, shut the phone down once more and put it into recovery mode (not bootloader).
      To get into recovery mode:
      • For bootloader 90.78: X button on keypad
      • For bootloader lower than 90.78: Camera button on side of phone
      Hold the respective button as detailed above and the power button together. When the Motorola logo appears, release the power button but keep hold of the X/Camera button until this icon appears:
      [​IMG]
    12. Phew! If you made it this far then congrats, you nearly have root!
      Now hold the Volume Up button and press the Camera button to bring up the command menu.
    13. Select from the menu using the D-PAD and choose apply sdcard:update.zip. If all is well it should start saying Rooting your phone..., once it is complete the command menu will re-appear. Simply choose reboot system now.
    14. Once the phone has started back up again, go through the initial setup (or skip it) and you should have a new app called Superuser Whitelist.
      Whenever an app requests root access you will get a prompt screen like this:
      [​IMG]

    End
    If you made it fully through this guide then you should now be able to download apps such as Root Explorer and be able to mount the various directories as r/w and be able to start going deeper into modding your phone.

    One of the best bits of this is being able to uninstall the CRAPPY apps that come with the phone and clog up memory such as Facebook or Sim Toolkit (these are deleted from /system/app), you can find out more about modding with root by other various guides.

    Just as a final note: I recommend turning off OTA updates as they wont work for a rooted phone, you'll need to use RSD Lite from the future (unless you unroot).

    Well I hope you find this guide useful! Took me long enough to write it :D

    Known Issues
    • Sometimes, even when you have done everything right in RSD Lite - the start button remains greyed out. You must launch it by command line on such occasions:
      Download this batch file, copy it and the SBFs you wish to flash into the RSD Lite folder and then drag and drop the SBFs you wish to flash onto it.
    • Sometimes RSD Lite is unable to restart the phone as it needs (RSD Lite will read: Please manually power up this phone). If this happens you must manually assist the phone in flashing. Thanks to tazd for reporting this issue and finding the workaround.
      1. Disconnect the USB cable and shut the phone down.
      2. Start the phone up in bootloader mode.
      3. Reconnect the USB cable. RSD Lite should continue now.


    EDIT: Changed the link to SBF Files to the newest one and added RSDLite 4.9 link. Szadzik

    Advertisement
    cha04, cracktojack, darkops and 21 others like this.
  2. darklight

    darklight New Member

    Hi,
    Wondering if you have been able to overclock the CPU on your rooted device.
    Cheers
    David
    Pspres likes this.
  3. alexbitzu

    alexbitzu New Member

    hello. stuck at step 6. my start button is not active after i choose the sbf file. i selected the same as u did, the 2.1 UK (non-service)
    i'm using windows 7. That's might be a problem?

    yep. that was the problem. i tried in win xp and all was perfect.
  4. craigcrawford1988

    craigcrawford1988 Well-Known Member

    Unfortunately, no. Overclocking would require a custom ROM and because the bootloader is locked we cannot flash a custom ROM :(. You can still underclock however.

    If the start button does not become active, then you must launch it by command line.

    I made a batch file a few days ago for such occasions (I had this problem once). Check the original post for the link under Known Issues.

    Just copy the batch file and any SBFs you wish to flash over to the RSD Lite folder and drag and drop the SBF onto the batch file.
    Pspres likes this.
  5. 77cats

    77cats New Member

    Thank you, craigcrawford1988.

    Mobile rooted in a 2 minutes - from the 2.1 update.
  6. watchout

    watchout New Member

    Brilliant guide! I rooted my original 2.1 milestone in minutes..

    Is it somehow possible to create a Nandroid backup too now??
  7. JohnM109R

    JohnM109R Active Member

    There is just can't find the howto right now as Alldroid.org has gone down but it will be back up in a few days according to the blog..
  8. watchout

    watchout New Member

  9. JohnM109R

    JohnM109R Active Member

  10. mixpix

    mixpix Well-Known Member

    Hey good work on the guide, It's nice to see something that's laid out well.

    So even the overclocking apps won't work, right? The only reason I would root is for overclocking, so it's unfortunate that you can't without a different rom.
  11. watchout

    watchout New Member

    That's right, you can toss the update.zip in the "OpenRecovery/updates" folder. The backup created through nandroid is still located in a root folder called /nandroid/

  12. binaryhellstorm

    binaryhellstorm Well-Known Member

    Will this work on the Telus Milestone?
  13. tazd

    tazd Member

    Ok imust be doing something really daft. I have followed this tutorial from step * as the phone had allready updated to 2.1 previously and all works til i get to

    13.Select from the menu using the D-PAD and choose apply sdcard:update.zip. If all is well it should start saying Rooting your phone..., once it is complete the command menu will re-appear. Simply choose reboot system now.

    even though i do as started it errors wiith the following message.
    E:signature verification failed
    Installation aborted.

    Any ideas on sorting this would be most appreciated.
    LinoAirosa likes this.
  14. craigcrawford1988

    craigcrawford1988 Well-Known Member

    It should do. However, I remember reading that people lose 3G on Telus Milestones with root.

    You could always try and then unroot if you do lose 3G of course.

    You need to flash the vulnerable recovery :).
    iLiKePaNkAcKeS likes this.
  15. binaryhellstorm

    binaryhellstorm Well-Known Member

    Ok, thanks. My main concern was that when I was looking for the Telus SFB, on the site that is indicated in the initial post, and on the site it states that the SFB is un-rootable. Do I want to use the Canadian SFB or should I use another one.
  16. craigcrawford1988

    craigcrawford1988 Well-Known Member

    Yes, you need to use the Canadian (Telus) SBF. It says unrootable because it is unrootable by default, that is why we flash the vulnerable recovery :).
  17. binaryhellstorm

    binaryhellstorm Well-Known Member

    Ahh, OK, now I understand, thanks for clearing that up.I will give it a try this afternoon and post the results.
  18. binaryhellstorm

    binaryhellstorm Well-Known Member

    Hooray I have root, it works perfectly and I still have 3G!!
  19. craigcrawford1988

    craigcrawford1988 Well-Known Member

  20. inner00secret

    inner00secret Member

    This is my milestone info:

    firmware config version:gas_emea_usashls00rtint_p012

    baseband version:3gsmepu91a_u_91.07.4ei

    kernel version:2.6.29-omap1...

    build number:shols_u2_02.31.0

    I bought it in vietnam, android 2.1-update1 pre-installed.

    Should I root? I hate some core apps and really am disappointed with the alarm bug. I would love to have speech to text function plus many more from the droid.
  21. craigcrawford1988

    craigcrawford1988 Well-Known Member

    Should you root is entirely up to you. If you are asking if I think you will be able to root then yes, I believe it would work.
  22. inner00secret

    inner00secret Member

    Thanks for your quick reply, craigcrawford1988. I've just found out something really really interesting by using Astro. I open /system/build.prop file and i reads my milestone comes from GB. Does it mean I can root mine with the guidline above? I'm so excited now. YAY!!!!!
  23. craigcrawford1988

    craigcrawford1988 Well-Known Member

    Probably, yes. Though take a look at Settings > About Phone > Firmware configuration version. If it says GB in there then you can flash a UK SBF (if you have a
    inner00secret likes this.
  24. inner00secret

    inner00secret Member

    My milestone's firmware must be south-east asia. And I rooted!!!! How simple it was! Thank you, craigcrawford1988. But I'm wondering if I can have speech to text function, home launcher like nexus one and the 3d gallery. What site suggest you?

    One more thing, can I restore the unrooted version when needed? Do I just need to factory reset or reflash?
  25. craigcrawford1988

    craigcrawford1988 Well-Known Member

    I believe the apps you are looking for are here.

    Though for TTS, that should be built into the phone under Language > Text-to-speech.

Share This Page