Milestone 2 (Europe GB) SMS stock apk problemSupport


Last Updated:

  1. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    Milestone 2 (MotoA953, Europe GB firmware version MILS2_U6_2.2.16) problem with native SMS apk.
    I have already asked for the assistance regarding this issue.
    After I rooted M2 (z4root.apk), on some way I disabled (first froze, than moved Text Messaging_2.2.apk from system folder) and put it in SD/backups/app folder.
    I have tried many times (using ROM Manager Premium and ROM Toolbox) to re-instal the apk but no chance.
    Currently I,m using Handecnt sms.apk without any problem.
    Does somebody have any idea where can I download native Text Messaging_2.2.apk for Milestone 2, or some similar stock apk, that I can re-instal on my phone and use it again.

    Szadzik? Can you help me this time?
     

    Advertisement
  2. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    I do not have 2.2 stock as I have been 2.3.4 for some time now. I can upload the one included in that version.

    Remember, that you do not need to install it. Just put it into \system\app folder and set permissions to Owner, Group, Others as Read and Owner Write.

    P.S. On a second thought, you will be better off flashing a service version of the SBF from here:
    sbf:milestone2 [And Developers]

    The service version is a version for firmware that does not erase any settings from your phone, just updates the system parts of it.
     
  3. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    Thank you Szadzik.
    I would rather try the first solution you suggested - 2.3.4 stock.
    Can you send apk to omnimj@gmail.com or using some other way?

    The SBF solution seams to be to complicated for me at the moment.
    Maybe if the previous one doesn't work on my M2.In that case your instructions would be welcome.

    BR
    Micha

    PS: I assume Szadzik is your name or nick name. Sorry if I'm wrong.
     
  4. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    File requested sent to email.

    Not sure if that will work or not.

    Regarding flashing the service SBF. It is very easy. You download RSDLite and install it. Connect the phone to the PC and open RSDLite, drivers will intall and you just point RSD to where you have the SBF and press start.
     
    omnimj likes this.
  5. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    I'll disappoint you.My skills are not so good to this by my own.
    SMS apk: I did everything you instructed:copied messaging.apk into the system/app folder, gave the permissions, reboot etc. but nothing happened.

    SBF: the same - installed RSD lite (v4.5.3), downloaded sbf, came into bootloader mode (prior USB debugging applied), USB drivers, connected to PC etc. Than Start in RSD lite but nothing happened.
    I tried with RSD lite v4.9 but nothing happened.The RSD screen was "frozen" although I pressed Start. It seamed RSD didn't recognize the phone.

    Maybe I did something wrong?
    I'll send you the RSD lite (v.4.5.3) screen image to g-mail.
     
  6. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    As explained in the email I sent you.

    1. Put the SBF in the root of your C drive.
    2. Rename the SBF to something short.
    3. This is a new step - Boot the device into Bootloader and then connect to the computer and try to flash it.
     
  7. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    Does it matter if the phone is rooted or not?
    Bootloader on my phone is 70.12. Is that important for .sbf version that I will use?
    .sbf version that I have is MILS2_U6_2.2.16_SIGNED_UCAMILESTONE2B1B80E100A.0R_UCXMILE20RTGB_P029_A007_HWp2a_Service1FF.sbf
     
  8. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    1. No.
    2. Not important, but why are you installing an old version fo the system instead of a new one?
     
  9. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    I didn't know whether it was old or new.
    I've just downloaded it.
    I found somewhere the version from august 2011, but I saw the bootloader was 70.13.
    As I told you, the bootloader in my phone is 70.12. I thought it was important.
    As I remember and I so somewhere when I previously tried to use "the old" one that the version of bootloader was 70.12. so I chose the "old version".
     
  10. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Try flashin teh bootloader first then. After that try flashing firmware
     
  11. omnimj

    omnimj Member This Topic's Starter

    Joined:
    Sep 28, 2011
    Messages:
    16
    Likes Received:
    0
    I fleshed successfully old firmware and got back all functions that I lost.
    That was what I wanted to do. SMS is now working well.And some other things.
    For a some time I will stop to "turn upside down" my phone.

    Thank you for advising me.

    Best regards,
    Micha
     
  12. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Good to hear that.
     
  13. npetrov

    npetrov New Member

    Joined:
    Mar 3, 2012
    Messages:
    1
    Likes Received:
    0
    Hello all,
    Sorry that this thread is old, but want to ask you for help!
    The link above "sbf:Milestone2" is no actual, but i need this file because my phone is only booting to the logo of Motorola.
    Could please help me to find and flash with european firmware.

    Thank you in advance!
     

Share This Page

Loading...