Milestone 3 (XT860) Root and Recovery


  1. LifeInAnalog

    LifeInAnalog Well-Known Member

    Hey all. I'm about as far away from someone who should be starting this topic as you can get...just this week I got my XT860, after using the Milestone for a little over a year. So far its been great. I thought I'd share a few links to show where I am thus far;

    www.psouza4.com/droid3

    ...the above link will take you to Pete's Motorola Tools, a simple one-click method to root your XT860. When I tried it, it actually failed on step 3 the first time, but was fine on the re-try.

    http://hash-of-codes.blogspot.com/p/android-downloads.html

    ...the above link will take you to Hashcodes site where you can download his tweak on Koush's CWM. Once you run this .apk you will have the ClockworkMod Recovery which you can enter first, by holding M while powering up, then scroll down to bp tools and enter.

    I'm not aware of any ROMs that we can flash yet. There are a few for the Droid 3, but they are not compatible with the XT860. And nope, no CM7 yet either...but they're working on it.

    Advertisement
    :
    Twitch_City likes this.
  2. Twitch_City

    Twitch_City Member

    Thanks for starting this thread! I'm just about to pick up an XT860 today and the first thing on my to do list is to root it to run on Fido instead of Bell.

    Cheers for confirming that the Droid3 methods of rooting the device work!

    Edit: Just for clarification, I know root does not mean the same as unlock. I plan on unlocking it by following this tutorial: http://www.youtube.com/watch?v=6tiU2j4lwDo and then gaining root access through your above link. Do you think it matters which I do first? (I was planning on unlocking first but I read that it might take up to 3 days to get the unlock code sent to me)
  3. LifeInAnalog

    LifeInAnalog Well-Known Member

    ...Hey, its great to hear from someone who is in the same boat as me, using a Bell phone on another network.

    Don't quote me of course, but I don't think neither unlocking nor rooting will affect the other. I, like you were thinking, wanted to unlock first. I used the Mobileincanada.com web site, which worked great. Got the code in about four hours.

    ...after rooting and installing ClockworkMod, the next thing is removing the large amount of bloatware on the phone...
  4. Bob_760

    Bob_760 New Member

    I'm in a similar boat, I just got my XT860 a few weeks ago. I didn't buy it directly through Bell so it was already unlocked by the person who sold it. It works great on AT&T's 4G. I am looking forward to rooting it at some point but as I just let go of my V3XX I don't know much about it and finding information on this phone has proven to be quite a task.
  5. Twitch_City

    Twitch_City Member

    Both unlocking and rooting were a breeze, using the above method.

    How are you going about removing all the bloatware? Especially since we are not using Bell, about half of the installed apps are functionally useless. It would be nice to get rid of em.

    Also, how is your battery life? I'm finding it fairly atrocious. Maybe I need to do a bit more tinkering with some settings but it seems far shorter than my original Milestone. It could be (I'm hoping) that it was because I was up north and perhaps it had a hard time finding/keeping the signal.

    Have you looked into extended batteries or anything like that?

    I need to pick up a dock or two for my house/office.

    I've replaced the text messaging app with Go SMS, which I think is better. I don't really text too often though so I may not be the best judge.

    We definitely need to keep this discussion alive and post things that come up. I still can't believe how quiet this forum is, considering how great the phone is!
  6. LifeInAnalog

    LifeInAnalog Well-Known Member

    ...it is quiet, but that'll change in awhile...I hope so at least, the more people trying things out the better.

    Most of the info that I've been getting is from over at XDA, in the Droid 3 forums. It's mostly developer talk, and a lot of it goes over my head, but you can still grab a tasty morsel or two. There's quite a few XT860 users littered in there as well, asking if this or that tweak will work with our handsets...some do and some don't. They really need a sub-forum over there.

    I've been using Titanium Backup (Pro version) to "freeze" the apps I don't need or want. Like any good noob, as soon as I got it, I froze about a dozen programs then expected everything to be fine. Well, my contacts got messed up, kept force closing. So, I unfroze everything, and now I'll freeze an app, then use the phone for a day and see if everything is ok. Slow...but safer ;)

    I have to agree with the battery comment. I'm not able to make a full day with mine as is, with moderate to heavy use. The original Milestone was better...but this baby has a lot more to keep juiced I guess. I haven't looked into the extended battery yet.
  7. LifeInAnalog

    LifeInAnalog Well-Known Member

    ...I missed the texting comment.

    So far I've just been using the stock texting app, though I prefer using Handscent..I just haven't got around to switching yet, although I did switch to using Swiftkey X as my keyboard.

    I'm thinking we should move these general conversations out of the root thread...whatcha think?
  8. Twitch_City

    Twitch_City Member

    Have you installed the update yet? And, if so, did you have to re-root the device afterward?

    In the other thread it seemed like this method doesn't work and I've been too busy to investigate it further.
  9. lyrabee

    lyrabee New Member

    Hey everyone, I just tried to root using the link above but it fails after the second step... And I tried it twice. I have a moto xt860 that's only a couple of months old, so it has gingerbread .6 instead of .4

    I'm wondering if there is an update or additional step to root my phone? I used to have a jail broken iPhone but the rooting process is a little new to me so any help would be appreciated!
  10. sbwoodside

    sbwoodside Member

    I also have failure when trying to root with the above method. I've installed the Bell update, running System version 5.2.476.XT860.BellMobility.en.CA.

    Here is my log:

    Code (Text):
    1. $ ./run_to_root_your_droid3.sh
    2. ***************************************************************************
    3. *                                                                         *
    4. *                       DROID 3 Easy Root script v7d                      *
    5. *                                                                         *
    6. ***************************************************************************
    7. *
    8. * Please make sure you meet these pre-requisites:
    9. *
    10. *       (a) install the correct driver... er, nevermind, we don't need no stinkin' drivers
    11. *       (b) turn on USB debugging (on your phone under Settings -> Applications)
    12. *       (c) plug in your phone and set your USB mode to 'PC Mode' (on Linux)
    13. *                                             or 'Charge Only' mode (on Mac)
    14. *           (but if it hangs waiting for the phone to connect, set it the other way)
    15. *
    16. * READY TO ROOT YOUR DROID 3 WHEN YOU ARE!
    17. *
    18. * Press enter to continue...
    19. *
    20. * Waiting for your phone to be connected...
    21. *
    22. * Running exploit [part 1 of 3]...
    23. *
    24. * Rebooting the phone... when the reboot is complete, you may need to unlock the phone to continue.
    25. *
    26. * daemon not running. starting it now on port 5037 *
    27. * daemon started successfully *
    28. * Running exploit [part 2 of 3]...
    29. failed on '/data/local.prop' - Permission denied
    30. cannot create /data/local.prop: permission denied
    31. cannot create /data/local.prop: permission denied
    32. cannot create /data/local.prop: permission denied
    33. cannot create /data/local.prop: permission denied
    34. cannot create /data/local.prop: permission denied
    35. cannot create /data/local.prop: permission denied
    36. cannot create /data/local.prop: permission denied
    37. cannot create /data/local.prop: permission denied
    38. cannot create /data/local.prop: permission denied
    39. cannot create /data/local.prop: permission denied
    40. *
    41. * Rebooting the phone... when the reboot is complete, you may need to unlock the phone to continue.
    42. *
    43. * daemon not running. starting it now on port 5037 *
    44. * daemon started successfully *
    45. ! ERROR: root was not obtained.
    46. !
    47. ! You might want to try rebooting your phone and trying again.
    48.  
  11. Green1

    Green1 Active Member

  12. sbwoodside

    sbwoodside Member

Loading...

Share This Page