Milestone decided not to read SD cardSupport

Last Updated:

  1. When i press the power button...i have to slide to unlock it right....

    then at the notifications bar...there is a exclamation mark saying

    SD card removed. Insert a new one.

    There is already an 8gb SD card but why doesnt it read it...i have not taken that SD card of my phone since i bought it..

    I even took the card off the phone and putting it back it....still the effing same!!!

    Driving me CRAZY!!!

    please help me...

  2. newbkilla

    newbkilla New Member

    This has happened to me too. I have no idea why it happened. Any SD card i use results in a "insert a new card!" message.
  3. chirag1105

    chirag1105 New Member

    HI I have been facing the same issue. Kindly reply if any solution found for the same
  4. raulsk8

    raulsk8 New Member

    Hi everyone, new member here... !!Great forum!!

    Unfortunately I do not have an answer but I do want to add myself to the dissapointed list. :(

    I bought my XT720 from Ebay (I buees I now know why the guy was selling it LOL) it came with a 8gb card and it all worked fine until I decided to update to a 32g card, same simptoms as the first post, the phone would try to scan the card and if it went to sleep while doing this I would not be able to wake it, the only thing that worked is to get the battery out. I thought this was a software related issue, It came with Dexter's froyo, so I reflashed back to 2.1 and it did same thing, reflashed again to 2.2, same thing... returned the card and got me a 16g card, same damn thing. Seems to me that this is a hardware related issue?? Nothing above 8g seemed to work for me, I'm back to the 8g card and it's now working fine...

    Can anyone confirm if your XT720 is working fine with the 8g or less?? :confused:
  5. raulsk8

    raulsk8 New Member

    Another question,

    Does anyone know which cards are the ones this phone likes??

    That would be great info. to have.

  6. mrashid99

    mrashid99 New Member


    Writing this for the first time on a forum, hope I get a quick response to my query.

    I need to upgrade my Android version from 2.1 to 2.2 or later version, in order to resolve the issue that when I download applications from Market, it gets saved on phone Memory. How do I save or move them on my SD card instead? There is no option to move.

    I appreciate if someone can help.:)
  7. raulsk8

    raulsk8 New Member


    You definitely need to upgrade to 2.2 if you want to save your apps on the SD card, but even then not all apps can be saved on the SD, some were not meant to be removable.

    I upgraded my XT720 to 2.2 and I found out that you loose the ability to control the volume on the radio, once you turn it on it goes to max volume and you can't turn it down. If this is not a problem for you then go ahead and do it as there are some other features that are not on 2.1.

    There are some tutorials on youtube that show you how to do this, and they are very easy to follow. Just be carefull as you can brick your phone if not done correctly. Check them out (sorry I can't send you the link, I am at work and youtube is blocked). There are some very nice videos from a guy called reverend something.

    Hope this helps,
    Good luck!
  8. seanamos

    seanamos New Member

    My Droid can't access the SD card anymore. It has an error message at the notification bar, "SD card removed. Insert a new one". I have tried replacing with another one, same problem. Formatted it using a Hi-Speed Card Reader/Writer and replaced it, nothing. Anyone knows a solution to this problem?
  9. Josiah Inyang

    Josiah Inyang New Member

    hi guys am new here too and with a similar problem but mine is that of sim card ,my XT720 MOTOROLA ,wount accept my MTN,AIRTEL,OR GLO SIM CARD,since i bought it i can't even use it for once please can someone help me here,and i can't receive or send anytext message on the phone.

Share This Page