Milestone Proximity sensor and Microphone not workingSupport

Last Updated:

  1. luvkillin

    luvkillin New Member

    Ok so the digitizer on my milestone went bad about a month ago, i ordered one off ebay and installed it myself. unfortunately while doing so i ripped the flex ribbon that has the sensors attached to it. went on ebay again and ordered that part and installed it, didnt destroy anything this time.
    put the phone back together and everything seemed to be working fine, then i got a call, the person on the other end couldnt hear me and the proximity sensor caused the screen to go blank even before i put the phone to my ear
    if i put the phone on speaker phone the person hears me but its very low im told, inserting the headset works fine, person can hear me perfectly.
    i tried doing a recording with the phones sound recorder and all i hear is a hissing type sound when i play it back, i also downloaded an app to test the proximity sensor and its showing a distance of zero and when i put my finger near and further away from it its still saying zero.
    tried doing a battery pull..hard reset, reflashing the froyomod that i have install and nothing seems to work, could this be a defect with the flex ribbon i bought? would this ribbon affect the microphone?
    any help would be appreciated


    haessam1 likes this.
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    *moved to Motorola Milestone forum*
  3. haessam1

    haessam1 New Member

    The Mic of my Milestone is nor working,i can make only handsfree calls,it is Andriod version 2.2.1,
    please advice

Share This Page