Milestone tethering problem: no response from adb on Lucid 64-bit


  1. Rinus

    Rinus Member

    I've been trying and scouting forums for a few days now but so far the answer seems to be hiding...

    I'm trying to tether my Moto Milestone to Ubuntu Lucid 64-bit. After some quirks - i had to install ia32-libs package to get any response from udev - i find myself looking at the same problem over and over again

    After asking (as root) udev for devices the only response I get is
    * daemon not running. starting it now *
    * daemon started successfully *
    List of devices attached

    And then the prompt again. I've tried adding rules to an executable 90-android.rules file in /etc/udev/rules.d like
    SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="22b8", SYMLINK+="android_adb", ATTRS{idProduct} =="41da", MODE="0666"

    The device is listed as seen from lsusb:
    Bus 002 Device 006: ID 22b8:41da Motorola PCS

    Somehow I can't seem to get it to talk to the Android Debug Bridge and somehow I think it's something to do with udev.

    I've been tying rules to OWNER="myself", I've tried tying to GROUP="plugdev" and adding myself to that group to no avail, I've checked the debugging mode on my phone, rebooting and checking again, changing rules and restarting udev, killing and restarting adb but nothing seems to work. It's driving me, well, slightly uncomfortable to be honest, but I feel I invested enough evenings to send out a cry for help.

    Has anyone succeeded in tethering a Milestone to Lucid 64-bit? Any suggestions? Help hugely appreciated.

    Advertisement
  2. Szadzik

    Szadzik Well-Known Member

    Why don't you just use Wireless Tether and allow the phone to act as a wireless router? Much simpler than using a cable connection and free.
  3. Rinus

    Rinus Member

    Does this allow for my laptop to use the Milestone's internet connection? How do I set up my phone as a router and can I form some sort of network bridge between WiFi and mobile connection?
  4. Szadzik

    Szadzik Well-Known Member

    1. You need to have root access on the Milestone
    2. Go to Market and find Wireless Tether for Root Users application and install it.
    3. Open the application and start tethering. It will broadcast WiFi signal which will allow your laptop or any other device that has WiFi to use the phone's internet connection.
  5. Rinus

    Rinus Member

    Many thanks for your reply, Szadzik,

    I was rather hoping not having to root the Milestone. Seeing many Moto users merrily usb-tethering, I still hope it is possible.

    Cable connection will not be gathering dust soon since WiFi rather drains the battery...

    Anyone in luck with usb-tether and Lucid 64-bit?
  6. Rinus

    Rinus Member

    Cracked it!

    Seems I had to configure something very simple on my moto. When plugged in, the USB icon appears in the top bar. Selecting this "USB connected" icon, it was set to some synchronising setting. Instead I set it to "Memory card access", as I believe is the proper translation of the Dutch version "De geheugenkaart openen" :)

    Then all of a sudden, all worked as a charm.
  7. jesumar

    jesumar New Member

    can Rinus say exactly what he did in the moto ?
  8. Rinus

    Rinus Member

    Enabled the debugging mode (earlier) and I believe I just selected USB Mass storage mode. It seems not all usb connection modes support ADB communication.

Share This Page