1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Missing 4GSupport


  1. ajmount88

    ajmount88 Well-Known Member

    Hi everyone. I recently purchased the Z1 direct from Sony, running on Android 4.2. I used to have the option in the network mode settings for 4G, as well as in the quick settings at the top of the notification bar.

    Unfortunately, after updating to 4.3 I noticed that this option appears to have vanished from both menus and I can no longer find anything to do with 4G anywhere on the phone. I have tried updating the APN settings (both automatically and manually) and it still is not there. I have been in a supposedly 4G area earlier today and saw no sign of any 4G signal (or any signal for that matter, but that appears to be lousy network coverage in the area). Has anybody else noticed this, or am I just being a bit thick?

    Advertisement
    :
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Can you try downloading the internet settings again?

    Also, have you set Network operator to manual or automatic?
  3. ajmount88

    ajmount88 Well-Known Member

    I've tried Manual and Auto, and downloading APN settings and entering them manually. Oh well... Hopefully kitkat or any minor Sony update in between will fix it. I'm not in any hurry to get 4G, as I'm switching to a 3G tariff to be able to get a better signal (Giffgaff is much better than the non existent Three, both at home and work).
  4. ajmount88

    ajmount88 Well-Known Member

    I'll probably try a factory reset at the weekend as well to see if that helps.
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

  6. ajmount88

    ajmount88 Well-Known Member

    I've just tried the app you linked to and it's just a shortcut to the network mode screen, which still only shows WCDMA and GSM. I'm pretty sure when I looked into an app to toggle 3g I read that apps can't change this setting on an unrooted handset, they can only take you to the network mode screen.
  7. ajmount88

    ajmount88 Well-Known Member

    Seems like a factory reset hasn't solved it either. I've just tried taking the SIM card out and restarting and the option for 4g showed up again in the network mode screen. For some reason, it disappears again when I put the SIM back in. It seems odd that I had the option there before the update, but now my SIM seems to be blocking me from accessing 4G.

    I only started the contract over Christmas, so I should have been given a 4G SIM, and it wasn't blocked before the update, which should have been unbranded anyway.

    Any more thoughts anyone, because I'm stumped.
  8. Slug

    Slug Check six! Moderator

    If you're on Three then the SIM is only 3G-enabled as the network don't (yet) have a 4G service. That should make no difference though; the "4G (preferred)/WCDMA/GSM" option should still be available in Settings/Mobile networks/Network Mode.

    It could be a bad SIM (it happens) so requesting a replacement from Three would be my first suggestion.

    If that doesn't fix it then contact Sony for warranty repair/replacement.
    El Presidente likes this.
  9. ajmount88

    ajmount88 Well-Known Member

    Three launched their 4G network at the end of last year, so they'd be pretty stupid to still be sending out 3G SIMs, but it does look possible that it's either a 3G SIM, or faulty.

    There's not much point me contacting Three for a replacement, as I'm currently awaiting a new SIM from Giffgaff due to Three's poor signal in my area (confirmed on another phone). I just wanted to find out whether it was the phone, the software update, or the SIM. My guess is that it was either a 3G SIM, or faulty, and that the software update disables the option if the phone/SIM is incompatible with 4G.

    If the new Giffgaff SIM doesn't show the option, I'll look into it with Sony (new Giffgaff SIMs are supposed to be 4G ready)
  10. Slug

    Slug Check six! Moderator

    It's only in a testing phase, and then only by selected customers. Their retail SIMs are definitely 3G only.

    That's beside the point though; the 4G/WCDMA/GSM network mode options are hardware-based, so if 4G isn't available then it's very probably an issue with the phone itself.
Loading...

Share This Page