Missing Play Store Credit/Free ItemsGeneral

Last Updated:

  1. Honey Badger

    Honey Badger Active Member

    So I never received the $25 credit or anything that was supposed to come with it. I tried calling Google yesterday, after waiting over an hour on hold someone picked up and dropped my call.

    I was about to call them back, but it looks like the number was removed from the "How to get your promo credit" page.. Anyone know what the number is?


  2. shaneydroid

    shaneydroid Well-Known Member

    I have been to the store and tried to buy things but it says I need to set up google wallet with a credit card to get
  3. CarsnGadgets

    CarsnGadgets Well-Known Member

    jmar likes this.
  4. davewood44

    davewood44 Well-Known Member

    jmar likes this.
  5. DanielM426

    DanielM426 Well-Known Member

  6. perfectstranger

    perfectstranger Well-Known Member

    I also didn't get the credit. Don't know why. Be sure to post back here when you get it or a proper explanation.

    Other than that, I'm loving this little thing.

  7. CrackBaby

    CrackBaby Well-Known Member

    Try buying an inexpensive app that you know you will use. Or get as far as you can in the shopping cart before you actually confirm to buy. The $25 might pop up at the last minute. It didn't show up for me til I bought a .99 game.
  8. Honey Badger

    Honey Badger Active Member

    No problem.. Just can't find the number anywhere.
  9. Honey Badger

    Honey Badger Active Member

    I purchased a magazine subscription already - made no difference.
  10. Mr-Android-

    Mr-Android- Member

    You can't get the credit unless 3 factors have been met. 1) No other account has received the $25 credit via your nexus 7. 2) You have a working credit card set up on your google wallet account, and said card has not already received the $25 credit from a different nexus 7 or account. 3) Your account has not already received a $25 credit via a different nexus 7.

    In other words, eligibility for the $25 credit is limited to one account, credit card, or nexus 7. You can read more about it here: http://goo.gl/FhLyA
  11. Honey Badger

    Honey Badger Active Member

    I just ended up wiping the device and re-activating - the credit went through. I think I may have had a wi-fi issues the first time I activated the device, which may have caused the credit not to register correctly.
  12. El Juicebox

    El Juicebox New Member

    Having the same issue. Never registered under any other account and I meet the requirements it seem. Did this bring in the other extras too?
  13. Honey Badger

    Honey Badger Active Member

    Yeah, gave me the movie and the book in addition to the credit.
    stridermt2k and El Juicebox like this.
  14. shaneydroid

    shaneydroid Well-Known Member

  15. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    I've merged two of these into one main thread on the issue. I get the feeling we'll see lots of people with this issue over the next few weeks.
    jmar and Unforgiven like this.
  16. TauxiC

    TauxiC Well-Known Member

  17. GreyCelt

    GreyCelt Well-Known Member

    Has anyone else received their Nexus7 without the freebies installed? I got mine on Tuesday the 17th and there is no movie, no $25 credit in the Play store, no magazines, no books, no nothing!

    Do I have to do something to get these items? I've already emailed Nexus support but I haven't heard back from them yet.
  18. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Have you tried signing into the play store?
  19. GreyCelt

    GreyCelt Well-Known Member

    Yes, I have signed into the play store, I have signed into Gmail, and every Google app on here. I have downloaded apps and I have made sure every Google app is set to sync.

    I can't think of anything else that can be done!

    I went to the Play store on my PC and went to "My Orders & Settings" and there is nothing there except what I have downloaded myself.
  20. GreyCelt

    GreyCelt Well-Known Member

    Nevermind. I did a factory reset and all is good.
  21. scooby8611

    scooby8611 Member

    I got Nexus 7 from Staples. Anyhow, I can't find the movie and I can't get my credit card to register with the 25 dollar credit. I noticed that even though the nexus appeared brand new...sticky clear covering was still on the screen, but the seal was broken on the box. Could this mean that someone used the credit for this Nexus? I did a factory reset, but still can't get the freebies. I can't even find the movie on the store.
  22. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    I believe the credit is tied to our account when you activate an N7, so the unsealed box shouldn't be a problem there. Some folks in this thread have had success by doing a factory reset and re-registering their N7, so you could try that.`
  23. hal1

    hal1 Well-Known Member

    I already had a Google account. As soon as I logged in to my N7 i got the following email. I hope everyone else gets figured out

    Your $25.00 Google Play balance is ready to use.

    To get you started with your Nexus 7, we've given you $25.00 credit to spend on Google Play. Pick your favorite entertainment from more than 600,000 apps and games, millions of eBooks and songs, thousands of movies, and a growing selection of TV shows and magazines.
    Your Google Play balance is ready to use right away: to start, just go to the Google Play store and start shopping. During check out, choose "Google Play balance" as your payment method and enjoy your selection."
  24. martingroso

    martingroso Well-Known Member

    Hey guys,

    I just got the Nexus 7 a couple of hours ago. I have a question regarding the 25 bucks credit on Google play. Whenever I try to get the 25 dollars credit, I need to put my credit card information. Is there any way yo get the 25 dollars credit without having to give my credit card info?
  25. perfectstranger

    perfectstranger Well-Known Member

    Following up....
    Activated my N7 on Tuesday when it showed up. Got the free media and $10 wallet credit but no Play Store $25 credit. I did a factory reset this evening and received the $25 credit.

Share This Page