MMS and Internet APN Settings Hero 3 UK


  1. craigyb81

    craigyb81 New Member

    Hi all

    I've been trawling the threads here for a few weeks to see if I can find the answers I'm looking for but since I can't seem to put my finger on it I've decided to post a thread hoping that you can help me out.

    I've bought an unlocked HTC Hero a couple of months back to use with my 3 sim card. I've been able to get the internet on the phone no problem but cannot recieve or send mms. Now that 3 support the HTC Hero, I thought they'd be able to provide me with settings that would allow my phone to work but for some unknown reason the settings they have given me do not do the job. I've called them three times, now...

    Could someone on 3 in the UK and has working mms and internet fill in the following gaps for me so I know that I've filled in all the APN fields correctly?

    Name:
    APN:
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC:
    MMS Proxy:
    MMS Port:
    MMS Protocol:
    MCC:
    MNC:
    APN type

    Thanks for your help!

    Craig

    Advertisement
    :
  2. jonous101

    jonous101 Well-Known Member

    I also bought a sim free hero and had trouble with settings from 3, but after lots and lots of playing about, i've managed to get everything sorted and before u ask, 3 did not help me lol.

    Server: 3 MMS
    MMSC <not set>
    MMS Proxy: http://mms.um.three.uk:10021/mmsc
    MMS Port: 8799
    MMS protocol: WAP 2.0
    MCC: 234
    MNC: 20
    APN type: default

    My MMS works fine with the above x
  3. craigyb81

    craigyb81 New Member

    Hmmm still doesn't seem to work for some reason...

    Any chance you can copy and paste all of the fields from my first post and fill them in so I can cross check it all? It could be something in one of the other fields that i've got wrong.

    Cheers
  4. jonous101

    jonous101 Well-Known Member

    Name: 3
    APN: three.co.uk
    Proxy: <not set>
    Port: <not set>
    Username: <not set>
    Password: <not set>
    Server: 3 MMS
    MMSC: <not set>
    MMS proxy: http://mms.um.three.uk:10021/mmsc
    MMS port: 8799
    MMS protocol: WAP 2.0
    MCC: 234
    MNC: 20
    APN type: default

    Does that help?
  5. craigyb81

    craigyb81 New Member

    Hmm... still no joy! Do you have separate APNs for mms and for the internet, or do you do it all with the one APN?
  6. MartinS

    MartinS Well-Known Member

  7. craigyb81

    craigyb81 New Member

    Crikey... No idea why none of these seem to work. They all seem to be slightly different and I've tried them as they've been shown as well as various combinations... Frustrating.
  8. jonous101

    jonous101 Well-Known Member

    What i put in the above message is all i have - i even rang 3 and the settings they told me over the phone didn't work - it seems every hero is different?
  9. jsp_1983

    jsp_1983 Well-Known Member

    Here are the settings on my Hero, which was supplied by 3:

    Name: 3
    APN: three.co.uk
    Proxy: <not set>
    Port: <not set>
    Username: <not set>
    Password: <not set>
    Server: <not set>
    MMSC: http://mms.um.three.co.uk:10021/mmsc
    MMS Proxy: mms.three.co.uk
    MMS Port: 8799
    MMS Protocol: WAO 2.0
    MCC: 234
    MNC: 20
    APN type: <not set>
  10. Lettuce

    Lettuce Well-Known Member

    Recent new owner of HTC Hero from 3 / Three. 18 month contract with the
  11. Lettuce

    Lettuce Well-Known Member

    Quick update...

    Didn't do anything else after posting, but, received the pictures this morning, eventually. One was over 24 hours getting through, the others about 14 hours. Weird. Must have got stuck somewhere...

    Looks like I'm working all fine, if a bit delayed.

    Lettuce
  12. theartfullodger

    theartfullodger Well-Known Member

    Just had a weird problem, posting the solution in case anyone else meets it...

    Today I lost 3G... didn't think anything of it as I was driving about somewhere I didn't know...

    Got home, no 3G...

    Checked everything, nope, all seems OK, switched to 2G, switched off 2G.. still no go...

    went & drove under the local mast, 5 bars, switch the 'phone off/on, still nothing...

    Arrggggghhhhhhhhhhhh...

    Came home, thought "Could it be those pesky APN settings?? and went through them 1-by-1... no idea why as I hadn't changed it but... "APN Type" rather than blank was set to "-"... blanked it again, 3G pops up in the status bar...

    No idea how it happened...

    Cheers!

    Lodger
  13. bigfod

    bigfod Active Member

    I've never got my MMS working since getting my nexus one in Jan, no matter what I try. I also discovered over the weekend that I can phone whilst abroad, but not send SMS. Bizarre.
    I've given up on MMS. I just upload the pictures to facebook!
  14. Baggy

    Baggy Well-Known Member

    the settings i have for my unlocked G1 on 3 is:

    name: 3
    APN: three.co.uk
    MMSC: http://mms.um.three.co.uk:10021/mmsc
    MMS PROXY: mms.three.co.uk
    MMS PORT: 8799
    MMC: 234
    MNC: 20

    everything else as <not set>
  15. ChadJ

    ChadJ Member

    mcyates likes this.
  16. ImperialJohn

    ImperialJohn Well-Known Member

    Thanks for all the useful advice in this thread esp Jonous! Now that I think about it MMS has never worked for me on my Defy with 3 and I completely forgot that I would need to set all this up.

    When I first switched to three on my old Nokia N70 (from Voda) I actually called them up and recal that they sent me configurations within a text message to my handset! The first time they did this it didn't work so I had to call them back. They sent them again and I recal receiving this text and doing something and it installed and set up all the three settings and configurations on my phone for mobile internet, sms and mms!

    I think I need to do the same for my Defy as MMS is the one that doesn't work so the others must have been automatically set up (if they needed to be?).

    My email has always been a problem for outgoing and 3 have been most unhelpful and clueless pointing me back to my ISP who point me to 3 and so on. But it is definitely 3 I need the settings from for outgoing emails (smtp) while on the move and away from home WiFi network yet they tell me categorically that they have no outgoing email server which is a lie.

    John
Loading...

Share This Page