MMS and "invalid address"Support


Last Updated:

  1. chris.h

    chris.h Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    78
    Likes Received:
    0
    UPDATE: This is the proposed fix. Worked for me.

    ---------------------------------------------------------------------------------

    So when sending MMSs to different people I'm getting an "invalid address" error. I don't know if this is my VZW account or my phone.

    Me -> Girlfriend (also has a droid, on my family plan) "invalid address"
    Me -> My dad goes through
    Me -> Roommate "invalid address"
    Me -> VZW rep goes through
    VZW rep -> me goes through

    GF -> Me, says it worked on her end but I get nothing
    GF -> my dad "invalid address"
    GF -> Roommate, says it goes through but gets nothing
    VZW rep -> GF goes through

    All numbers are entered in the phone as "(XXX) XXX-XXXX" I also deleted her from my contacts and tried sending her the MMS to "XXXXXXXXXX" so I don't think it has to do with the formatting of the number in contacts.

    I spent 2.5 hours on the phone with Verizon, who had no idea and said they'd have to look into it and call me back...

    Anyone else have anything like this happen?
     

    Advertisement
  2. silverhack

    silverhack Active Member

    Joined:
    Nov 6, 2009
    Messages:
    41
    Likes Received:
    0
    How are you sending the message? Are you using your contacts list and selecting the option to send text, or are you in the messaging app and typing in the person's name? Or are you just putting in the phone number manually?

    Try putting the 1 before the area code, like: 1 (xxx) xxx-xxxx, or 1-xxx xxx-xxxx, or 1xxxxxxxxxx

    I've seen somewhere else that the 1 was needed for certain texts
     
  3. chris.h

    chris.h Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    78
    Likes Received:
    0
    I've tried all ways. From contacts, from messaging, and from messaging entering the number manually. Deleting the contact and entering the number manually and formatting the number on contacts differently. (with parens, with a 1, with just hyphens...)

    SMS works totally fine though, which makes me wonder if it's a problem on VZW's end since SMS and MMS use different networks (according to customer service).
     
  4. silverhack

    silverhack Active Member

    Joined:
    Nov 6, 2009
    Messages:
    41
    Likes Received:
    0
    yep, sounds like you've tried just about everything. Seems like it might be a problem with VW.
     
  5. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    i hadnt even tried mms yet, sure enough dont work for me
     
  6. chris.h

    chris.h Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    78
    Likes Received:
    0
    I'm not sure if Verizon changed something on my account but I couldn't send MMS when I was done with them yesterday and they still wouldn't send this morning. However in the past hour all MMS started working again with no problems... Hopefully this is something that just works itself out for people.
     
  7. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    hmm, hopefully it will just work itself out
     
  8. Robobandit

    Robobandit Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    53
    Likes Received:
    0
    I'm having the same issue..

    maybe I'll go by verizon tomorrow and see what's going on.

    edit:

    If you send mms to an e-mail address, it works.. I tried it with my hotmail address.. and I got an e-mail from vzwpix with the image.
     
  9. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    im still having the issue, called verizon today and they ended up opening a trouble ticket to get the issue resolved. If they are able to resolve and indicate what was done to fix ill post back (depending on if the issue fixes itself for everyone before hand)

    *edit*
    they did note that one bug thats been identified is sending mms outside of your local area code can cause this issue due to the messaging app replacing the area code with its local one - though this was not my problem it seems. But, its a known issue they are working on
     
  10. gregbridwell

    gregbridwell Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    60
    Likes Received:
    2

    I spent 2 hours in store with a rep on the phone with vzw service. Same error, same thing with some recipients ok and others not okay. after a factory reset some of the numbers i was trying to send a picture too started working BUT I am still having the issue with other numbers today after 3 factory resets. Saw somewhere that it was recommended to exchange the phone but I'd rather not. Needless to say you can do a factory reset if you like but from my experience in the last 12 hours it won't help and my recommendation is don't go through all that trouble! Man I hope they fix it and its that easy!

    P.S. the VZW rep in store was great! She stayed almost a full half hour after the store closed to continue helping me.
     
  11. fehhkk

    fehhkk Member

    Joined:
    Nov 9, 2009
    Messages:
    20
    Likes Received:
    0
    A bug was identified in the Android Contacts application, and there will soon be an Over The Air Fix to address this... hang in there
     
  12. gregbridwell

    gregbridwell Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    60
    Likes Received:
    2
    Was a time frame mentioned?
     
  13. justchilln

    justchilln Active Member

    Joined:
    Nov 6, 2009
    Messages:
    26
    Likes Received:
    0
    Yeah getting thhe same error here, sms works but when I try to send mms it says invalid address
     
  14. fehhkk

    fehhkk Member

    Joined:
    Nov 9, 2009
    Messages:
    20
    Likes Received:
    0
    I heard potentially first week of December, along with a bunch of other OS fixes to bugs.
     
  15. gregbridwell

    gregbridwell Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    60
    Likes Received:
    2
    It's gonna suck having to wait!
     
  16. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    just as an update they closed my ticket stating that its been resolved based on the following

    the rep that called explained that they have had a lot of tickets on this issue and in every case its been resolved by deleting a ll text/mms in the messaging app. then going to the contacts and removing all parentheses "()" in the numbers. Last steps are to reboot the phone and text again to these new numbers that dont contain the "()" in the number.

    I explained to him that im able to send a mms to my brother who is on sprint which contains parentheses in the number. Also explained that another friend of mine who is on sprint im unable to. Ive also tried to delete all parentheses (but at that time I didnt reboot - im going to try this next) with no luck.

    Then the guy explained that this only seems to be an issue with contacts added through google contacts which makes no sense being either on the phone itself or or google contacts its the *same* number on both once it syncs

    seems they dont know what the problem is and they are taking the shotgun approach... I may need to call and reopen this case once I test the modify/reboot/text as he explained to do.
     
  17. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    ok so odd enough after following the steps outlined above the issue was still there - called back and he asked me to try again so he could monitor my texts out to see what was going on. this time the mms went through (without the parentheses).

    On my brothers number, in the contacts it shows the parentheses but sending a mms to him on the servers side of things they see no parentheses in the number which is why it works sending to him. He has no idea how that works, but does show that its something to do with the parentheses (at least for me, just seems inconsistent).

    so if you are still having an issue try the following

    1. delete all SMS/mms messages from the messaging app
    2. edit the contact info so it does not have parentheses (the dashes will still show)
    3. reboot the phone (power off/on)
    4. send out a mms to this updated number
    may or may not work - didnt work for me the first time, but all times after that its working now... odd

    he did mention that they have identified an issue and it will be part of the software update slated for December (though i hope they push this out sooner)
     
  18. x0SiN0x

    x0SiN0x Active Member

    Joined:
    Nov 6, 2009
    Messages:
    25
    Likes Received:
    0
    should be my last update to this as my issues seem to have been resolved (except to one number... figures)

    brought the phone into a tech at the store and he performed the following on the phone which seems to have fixed my problem on all but one contact that ive tested.

    he went through the following programming options (dialing/calling the following)
    *18
    *73
    #832

    after this i guess it resets the programming on the phone and all seemed well.
     
  19. digitard

    digitard Well-Known Member

    Joined:
    Nov 2, 2009
    Messages:
    75
    Likes Received:
    0
    I don't know what #832 does, but the other 2 didn't help.

    *18 enables "Follow me Roaming". Nothing major. If you're outside your home area and it's disabled (I think its *19 not sure) you can't use your phone. Reps have been trying that for years as a "fix" for everything.

    *73 just disables any transfer options you have (No Answer or Immediate Unconditional). So if you dialed *71+# (no answer transfer) or *72+# (unconditional) it would disable it.

    I will say, though, I have no idea what #832 does to be honest.
     
  20. DevilDroid

    DevilDroid Member

    Joined:
    Nov 13, 2009
    Messages:
    5
    Likes Received:
    0

    Hi,
    Nope didn't help at all... followed ALL the above suggestions in this post and I'm still experiencing the "Invalid Address" when sending MMS to certain contacts.....I rather not call a VZW Rep, as they are dumber than a doornail...seriously, the troubleshooting approaches that they take are ridiculous....sounds like they are reading from a 1992 troubleshooting manual!! :p

    Well, hope someone can find a fix to this....otherwise I guess we are waiting for the Dec 11th OTA update...and even then we don't know if the fix for this issue will be included!! >:-O :mad:
     
  21. fehhkk

    fehhkk Member

    Joined:
    Nov 9, 2009
    Messages:
    20
    Likes Received:
    0
    #832 is just a test call recording, Verizon reps instruct you to call this number, to prove that you can originate calls.

    Back to the topic, I had an engineering sample that had the MMS issue. I got my actual production Droid handset, and now for some reason, I don't seem to have the ( ) issue anymore.

    I also have another engineering sample Droid, that has the upcoming 2.1 Eclair firmware, and it doesn't have the ( ) MMS issue apparently... so that's good news at least.
     
  22. gregbridwell

    gregbridwell Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    60
    Likes Received:
    2
    I can confirm that taking out the ( )'s in my contacts and deleting all my messages from the phone and then restarting helped some at first but didn't fix everything. Some #'s that I couldn't send to before have been able to receive my MMS's. Other numbers that failed no longer give me the invalid address error but my delivery report seems to stay stuck in "Pending"....I seem to be able to send to contacts that have the same area code as my phone number on the Droid. I am also trying from an area that is in the 312 area code currently but my phone's # is a 630 area code....Maybe I will try while I am physically located in my local 630 area and see if it lets me send them then...Is that logically or am I just making stuff up in my head?

    I admit I am just taking the forum's tips and running with them so if anyone has anymore ideas I would love to find a consistent "bandaid" until the December OTA update.
     
  23. Ainvar

    Ainvar Active Member

    Joined:
    Nov 9, 2009
    Messages:
    31
    Likes Received:
    0
    This fixed my problem also.

    I exported the contacts from gmail to a google.csv file and then did a mass find & replace on all cells with phone numbers.

    Deleted all contacts from gmail and then did a reimport.

    Deleted all SMS/MMS from phone

    Rebooted phone

    Now able to send MMS to all people i have tried to send to so far
     
  24. gregbridwell

    gregbridwell Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    60
    Likes Received:
    2
    Thanks Ainvar. Knock on wood, this seems to be working for me as well right now.
     
  25. Ainvar

    Ainvar Active Member

    Joined:
    Nov 9, 2009
    Messages:
    31
    Likes Received:
    0
    Cool! I am glad it worked out for you also.

    I just took all the great info I found in this thread and put it into something workable for me and thought I would put my variation on here also.

    See my droid took it one step further on this issue.

    Every time I would send an MMS msg to a group of friends it would send the actual pic to someone else who had the same number but a different area code here in Northern VA.

    The lady it was sending this umm said MMS messages too did not find the humor that my friends, friends wives, and my wife found. So after calling VZW and researching I got it all fixed. I am glad it is fixed now.


    One thing I should add is when you do a mass edit please make sure you do not mess or edit the top line of the csv file or when you do an import it will not go in the right fields.

    When I did a replace I used the following parameters (right word?)

    "(" replace with nothing
    ") " replace with nothing
    "-" replace with nothing
    "." replace with nothing some DOD and other GOV vcf files you get may have the number formatting using "." instead of "-"

    Now I am working on how to get the address for work and home formatted to where they fill in the fields in my contacts on my droid and use the right fields when I do a import/export.

    I am really OCD anal about how my contacts look and not being able to use the ()- in formatting my numbers kind of drives me crazy. Now that I know about the address portion of the contacts I really don't want to do it all by hand.
     

Share This Page

Loading...