MMS on Vodafone


Last Updated:

  1. robbiec

    robbiec Member This Topic's Starter

    Joined:
    Aug 14, 2009
    Messages:
    23
    Likes Received:
    0
    Hey all,

    I'm having problems sending MMS messages, I can recieve them OK.

    None of the MMS related settings are in place and Vodafone say they can't send the settings direct to the phone as they don't officially support the Hero. They did however email me the settings for the Magic which I've tried but they don't work.

    When I attempt to send an MMS to myself (for testing) I get two messages the first is blank and then the second has the link and password to view the pic online but when I go in to the message i get an error that says:

    "sorry! The application messages (process com.android.mms) has stopped unexpectedly. Please try again."

    Anyone else got this problem? The Magic settings I was sent are:

    ----------
    HTC Magic
    Setting up WAP & MMS
    1.Press the Menu button
    2.Tap Settings
    3.Tap Wireless Controls
    4.Tap Mobile Networks
    5.Tap Access Point Names
    6.Press the Menu key
    7.Tap New APN
    8.Tap Name and enter a name e.g. Vodafone WAP and tap OK
    9.Tap APN and enter
    for Pay monthly customers: wap.vodafone.co.uk
    for Pay as you go customers: pp.vodafone.co.uk
    10.Tap Username and enter wap and tap OK
    11.Tap Password and enter wap and tap OK
    12.Tap MMSC and enter http://mms.vodafone.co.uk/servlets/mms and tap OK
    13.Tap MMS Proxy and enter 212.183.137.012 and tap OK
    14.Tap MMS Port and enter 8799 and tap OK
    15.Tap MCC and enter 234 and tap OK
    16.Tap MNC and enter 15 and tap OK
    17.Press the Menu key
    18.Press Save
    ----------

    Any help much appreciated...

    Regards,
    Rob.
     

    Advertisement
  2. tone-fu

    tone-fu New Member

    Joined:
    Aug 16, 2009
    Messages:
    4
    Likes Received:
    0
    Here are the settings I personally used:

    1. Press the Menu button
    2. Tap Settings
    3. Tap Wireless Controls
    4. Tap Mobile Networks
    5. Tap Access Point Names
    6. Press the Menu key
    7. Tap New APN
    8. Tap Name and enter a name e.g. Vodafone WAP and tap OK
    9. Tap APN and enter

    for Pay monthly customers: wap.vodafone.co.uk
    for Pay as you go customers: pp.vodafone.co.uk
    10. Tap Username and enter wap and tap OK
    11. Tap Password and enter wap and tap OK
    12. Tap MMSC and enter http://mms.vodafone.co.uk and tap OK
    13. Tap MMS Proxy and enter 212.183.137.012 and tap OK
    14. Tap MMS Port and enter 8799 and tap OK
    15. Tap MCC and enter 234 and tap OK
    16. Tap MNC and enter15 and tap OK
    17. Press the Menu key
    18. Press Save

    Proxy, Port and APN Type shouldn't be set at all, they should say <Not Set>
     
  3. cheggerspop

    cheggerspop Well-Known Member

    Joined:
    Aug 16, 2009
    Messages:
    171
    Likes Received:
    6
    I'm also having a problem with MMS on the HTC Magic, which is on a Vodafone contract. Vodafone also forwarded the settings robbiec has posted, which don't work. I've also tried the amended ones from tone-fu, but they're also not working!?! If MMS are sent to the mobile, they can only be viewed by clicking and link and entering a password. If anyone can offer any assistance it would be greatly appreciated. Chegs.
     
  4. tone-fu

    tone-fu New Member

    Joined:
    Aug 16, 2009
    Messages:
    4
    Likes Received:
    0

    That's odd. It took me a good few hours to get the settings right and they've been thoroughly tested (both send and receive work perfectly).

    I presume you are in the U.K.?
     
  5. cheggerspop

    cheggerspop Well-Known Member

    Joined:
    Aug 16, 2009
    Messages:
    171
    Likes Received:
    6

    Yep, I'm in the UK and wondering if some other setting is causing the problem?

    The unit came with what would appear to be correct WAP setting already installed. By this I mean they are the same setting that Vodafone forwarded for manual inputting. I did however create a new WAP profile and that has the amended setting that you offered and I've confirm the new profile is selected.

    I wonder if it's worth deleting both profiles and starting from scratch?


    Chegs.
     
  6. robbiec

    robbiec Member This Topic's Starter

    Joined:
    Aug 14, 2009
    Messages:
    23
    Likes Received:
    0
    No this does't make any difference for me either :mad:

    Does anyone else have MMS working on Vodafone and happy to share their settings?!


    Thanks,
    Rob.
     
  7. tone-fu

    tone-fu New Member

    Joined:
    Aug 16, 2009
    Messages:
    4
    Likes Received:
    0
    I came across a few settings on blogs and the like, none of them worked for me. When creating a new APN I would put the details in, press save and then go back to the selection page where it wouldn't have even saved it.

    I just spent time going through settings found on the web, ones given to me by Vodafone and mixed the two together until I got it to work. Here is my APN, as it is (and I can send and receive MMS, browse the web and do everything apart from use Peep to Tweet):

    Name - Vodafone WAP
    APN - wap.vodafone.co.uk
    Proxy - Not Set
    Port - Not Set
    Username - wap
    Password - wap
    Server - Not Set
    MMSC - http://mms.vodafone.co.uk
    MMS Proxy - 212.183.137.012
    MMS Port - 8799
    MMS Protocol - WAP 2.0
    MCC - 234
    MNC - 15
    APN Type - Not Set
     
  8. cheggerspop

    cheggerspop Well-Known Member

    Joined:
    Aug 16, 2009
    Messages:
    171
    Likes Received:
    6
    Damn, this is soooo frustrating, still can't find any settings that work!?!

    Vodafone are about as much use a a chocolate tea pot, so not sure which way to turn now :confused:
     
  9. trick202

    trick202 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    949
    Likes Received:
    49
    I can offer you only a theory I'm afraid.

    Back when I had the 3G iPhone (before the 3.0 update), the phone could not get MMS messages (no iphone could in the UK without JB). All you got was the sms with link and password.
    Then came an app from Cydia (If I recall) that allowed you to see MMS messages in the traditional way.
    However, you had to get the guys at O2 HQ to activate the setting on their side that acknowledged you had a handset that could accept MMS - otherwise you just got the sms/code/link.
    Some said that the setting was already activated, and that they had to convince the 02 guy to deactivate and reactivate.

    I know this sounds like a real long shot, but may just be the answer.
    If you are getting an SMS with code/link, then it's a setting on the Vodafone side that's causing that. Your handset doesn't decide how to handle the message by itself.
     
  10. robbiec

    robbiec Member This Topic's Starter

    Joined:
    Aug 14, 2009
    Messages:
    23
    Likes Received:
    0
    Yep.. still not working for me either.

    There's another thread on this on the Vodafone forums here: forum.vodafone.co.uk/index.php?showtopic=33165

    Maybe worth posting there too to try and get them to take the problem more seriously!
     
  11. cheggerspop

    cheggerspop Well-Known Member

    Joined:
    Aug 16, 2009
    Messages:
    171
    Likes Received:
    6
    OK, I've just got myself a HTC Hero on Vodafone via mobilephonesdirect and it appears to have come with all the necessary text/wap/MMS setting pre-installed!?!

    I know the Magic and Hero are different mobiles, but thought I'd add the settings on my unit, as this might give the clever people who know about this sort of stuff something to work from.

    Interestingly there are two sets of APN data inputted, with the top one being checked -

    Name - Vodafone Post-pay ISP
    APN - internet
    Proxy - <Not set>
    Port - <Not set>
    Username - web
    Password - web
    Server - <Not set>
    MMSC - <Not set>
    MMS proxy - <Not set>
    MMS port - <Not set>
    MMS protocol - WAP 2.0
    MCC - 234
    MNC - 15
    APN type - default

    Name - Vodafone MMS
    APN - wap.vodafone.co.uk
    Proxy - <Not set>
    Port - <Not set>
    Username - wap
    Password - wap
    Server - <Not set>
    MMSC - http://mms.vodafone.co.uk/servlets/mms
    MMS proxy - 212.183.137.12
    MMS port - 8799
    MMS protocol - WAP 2.0
    MCC - 234
    MNC - 15
    APN type - mms

    The one main problem for Magic owners is there's no "MMS protocol" option on these units.

    But.......and there's always a but.....I've tried putting the above details into my missus's Magic and it's STILL playing silly buggers and not sending/receiving MMS :mad:
     
  12. Carl C

    Carl C Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,062
    Likes Received:
    38
    Guys and Girls I beleive I have the Resolution! :D

    1) All Vodafone Numbers MMS is deactivated At network level by default , you need to Ring customer services up on 191 Free of charge and ask them to Activate it ;)

    **Please Allow up to 24 hours for the Activation to fully take effect

    2) Just a heads up! Vodafone customers currently with numbers beginning with 0758 are having difficulties sending and receiving MMS , Vodafone engineers are working on it however their is no time scale as to when it will be fixed.

    Carl C :D

    P.S. If your a vodafone UK customer did you know they have MMS bundles , 50 MMS for
     
  13. cheggerspop

    cheggerspop Well-Known Member

    Joined:
    Aug 16, 2009
    Messages:
    171
    Likes Received:
    6
    Adding to Carl C's comments, I've just become aware that the sending of MMS messages in not included in Vodafone data packages and you get charged about 35p for each on you send!?! I've sent about 6 or 7 since getting my Hero, so that's two quid down the drain!!!

    Not impressed :(
     
  14. Carl C

    Carl C Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,062
    Likes Received:
    38
    Hey Cheggerspop :)

    Just to Make you guys aware Vodafone UK customers who are on contract can have an MMS bundle added to their account:

    50 MMS for
     
  15. darrenmc168

    darrenmc168 Member

    Joined:
    Aug 31, 2009
    Messages:
    5
    Likes Received:
    0
    Dont know if this will help but i was having the same problem, and it appeared to be the lack of a 3g signal when i selected "use 2g networks only" it got and displayed the mms immediately.

    Hope this may help some of you, coz i know its frustrating
    :)
     
  16. BasthePub

    BasthePub New Member

    Joined:
    Dec 13, 2009
    Messages:
    1
    Likes Received:
    0
    Hi.

    I bought a sim-free Samsung Galaxy, and have spent ages scouring the web for clues to setting up mms. I found a final idea here, and now it works. I don't know how similar your HTCs are, but what I have is very similar to an earlier reply, so it might work for you. Browser and mms are combined in a single APN, and the settings I've used are:

    Name - Vodafone WAP
    APN - wap.vodafone.co.uk
    Proxy - Not Set
    Port - Not Set
    Username - web
    Password - web
    Server - Not Set
    MMSC - http://mms.vodafone.co.uk/servlets/mms/
    MMS Proxy - 212.183.137.12
    MMS Port - 8799
    MCC - 234
    MNC - 15
    APN Type - internet + mms
    Authentication Type - Normal(PAP)

    I hope this helps!
     
  17. crish

    crish Active Member

    Joined:
    Oct 27, 2009
    Messages:
    25
    Likes Received:
    1
    Did the people who couldnt use MMS ever get it resolved?
    I still cant send or recieve and i've tried all the above.
    Help!!
    Thanks
    Chris
     

Share This Page

Loading...