MMS Picture messaging fails


Last Updated:

  1. bthoward

    bthoward Well-Known Member This Topic's Starter

    Joined:
    Nov 7, 2009
    Messages:
    243
    Likes Received:
    1
    So I'm having issues sending picture messages using the messaging app. I get an error saying that I typed in an invalid address. I think that this is because its not resizing the images that I try to send.... When i use Handcent all works like it is supposed to but not when I use the default messaging application.
     

    Advertisement
  2. chris.h

    chris.h Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    78
    Likes Received:
    0
  3. Robobandit

    Robobandit Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    53
    Likes Received:
    0
    Check the phone numbers in your contacts. If you have them set to area code + phone number.. add a 1 in front of the area code so they look like this 1-XXX-XXX-XXXX with or without dashes.

    I had just the area code and phone number on mine, and was getting "invalid address" What it does is try to send mms messages to 1 + area code + phone number + area code + phone number

    so Instead of it sending to 18888888888, it is trying to send it to 188888888888888888888

    When I added a 1 in front of the area code in my contacts list, it sends mms properly.
     
  4. Teezy

    Teezy Well-Known Member

    Joined:
    Nov 14, 2009
    Messages:
    71
    Likes Received:
    0
    ah crap, so i'm gonna have to go through all my contacts and add a 1 in front of area code. /shake fist. is there no option that automatically does this like BB's do?
     
  5. chris.h

    chris.h Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    78
    Likes Received:
    0
    All of mine work without a 1 in front of the number as long as there are no parenthesis. e.g., XXX-XXX-XXXX.

    You can export to a CSV file from gmail and do a find and replace in a text editor to change, for example, ") " to "-" and "(" to "".
     
  6. Robobandit

    Robobandit Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    53
    Likes Received:
    0
    The problem I was having was that it was adding a 1 and the whole phone number including area code again. instead of just adding a 1 in front of the area code.

    However, it was only having trouble with mms messages doing this. When I had facebook integrated into my contacts, I only had trouble with sending mms.. when I removed the facebook integration from my contacts list, some people weren't getting my texts either until I added a 1 in front of the phone number in my contacts list, this also corrected the mms problem for me.
     

Share This Page

Loading...