MMS problems for Desire on O2

Discussion in 'Android Devices' started by taffysaint, May 2, 2010.

  1. taffysaint

    taffysaint Member
    5

    May 2, 2010
    5
    0
    5
    Hi again,

    I can't get my Desire to send picture messages, I've trawled the web for settings and once of you has posted a helpful response but I still can't seem to get it working. Part of the problem is that O2 have no details on the handset yet (got it from CPW) so aren't brilliantly helpful.

    Going into the handset under Settings>Wireless & Networks>Mobile Networks>Access Point Names - I get two options

    1) O2 Mobile Web - this has a green 'Active' blob next to it, I messed with these settings and broke it temporarily but now working again

    2) O2 MMS Prepay - I've changed this to match what should be the contract settings - I have the below set up but with no success:

    Name: O2 MMS
    APN: wap.o2.co.uk
    Proxy:<Not set>
    Port: <Not set>
    Username:eek:2wap
    password:password
    Server: <Not set>
    MMSC:http://mmsc.mmc.o2.co.uk:8002
    MMS proxy:193.113.200.195
    MMS port: 9201 (or 8080)
    MCC: 234
    MNC: 10
    Authentication Type:<Not set> (only have options for 'None';'CHAP', 'PAP' 'CHAP or PAP')
    APN Type: mms

    Anything on there leap at you as to what I might be doing wrong? Thanks in advance.
     

    Advertisement
  2. WozzaX

    WozzaX Well-Known Member
    16

    Apr 2, 2010
    99
    6
    16
    Setting look the same as mine.

    I would reset your phone to factory and choose O2 Prepay when asked at startup.

    Give that a go.
     
  3. WozzaX

    WozzaX Well-Known Member
    16

    Apr 2, 2010
    99
    6
    16
  4. lekky

    lekky Lover
    VIP Member
    313

    Guess you've tried turning the phone on and off again. Maybe call O2 directly and just ask for their MMS settings?

    EDIT: Wozza got in a reply, don't do a factory reset!!!!!!!
     
  5. taffysaint

    taffysaint Member
    5

    May 2, 2010
    5
    0
    5
    Isn't prepay Pay as you Go?
     
  6. WozzaX

    WozzaX Well-Known Member
    16

    Apr 2, 2010
    99
    6
    16
    LOL, yeah, i had problems with my Desire auto choosing Prepay when I typed Postpay.

    On my pc now.

    Did you try changing that url from my post above?
     
  7. silvershadow68

    25

    Apr 26, 2010
    22
    0
    25
    Male
    Sales
    Scotland

    Has anybody had any luck with picture msg yet.

    I am on the simplicity o2 sim, and have used the setting above
    (after modifying the mmc.o2 > mms.o2).

    I cant send picture msg, but i can receive them, using the above settings.

    set up using postpay

    Stumped
     
  8. stringent

    stringent Well-Known Member
    26

    I have had two picture messages not been recieved. However since then the ones sent have. Both were to a T-Mobile network. However my dad sent me one from his iPhone to me and I got it fine. He is on O2. I chose the O2 PostPay option when setting my phone up.

    I might try sending a few tomorrow and see if it works. I'm on a normal contract. However I think if you have just started a new contract and SIM ring O2 up and get them to activate MMS and mobile Internet on your account. I have had to do this when changing SIM cards.
     
  9. silvershadow68

    25

    Apr 26, 2010
    22
    0
    25
    Male
    Sales
    Scotland
    So,
    i have just been told by the people i have sent pictures msg too, that they received them ok,
    Thats all good, but the problem is, when you click on the msg in my sms application, its still showing as a pending msg, with the little clock next to the piccy.

    Very confusing.
    I have sent an email to o2 for an explanation
     
  10. Sypher

    Sypher Well-Known Member
    26

    Apr 25, 2010
    50
    1
    26
    You can try sending ACTIVE to 2020. O2 will txt you back the settings you need.
     
  11. dunbad

    dunbad Well-Known Member
    38

    Apr 22, 2010
    117
    11
    38
    I can send and recieve mms fine with o2. Your settings are different from mine, of the top of my head, I know that I have 8080 on mms port. Sod it, here's what I got.
    Name o2 MMS
    apn wap.o2.co.uk
    proxy http://wap.o2.co.uk
    port9201
    username o2wap
    password password
    server (as you got for mmsc)
    mmsc (same as what you got)
    mms proxy (same as what you got)
    mms port 8080
    mms protocol wap 2.0
    the rest is the same as you got

    I've also got o2 mobile web apn
    and the second apn I got is o2mms postpay
    so I have 3 apns
    text to 2020 didn't work for me as I got an iPhone sim and they wouldn't allow it! So I had to hunt the settings down long and hard I hasten to add. But nows all good. Have you sent your self an mms?
    Let me know if it works for you and I'll know if I can delete the third apn that I might not need!
     
  12. silvershadow68

    25

    Apr 26, 2010
    22
    0
    25
    Male
    Sales
    Scotland


    Yep,

    I put in the additional information, and it worked ok, received the mms ok.

    But, same as before.

    when you send a picture msg to yourself, or anybody else, they seem to get the msg ok, but when I go into the the message i have sent, it shows the little clock, in the rh corner, and when you highlight the messgage and view the report, it tells you the message is still *pending*, altho the recipient has received it.

    This is what i get anyhow.

    I managed to phone o2, qnd i was told, i may have a faulty sim.

    UTTER RUBBISH.

    I got the usual, take out your sim, take out your battery, wipe your sim with a small damp cloth.

    Nothing the told me, made the slightest bit off difference, but i could have told them that in the first place.

    I have used this sim, in 4 other phones, with no problem at all.

    And when o2, doesnt have the answer, what you get told is.

    SORRY, WE CURRENTLY DONT SUPPORT THAT MODEL AT THE MOMENT.

    DOH !!!!
     
  13. chris100575

    chris100575 Well-Known Member
    53

    May 2, 2010
    130
    25
    53
    IT Tech
    North Cumbria
    Taffysaint: I have the same settings as you except it's called O2 MMS Postpay, the MMSC address is http://mmsc.mms.o2.co.uk:8002, and the MMS port is 8080.

    I'm on a standard O2 contract and bought the phone unlocked from CPW, it picked up the settings from my SIM and just works.
     
  14. stringent

    stringent Well-Known Member
    26

    What phones do they have? Not all phones send back a report on O2 like the iPhone.
     
  15. srem

    srem New Member
    5

    Apr 28, 2010
    2
    0
    5
    i too get a pending icon on the message but the pics seem to get there. strange
     
  16. silvershadow68

    25

    Apr 26, 2010
    22
    0
    25
    Male
    Sales
    Scotland
    Yep,

    all my picture msg have the pending icon on them still.

    maybe this will be sorted for me, when O2 finally support this model
     
  17. silvershadow68

    25

    Apr 26, 2010
    22
    0
    25
    Male
    Sales
    Scotland
    Anything from The iphone, Nokia 95, samsung jet & the htc desire
     
Tags:

Share This Page

Loading...