MMS settings on O2?


Last Updated:

  1. spiderbundy

    spiderbundy Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    16
    Likes Received:
    1
    Hi guys,

    Has anyone who bought a sim free Desire and inserted an O2 sim manage to get the settings for MMS yet? Phone is working great on HSPA,3G and EDGE and wifi....but i cant get the MMS settings from O2 as they don't support it yet.
    Tried to manually set it up with some settings found via google but no luck.

    Cheers,

    Gaz
     

    Advertisement
  2. mobilephone2003

    mobilephone2003 Member

    Joined:
    Apr 1, 2010
    Messages:
    9
    Likes Received:
    0
    My HTC Desire with O2 PAYG SIM looks to have set itself up, but don't know if it works, havent tried it.

    Here are my settings:

    APN: payandgo.o2.co.uk
    Proxy: <not set>
    Port: <not set>
    Username: payandgo
    Password: password
    Server: <not set>
    MMSC: http://mmsc.mms.o2.co.uk:8002
    MMS Proxy: 193.113.200.195
    MMS port: 8080
    MMS protocol: WAP 2.0
    MCC: 234
    MNC: 10
    Authentication type: <not set>
    APN type: mms


    These settings look similar to my iPhone 3GS, so no reason why they shouldnt work.
     
  3. spiderbundy

    spiderbundy Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    16
    Likes Received:
    1
    Thanks for the reply,

    Mine is a contract sim....the apn settings for pay and go are already on the phone....i input manually the settings almost identical to yours....except the APN is wap.o2.co.uk and the user name is O2wap. I'm baffled! :confused:
     
  4. loungelizard

    loungelizard Member

    Joined:
    Mar 20, 2010
    Messages:
    12
    Likes Received:
    1
    I haven't got my Desire yet so haven't tried them but here are some settings for the Hero on O2 contract I found somewhere else:

    1. Go into your APN settings and delete everything there an reboot your phone.

    2. Back into APN and input these;

    NAME: O2 UK Postpay
    APN: wap.o2.co.uk
    PROXY: <Not set>
    PORT: <Not set>
    USERNAME: O2wap
    PASSWORD: password
    SERVER: http://mmsc.mms.o2.co.uk:8002
    MMSC: http://mmsc.mms.o2.co.uk:8002
    MMS: PROXY 193.113.200.195
    MMS: PORT 8080
    MCC: 234
    MNC: 10
    APN TYPE: <Not set>

    Don't forget to select 'Menu' and select 'Save' before exiting out of the settings.

    3. Now reboot phone and test. Don't forget to have 'Mobile Network' enabled to use MMS.
     
  5. Jaylozza

    Jaylozza New Member

    Joined:
    Jul 20, 2011
    Messages:
    1
    Likes Received:
    0
    i have a htc wildfire and would like mms and internet settings please help?
     
  6. disco

    disco Member

    Joined:
    Jul 10, 2010
    Messages:
    21
    Likes Received:
    0
    hi, i am on o2 sim only contract and had this problem i.e could not send or recieve picture msgs so phoned o2 and they gave me the settings which did not work.I then went into settings >mobile networks>acess point names>pressed menu>pressed reset to default>highlighted o2 mms >removed battery>switched back on>sent myself a picture msgs and its now working .hope this works for you and i hope i have explained properly i am not into technology?KRO
     

Share This Page

Loading...