MMS Settings.General

  1. syedharis

    syedharis New Member

    "Message cannot be downloaded. Check MMS settings". Can anyone help please?

    Sony Xperia X10

  2. beau420

    beau420 Well-Known Member

    Hit the Menu button (left button) and open Settings->Wireless->Mobile->APN

    Are the settings there for your service provider?

    If not, you need that information.

    Who is your service provider? Or do a google search for mms settings and your cell provider and you should be able to fill in the information manually.
  3. Merolas

    Merolas Well-Known Member

    as posted before...
    Rogers APN Settings
    Go to Settings -> Wireless Controls -> Mobile Networks -> Access Point Names
    Add a new APN.
    Lastly, make sure there are no extra spaces after entering any of these values, else your 3G won’t work.
    Name: Rogers Internet
    APN: rogers-core-appl1.apn
    Proxy: Not Set
    Port: Not Set
    Username: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: http ://
    MMS proxy:
    MMS port: 80
    MCC: 302
    MNC: 720
    APN Type: Not Set
    Don’t forget to Save the new APN by pressing the “menu” button!

Share This Page