MMS & uploading pics via text on rooted S3 doesn't send: carrier "MobiPCS"Support

Last Updated:

  1. boofay

    boofay New Member

    I have an S3 rooted recently by a contact who mentioned that at the moment there isn't an app/patch which allows one to send a text w/a pic attach. This is the Verizon S3 LTE/4G SCH 1535 which is now being used on the carrier MobiPCS in the Hawaiian Islands. I can send receive data, make calls, search the internet but texting is limited to about 40ish characters per. I can receive text/pics. I have SMS PRO and have tried Handcent SMS but still can't send pics. Is it possible to use the other text apps w/o Sammy's default text app? Forgive my ignorance, I'm not a developer and am on a journey here to resolve this. I've been using the S3 for about a week now and it's a terrific device even on 3G.

    Mobi's own android phones do send/receive text/pics.

    Any assistance is greatly appreciated.

  2. CDPlant

    CDPlant Well-Known Member

    Moved to Galaxy S3 forum :)
  3. UserName872

    UserName872 Well-Known Member

    Make sure you have the APN for your carrier for MMS on your device. Easiest it to call up your carrier or visit their support page for the APN you need. It can be added under settings>more>mobile networks>access point names.
  4. boofay

    boofay New Member


    Okay everyone, case resolved for 2 issues with the VZW S3 thanks to a techie who replied to my post on Craigslist. I was given the correct leads from several members on the Samsung Galaxy S3 forum which I will update there as well but there was no clarity as to how to specifically pinpoint the method to resolving these issues. Here it is. Install GO SMS Pro....Open GO SMS Pro/click on text pad-pencil icon top right to create a new text/click on hand icon with the word "GO" at bottom of screen/click on pictures/video/capture picture or which ever of those icons suits your needs.

    Here is the next issue that was resolved to split large messages. Open GO SMS Pro/click on the boxes icon top left corner and it will open to a functions directory/click on settings. You'll see send messages, once you are there put a check mark in the box that says "Split large messages". All is good now! ​


Share This Page