mobile doesn't charge. red LED blinks, but nothingSupport


Last Updated: 2012-01-20 18:28:36
  1. mike_11

    mike_11 Active Member

    Everything was fine two days ago. I then charged the mobile as usual via a usb cable, but the red LED just blinked but it never got charged.

    Since then I've taken out the battery, reinstalled it, tried different usb ports, nothing works.
    It either switches from a blinking red to solid red for a short time, and then back to a blinking led, but never goes orange or green.

    The mobile is about 8 months in use, so pretty new.

    Any suggestions how to fix this?

    TIA,
    Mike

    Advertisement
  2. gsdsarah

    gsdsarah New Member

    Hi Mike,
    Have the same phone, had the same problems and since the X10 mini pro's battery doesn't last that long, it's a big problem huh?
    There are a few things you can try which I'm doing write now:
    1. Change charger (you can easily order one for a good price on ebay)
    OR
    2. Switch the phone off, and while it's off put it for charging. It will switch on in a minute, and show you the charging screen. Don't mess around with it by pressing the on/off button just let it charge.
    OR
    3. Hold the charger at an angle! Put a highlighter for example, under the usb cable where it meets your phone.
    Hope it helps!
  3. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Please do not hold the charger at an angle. This can apply undue stress to the connection and end up physically damaging the main board leaving you with an expensive paper weight.

    In your case the first thing I would advise doing is leave it on for charge for at least 2.5 hours to see if you get a change. If you do not then run the Update Service to reload the firmware (don't worry this is done with the phone powered off)

    http://dl-www.sonyericsson.com/cws/download/1/110/61/1323075336/Update_Service_Setup-2.11.12.5.exe
  4. mike_11

    mike_11 Active Member

    Sam-SE:
    I've installed the SE software, followed the instructions, namely, pressed the back button while connecting the micro-usb cable. nothing happens.

    I keep getting the screen animation showing how to connect the phone, but the software doesn't show the phone has been detected. The red led on the phone blinks while it's connected with the usb cable.

    Please advice.
  5. mike_11

    mike_11 Active Member

    I've installed the SE utility, but it doesn't progress beyond the screen which shows how to connect the mobile to the PC, so it looks like it doesn't recognize the mobile when I connect it.

    To clarify, I haven't rooted the mobile or installed a new a rom etc.

    suggestions anyone?

    TIA,
    Mike.
  6. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    The link to the software posted above by Sam is the Update Service, since it didn't work why don't you go ahead and try the Repair Phone option on PC Companion to see if that helps.

Share This Page